Getting rough top layers with Hexagon hotend

I have been trying different settings, but I always get pretty rough top layers using the new hexagon hotend in my TAZ4.
Have tried with different temperature and infills, without success.
Does anyone have noticed this effect using the new hotend ?


What slicer? With S3D the top layers are usually printed slower for detail. I’m not sure if Cura or Slic3r compensate…

Regardless, try adjusting the print speeds lower for more accuracy. Of course the drawbacks are a longer print time.

Did you recalibrate your Esteps? If not then you are probably extruding the wrong amount of filament and this would cause a bad looking top.

Tmorris. Nope, i used the same i had for the Budas. I will check it.

esteps are NOT dependent on the hotend, only the extruder. If you are using the same extruder, you do not need to recalibrate. Extruder calibration is how many steps it takes to extrude 1mm of filament. The hotend does not factor in.

However, if your new hotend has a different nozzle size, you do have to configure that in your slicer (most likely Cura).

What size nozzle does the stock Buddashnozzle and Hexagon come with?


I am assuming he bought the whole extruder assembly for the hexagon which means he does need to calibrate the esteps. However whenever I got new assemblies from LulzBot they always attached a tag with the calibrated esteps.

Yes I bought the whole extruder set, extruder plus hotend already mounted.
And no, Lulzbot did not provide any data about calibration along the extruder.

I have reclaibrated the e-steps and found a minor difference with regards to the figures on the TAZ5 marlin firmware (as provided by Lulzbot). Have set this number on the firmware but I cannot see any difference.

Attached is a picture of a simple test (thingiverse: “20mm-box.stl”.
Top layer is rough compared to the same test performed with the Budas nozzle or even with my Prusa i3.

Have you tried gradually reducing your extrusion multiplier? It looks like you are over extruding a bit.

I print a small high infill block many times while adjusting the extrusion multiplier to fine tune the extrusion. I keep reducing the multiplier until the top surface smooths out. That usually does the trick.

I have really been fighting this problem since moving to the e3d v6.

Also make sure you are saving the estep values to eeprom

nbmoretto, I am reprogramming the whole firmware from the sources. So the new values are saved. Thanks for pointing it out.

nopick, I have set the extruding factor to 0.9. I expected a printing disaster after this setting, but the outcome has been almost identical. I am going to try with 0.8.

btw, in case anyone have a chance to print the part I am using for testing, I would be glad to see the results.!


It is worthwhile to check that the extruder is feeding 100mm of filament when you command it to feed 100mm. Mine did need some tweaking out of the box.

As tmorris9 pointed above, i did an E-step recalibration. I had to tweak it a little and now i am getting 100mm almost exactly. I am using higher temperatures than using Budas. Perhaps i could try with a table of temperature/speed settings.
I would be interested to hear experience from anyone who has upgraded to hexagon or have purchased the taz5 or even the Mini.