HELP - Flashing TAZ 6 with M175 through Arduino 1.0.5


I have a Lulzbot TAZ 6 with an M175 toolhead that had worked well for a long time. When the M175 toolhead was added I followed the instructions at the time and upgraded the firmware through Cura using all factory settings/options (TAZ 6 with M175 and 0.5mm nozzle). This is not an M175V2.

I have recently modified the TAZ 6 by increasing the height by 150mm (replaced the leadscrews, aluminium extrusion, smooth rods and extended the wiring harness). I then realised this was useless until the firmware was updated to allow Z travel (after homing) beyond 270mm. I also realised this could not be done through Cura, rather I would have to compile my own in Arduino and flash directly to the TAZ after modifying the #define Z_MAX_POS (to 420 from 270) within the configuration.h file. I managed to do this, which was not straightforward since I had never programmed/compiled. I used the Marlin_Oliveoil_Tilapia_v1.0.2.22_60d344d.tar.gz source file from Index of /TAZ/6.03/software/firmware and followed older youtube instructions.

I know I needed to update the steps/mm and Z offset – but that is done through the TAZ GUI after flashing.

After flashing through Arduino 1.0.5, the TAZ would move in all axis but when I home it sticks on the x limit switch and then tries to home to zero in the wrong location (too far rearward).

Can someone please tell me if I have done anything wrong?

I assume there must be more M175 specific changes that need to be made to the configuration.h file. Should I need to change any other files within the marlin.ino group?

Any assistance would be greatly appreciated – I am trying to get the machine running ASAP



I’d recommend dumping the and build from the latest - LulzBot 3D / Marlin · GitLab

I’m also a novice at building my own Marlin, but have done a few tweaks needed to get around a bad stepper driver. First, do a “vanilla” Taz 6 build to confirm that your environment is working right and then you should only have to modify the max Z.

Hello Wrathernaut,

I agree starting with ‘vanilla’ is best – then change height…

I did as you suggested and went to LulzBot 3D / Marlin · GitLab.

I downloaded the latest version – and Arduino IDE 2.0.3 also.

I liked the look of the configuration.h file and selected TAZ 6 and M175, but I could not verify/compile because I continually encountered the “ Compilation error: ‘init’ is not a member of ‘U8GLIB’ “ error.

Arduino also took ages to work through compiling the sketch (15+mins) before having the issue.

I feel I’m close but just need some assistance to resolve this issue if possible.

I have attempted some suggested fixes found online regarding “ Compilation error: ‘init’ is not a member of ‘U8GLIB’ “ but without success. I installed U8glib by oliver and then tried U8glib-HAL by Scott Lahteine. Maybe I installed them to the wrong place? I installed it in another folder on the C: drive (not in the project folder) with no success either.

I would be more than happy to compensate someone who could compile the firmware for a TAZ6 with M175 toolhead and an additional 150mm Z build height – I assume I could flash this through Cura. I would then update my esteps/mm and z-offset on the GUI that I had recorded previously.

I’m under pressure to resolve this ASAP.



Hi David,

We usually do not support the M175v1 and strongly recommend updating to the M175v2 conversion kit so you are able to keep up with our latest firmware, but I have compiled a M175v1 with the additional 150mm added to the Z max to give you a max height of 422mm. Here is a link to download the .hex file and you can use CureLE “Upload custom Firmware” option in the update firmware window to select this .hex file.

I do not have a M175v1 built anymore (I updated mine to a v2) but it is build out of the last M175v1 code that was worked on. Being that we were not able to verify that the M175v1 works with this, this file is not supported by LulzBot.

Let me know if you are not able to flash this firmware.

Hi Brian,

Thankyou very much for creating the custom M175v1 +150mm height .hex file.

It updated through the latest Cura 3.6.37 perfectly.

I have a print running now that will continue overnight – it should be 350mm tall tomorrow morning.

I will look at the M175v2 conversion kit – I like the idea of keeping up with the latest firmware, however, I would not then be able to use my additional 150mm height.

Your assistance is very much appreciated.