KITTAZ Left Z-motor skipping

As the title says, the left Z-motor on my KITTAZ is having problems. When I try to home the Z-axis, everything will work fine until the bottom inch of travel or so where the left motor starts to make horrible grinding noises yet the right motor works fine.

I’ve checked leveling - I manually adjust the rods to level the Z-axis and when I move it back and forth high above the bed, everything works fine. When I move the Z axis near the bed, the problems start where the right side will move properly but the left side won’t so it becomes unlevel.

I read that others had problems with the motor trying to move too quickly but if this were the case, it wouldn’t matter if the Z axis was moving in the upper part of its range or lower part of its range. I’ve also tried slowing the motor down to 10mm/s, still having the same problems.

Anybody have suggestions on where I can begin diagnosing the problem?

When Z axis occurs towards the extremes of that axis it’s due to the Z axis or lead screw being out of square. The bottom of the Z axis is either too close together or too far apart. Center the bottom of the lead screw within the coupler by loosening both the top and bottom screws with the Z axis at its lowest point. Once centered tighten the set screws (not too tight that you strip them).

If the binding still occurs, compare the distance of the smooth rod on the top of the Z axis to the same measurement on the bottom of the Z axis. Then compare the distance of the leadscrew in a similar fashion. Make sure that the Z axis lead screw nut mount is loosened then tightened again at the lower part of the z axis travel. Doing that at the Z min may allow any misalignment to center itself.

Well, I literally should have looked at both sides of the problem here. I had my KITTAZ up against the wall so was only looking at it from the front side.

It turned out that I had actually mounted the electronics case a little too high up the frame so the upper-back mounting screw was interfering with one of the x-motor mount screws. I moved the case lower and it seems to have solved the issue.