Latest Firmware ( Unprintable (Taz6/M175) (Fixed)

I recently installed the latest version of Cura (3.6.25-10) so I could get the latest version of firmware ( onto my Taz6. The very same GCODE file I was printing under was now completely unprintable under Massive over extrusion and squashing of layers. And yes, I’ve set the Tool Head to M175 and double checked my steps/mm and Z-Offset… (Details at the end of this posting)

Day 1: After lots of testing and double checking, I called Luzbot support and after a lengthy discussion they said to try printing directly from the latest version of Cura (instead of my existing GCode on SDCard - from Simplify3D).

Day 2: I tried printing from the latest version of Cura and got EXACTLY THE SAME RESULTS. I spent several more hours modify my GCODE to see if this was a volumetric vs linear extrusion issue or absolute vs relative movement issue on the Z axis. Nothing helped. So I called them back. I told them in detail what I was experiencing and what I was seeing. Apparently a detailed explanation (inc extrusions over 1mm wide from my 0.4mm print head) wasn’t good enough to start troubleshooting they needed more info. They wanted me to write up a support ticket with all the details (cause apparently they weren’t listening) as well as taking some photos (cause they didn’t understand what a squashed 1mm wide extrusion might actually LOOK like). Anyway, off I went to gather all this info according to their requirements…

Day 3: I submitted my description of events and things I have tried and they simply got back to me and told me to run the old firmware ( AS IF I DIDN’T ALREADY KNOW THIS. I guess they though asking me to document and photograph all that crap was going to force me to just go away. But I did what they asked (surprise, surprise), and now they just tell me to run the old firmware.

ANYWAY: Beware issues you may encounter if you are running the latest firmware. I’m not sure if this effects any one other than folks running the new M175 Tool Head, but heads up in any case. This new firmware looks like its only been out a couple of weeks and now they are also saying that they are already moving to separate the M175 firmware from the new “combined” model.

I also spent a good portion of the day trying to see if I could mitigate the issue by adjusting my ESteps (to limit extrusion), or my Z-Offset (as my first layer was definitely squashed), or by adjusting my ZSteps (as even if I got the first layer right the others also seemed to be to close). No matter what I tried, I could not mitigate the issues. If I got a good first layer, the rest were over extruded and/or squashed. I tried messing with volumetric vs linear extrusion settings and even relative vs linear extrusion settings in my GCODE thinking maybe the firmware defaults might have been changed or improperly implemented. My existing GCODE would not print properly with the new firmware no matter what I tried.

Here are the details I submitted in case anyone is interested (It certainly appears that Lulzbot was not):

When I originally purchased my M175 Tool Head (March 2021), I upgraded my Cura Version to 3.6.23 in order to apply an automatic firmware upgrade (to for M175 Support on my Taz 6. This has worked nicely other than fighting some oozing issues during the bed-leveling process which causes fairly frequent failures in the process.

(Old Version Cura = 3.6.23, Old Version Firmware=

I recently saw a newer version of Cura was available (3.6.25-10) so I decided to install it to see if newer firmware would provide a more reliable bed-leveling process. I ran the automatic firmware upgrade process to install version on my Taz 6.

(New Version Cura = 3.6.25-10, New Version Firmware=

I then ran the very same GCODE file off of my SDCard that I had been using with the older version and it would not make an acceptable print with the new firmware installed. The tool head was over extruding heavily during the print from the very same GCODE file I had been using for quite some time. I made sure I had the M175 Tool Head selected in the New Universal Firmware. I also double checked all my TAZ 6 Configuration Settings were correct:

XSteps: 100.5 (Factory)
YSteps: 100.5 (Factory)
ZSteps: 1600.0 (Default)
ESteps: 412.4 (Calibrated)
ZOffset: -1.370 (Calibrated)

I have been uninstalling/resinstalling Cura versions (old <-> new) in order to perform testing as it does not seem I can reliably load (or identify?) the older firmware manually from the newer version of Cura. (I have preserved both sets of “firmware” folders from both versions of Cura so I have full access to all associated firmware files). IOW: If I rely on the auto update feature of the corresponding Cura Version I get what I expect is correct. However, if I try to load the older version of the M175/Taz6/lutefisk firmware from the new version of Cura, the ESTEPS is not set properly to the default (415). Note that the ESTEPS IS SET properly if I simply perform an auto firmware update from the old version of Cura. I obviously have no problem changing this manually, but I am concerned that I am simply not choosing/selecting the proper old firmware file, so I have be resorting to swapping versions of Cura back and forth for testing. (I have always been enabling the function to overwrite the EEPROM in any case). So, in order to minimize the possibility of introducing user-error, I have been swapping versions of Cura and relying on the Auto Firmware Update process.

Old Firmware: lulzbot_taz6_lutefisk.hex, 11/25/2020, 462,296 bytes
New Firmware: Marlin_TAZ6_Universal_2.0.6.7_d5f08b22.hex, 7/21/2021, 568,521 bytes

It should be noted that I don’t normally use Cura for slicing. I have been using Simplify3D for many years across multiple printers and it has always worked well with the Taz 6 (at least until this firmware release). As such the GCODE file I am using to test this firmware was generated by Simplify 3D.

In order to remove Simplify3D as a source of the problem (and/or determine what GCODE updates might be required in the Simplify3D Start Script), I then tried printing my test STL file directly from Cura. I loaded the exact same STL file that was used by Simplify3D and (USB connected) Cura produced the exact same over-extrusion problem that I saw when using the Simplify3D GCODE file from SDCard.

It should be noted that I am using a 0.4mm nozzle on my M175 but I did make the associated change to the “Hot End” configuration in Cura (as I did in Simplify3D). This is not a 0.5mm vs 0.4mm configuration issue (particularly since my existing Simplify3D GCODE file has been designed for a 0.4mm nozzle and working fine for quite some time).

Note that the GCODE file I am providing (from Simplify3D) has been generated for a 0.4mm nozzle.

As the latest version of Cura seems to be generating EXACTLY the same type of over-extrusion issues I am seeing with my original GCODE file, it appears that there is some issue with the firmware or the associated configuration of my Taz 6 (after the firmware has been applied). Once again, note that I am selecting the M175 Tool Head and checking all my Step Settings as well as my Z-Offset.
If I load (and configure) the firmware, my prints look great. If I load (and configure) the firmware, my prints are massively over-extruded (regardless of whether I use Simplify3D GCODE files or print directly from Cura itself). The over-extrusion is so bad that the nozzle begins “rumbling” over plastic bumps and ridges after only a couple of layers (the prints cannot be completed at all).

As required, I have included some photos of the issue. Normally, my GCODE (and Cura) should deposit a relatively thin line of extrusion (0.4mm or so). Clearly, the new firmware is resulting in an extrusion of over 1mm in width.

In the Good photo (Old Firmware), you will see a normal extrusion. It should be noted that I had to restart my print job so many times (3 or 4) that the nozzle was pretty empty when it began printing (from retraction at each start attempt). This is why you will note that the skirt did not print and the “sputtering” left behind as the nozzle fills back up on the first pass. (This thin line is actually the SECOND pass around the perimeter). I actually ran this job to completion and came out quite well. Never-the-less, you can see a representative width of the extrusion.

In the Bad photo (New Firmware), you will see a greatly increased amount of extrusion on the very first pass. This is exactly the same result whether I submit the very same GCODE file or print directly from Cura. In my testing the extrusion is so bad that only after a couple of layers the nozzle will start rumbling/grinding over the additional material. This is not a z-offset issue as the heavy extrusion continues on every layer. (I have also tried the default -1.20 Z-Offset with no real improvement). Jobs processed by this firmware cannot be completed without damaging the tool head.
In the Measured photo, you can see that the extrusion width easily exceeds 1mm.

I believe you either have a major issue with the firmware for Taz6/M175 or there is some other configuration setting in my Taz6 which is being overlooked.

We are looking into this issue and have determined it to be firmware related. Support is not trying to make you go away, they are working through the problem with information provided.

As far as firmware goes Removed M175 from universal toolhead for Workhorse, Pro, and ProXT since... (455b7e2a) · Commits · LulzBot 3D / Cura-LE / Cura Binary Data · GitLab . We have not released another version of Cura, yet.

The reason for opening a support ticket after calling is to be able to take the time to reproduce issues and investigate ways to mitigate the issue. In addition to having instructions we also have in your own words what the issues are, when communicating to other staff about the issue this is extremely important to finding the correct solution.

As you state in your post that you are using a non standard tool head as well as a slicer that is outside of our ability to test. This adds additional steps that are necessary to check off to confirm your issue and what may be causing it.

We want all of our users to be able to print well and as intended, but problems arise and to fix them we need detailed information. We ask things of our customers that are experiencing issues so that we can solve their problem and get them back to printing, provided they let us help them. Please keep in mind that when communicating with Support we have a shared goal and that is to get you back to 3D printing.

1 Like

Its not a non-standard Tool Head. Its YOUR tool head. I got the M175 from Lulzbot (and it wasn’t cheap)… I assume you should be testing all YOUR Tool Heads…

…and I did reproduce the problem using Cura directly so you have no claim to a slicer “outside your ability to test”. …and Cura behaved EXACTLY the same way my GCODE on SDCard did. …or did you NOT read my report?

I obviously AM back to printing. I was, in fact, before I first called you. I have been swapping firmware back and forth in an effort to try and find out what this issue is (for everyone’s benefit). But DOES have a better bed leveling process which appears to be more reliable than the one in

Our nozzle comes STANDARD with a 0.5mm nozzle.

I was referring to the fact that you use a slicer that we do not use in house. We cannot test on a slicer that we do not have. I was not saying that we would not test it, we were verifying that it was not a slicer specific issue.

Thank you for the useful feedback.

@evanevery I am just getting back from vacation all of last week and working though some of the issues that arose while I was away. I was able to reproduce the issue you were having and believe that I have found where the issue potentially lies. It was a change with the M206 (nozzle offset adjustment) command that is used when using the Tool Heads option for the Universal firmware. In separating the M175 from the Universal firmware, the bed leveling uses Bilinear as compared to the linear leveling that so you should still see the change in first layer accuracy, yet it does not take use of the M206 offset change.

Using the test firmware found here, I was able to print out a calibration cube without any blemishes. If you are willing to try out this firmware I would be happy to try and help you though these issues you are having.

I too could not print with the m175 after updating to 3.6.25 and updating the firmware. Going back to 3.6.23 and reverting the firmware cured the problem, although I do get messages saying a firmware update is available. I must resist the call of the dark side and not update the firmware.

I will try this new “trial” firmware with 3.6.25 and see what happens.

We now have a couple of updates we are doing to the M175 blower shroud to help out with the issue. Before you try the experimental version of Cura LE with updated firmware for the M175 you will need to print out new parts for your M175, unreleased/v2-0/stl · master · LulzBot 3D / Tool Heads / Lutefisk · GitLab

Can you suggest a material and profile for these new parts?

@b-morgan We recommend using ABS for both parts and any of our standard profiles will work well.

Hi all – I’m a touch confused!
Over the summer I upgraded my Taz 6 to the latest Marlin firmware.
This week I bought the M175 head + universal adapter, and am about to install it.

This thread makes it sound like the latest firmware will not work; and indeed, when I tell Cura I have the M175 head, it insists on backdating my firmware to 2.0.0. I assume that I should let that happen?

While I’m here: like the original poster (Evan), I typically use Simplify3D rather than Cura. Evan, did you have to do anything special to get the M175 toolhead working in Simplify3D (other than backdating the firmware)? Thanks!


Hopefully the following will be easy to understand

Determine which tool head you have v1 or v2

v1 -

v2 -

If you are unable to figure out from the pictures there please contact

We have an issue with the v1 construction that causes prints to come out funky when used with the tool head swapping function that was fixed by the v2 construction.

What firmware should I use?

TAZ 6 M175 v1 - firmware version
TAZ 6 M175 v2 - firmware version (remember to select the tool head on the lcd before printing)

as of Cura version 3.6.28

For other slicers the start and end gcode are pretty crucial, other than that fill out the settings using Cura LE as a guide.

Can you elaborate on “funky” and the “tool head swapping function”? i.e. Details on what the v2 construction fixes?

I’m patiently waiting for the 1x- [KT-PP0055] M175 V2 update kit to be available for purchase.

There was a bug we encountered in firmware. Due to the difference in offsets between our e3d tool heads and the M175v1 the firmware would not print some layers at the correct thickness (somewhere was doubling/halving the layer height) .

For now you can contact and they can help you purchase the V2 update kit until it is on our store.

Thanks, Robert! I just purchased this M175 head from Matterhackers last week. I don’t see any giant “m175” or “v2” printed on the printed portions, so I assume I must be using v1. Is it worth upgrading to v2?

Yes! While there should be no changes in print quality, we aren’t planning on updating the firmware for the v1. Obviously if there are significant bugs in the firmware that is already available you could expect an update. Once again if you wish to purchase the upgrade kit you can get in contact with . Otherwise if you wish to procure the necessary non printed hardware (heat set inserts and some screws), you can find the 3d models here .