Layer Offset issue - not sure if mechanical or software

I have a Taz 4 where i have upgraded the extruder and flashed the taz 5 firmware. I never had any problem in the past with printing until recently where every part i print over a few cm in height have some layer offset issues.

I tried printing the exact same file multiple times however it seems that the offset issue happens at a different height each time. Just to rule out gcode issues i tried to reslice the file with a different program with the same issue. Ive used both Cura and S3D, and when using a gcode viewer i do not see any kind of issues.

I have also tried tightening both the X and Y axis timing belts to make sure there is enough tension in the belts. I have checked the set screws on the stepper motor clamps and both are secure and extremely tight. I’ve also check the bearings, bolts, screws, nothing seems to be loose.

I have tried to orient the parts so that while printing it would minimize movement in one of the axis’s to make sure that slipping is not the issue. I did this for both X and Y and there were no changes, there was still an offset happening at random heights. I have also tried to relevel the bed to make sure that it was not somehow contributing to the issue.

Not sure where to go from here in order to pinpoint if this is a mechanical or software issue.

Whatever it is, its in your X axis. If it’s mechanical it could be the following:

  1. Loose X motor pulley setscrew (can cause a slight shift side to side even if belt is otherwise tight)
  2. Broken X motor shaft (unlikely since the rest of the print is coming out fine)
  3. inadequate belt tension (should make a sound like plucking a low guitar string when you pluck the belt)
  4. Gummed up or failing X rod bearings
  5. Bent or otherwise offset X rods (unlikely, print would fail earlier)
  6. Loose X toolhead on carriage or otherwise loose X carriage
  7. belt drag due to improper angle on the belt to idler or belt to motor loop
  8. Bad idler bearings
  9. an X axis alignment issue,

If it is none of those, it’s probably electrical, usually a heat sink has fallen off a motor control chip, the exhaust fan has failed, or the control board is in an enclosure and isn’t vented properly and is overheating.

It’s minutely possible that is a Y axis issue shifting sideways in the X axis direction, possibly due to a loose bed plate or a loose Y frame mount, but that is unlikely to the point it probably isn’t even worth checking. If either of those were loose, you would know it because all of your prints would be failing on layer 2

I was going over everything again, checking all the things you suggested. It looks like my X axis belt is miss aligned, when it is alll the way to the right the belt is riding between the idler and the plastic housing, and when it moves over to the left it kind of jumps back onto the idler but nowhere near the center. I think i have it back on properly but it wander a bit when the extruder moves to both extremes. Worst case ill have to release the belt and realign and retighten. I originally thought it was a Y axis issue so i missed this. I hope this works!