Mini Z motor grinding noise and binding

Well it’s been a while, but I’m in need of of your learned advice once again. One of my Minis v1.04 recently developed a a loud grinding noise that sounds like it’s the left side Z motor. It had been leveling and printing fine for a year or so, but I checked a print after a few hours last night and found it failed and had made a mess. I turned off the machine and cleaned it up. When I reconnected and tried to start another print, the noise was even louder, especially when trying to go through leveling. Then it started binding and skipping on Z moves and fails to level at all. When trying to home, it seized up so I shut it down and have been trying to find some answers. I searched the forum and made sure the X carriage was level with the bed. The Z motors will turn, although still making the grinding noise during slow movements. Strangely enough it homes normally with only grinding at the top after hitting the end stop. So how do I diagnose this? Is it motor replacement time? I did check the mounts, couplers, and rods and can’t see any problems there. Help me Obiwan, you’re my only hope!

Reach out to the support team for help leveling your Z-axis at, they’ll recommend following a procedure similar to this:

Thank you for your response. I have leveled and releveled several times and doesn’t seem to be the issue. I checked for debris in the screws and loosened the Z nuts to see if they were damaged but found nothing. I retightened the motor mount screws which were a little loose but not enough to cause the motor to drop or be out of alignment. As far as I can tell when I do a 100mm travel at the normal homing speed up or down it seems to work fine with little noise. But when it slows down after hitting the end stop or trying to do a bed level, it makes the loud buzzing again and starts missing steps and sometime the motor stops turning altogether, which I can restart by hand twisting the lead screws a bit.

So I’m guessing the left side motor is dying and the right side may not be far behind. I just want to make sure I haven’t missed anything else, like a broken coupler (they look fine) or loose mounting screws (which all seem to be tight) or maybe bent rods or lead screws (which I have inspected from about every angle and they seem fine). I got this Mini (v1.04) in 2017 so I would think the motors would last longer than that. My 2015 Mini (v1.03) is still humming along and I’v been running them both every day.

Is there a possibility that it could be rambo board related? I reflashed the firmware with the same version (v. and everything seems to operate normally until I try to do any slow vertical moves or do a bed level. It skips badly before touching the washers and gives bad reads. I’m about ready to do a complete Z-axis rebuild. Thoughts?

Have you tried to loosen the X axis belt/rods? It may be a slight binding from them pulling or pushing the end pieces out of alignment. Thus putting pressure on the smooth rods on the Z axis.

Thanks for the suggestion, but that wasn’t it either. I did hook it up via USB and opened Simplify 3D and used the machine control panel to test Z movements at different lengths and speeds. What I found was that any Z travel length (1mm -120mm) at any speed over 300 mm/min didn’t produce the buzz/vibration/grinding noise. Any travel length (1mm-120mm) at speeds below 300 mm/min produced the noise/vibration, with it being louder at each slower speed tested down to 6 mm/min.

I did disconnect the Z-axis cable chain to see if it was causing undo drag for some reason and there was a slight improvement and I haven’t noticed the skipping during those tests, but I haven’t tried another small print yest to see if it will make it past the auto-level. Still stumped.

Okay here’s a new wrinkle… Upon closer inspection I see that the Z motors on the Mini v1.04 are Moons’, which are pretty heavy duty and they still turn fine at regular speed and only make the loud buzzing at slow speed, but they are turning so I’m thinking it’s not the motors. I checked again to make sure there were no cracked or broken mounts or couplers and all the printed X, Y, & Z parts look intact as well. However I did find that the case fan was not operating. I never checked that so I don’t know how long that has been broken. My question now is, could that have damaged the Rambo board and could that be affecting the Z motor? How would I check that to see if that’s the problem?

The built-in thermal protection circuit on the driver chip should prevent too much damage, but since the Z axis has 2 motors loading it it will thermally shut down before the other two(X/Y). Getting the fan working again should be all you need, if it does not fix then ???

Thanks kmanley57, replacement fan has been ordered and fingers crossed. If I have to replace the board, I’ve done that before on another Mini and it is pretty easy, but a little pricey. All you can do is hope for the best and plan for the worst. :wink:

Well, it turns out it was a Rambo Board issue. I replaced it and everything works like normal. No noises, no grinding, just smooth running. This is the second Mini that I’ve had to replace the Rambo in. Both instances should probably have popped the fuses before damaging the board, but all of the fuses were intact. It makes me think there should be lower value fuses in these. But whatever, #2 is up and running happily again. Maybe I should stock up on Rambos. :wink:

One more thought on this topic, in case anyone else has the problem and reads this thread.

When my Mini arrived from the factory, it had all sorts of problems. Digging in, I discovered that the two Z drive systems (on either side of the printhead carriage) were grossly out of synchronization. If the nozzle was just touching the buildplate when the X axis was all the way one direction, it would be significantly distant from the buildplate at the other extreme of X axis travel. In other words, the X axis was not parallel with the buildplate… but this was caused by a Z axis problem.

Obviously this caused printing issues - bed leveling and 3D matrix rotations can only do so much - but with respect to this thread it also caused a grinding/binding noise from the Z axis bearings. It’s easy to understand why: When the two Z axis stepper motor/lead screws aren’t in sync, the printhead carriage is out of level, which in turn twists the left and right Z axis bearings out of alignment with their smooth shafts.

Background: The drive systems on the Mini are totally open loop. There is no absolute measurement for position such as a rotary encoder on the motor shaft or linear encoder on the carriage or buildplate. They just home and then count steps and “hope nothing goes wrong”. This is doubly problematic on the Z axis where not only is the overall axis open loop, but the twin steppers are open loop with respect to each other! At least the X and Y axes get a fresh sense of “home” at the start of every print. But any de-sync between the two Z axis steppers is permanent until a human intervenes to re-sync them. Expressed another way: Once there’s a “missing step” between the two Z steppers there are no sensors on the Mini to indicate this and enable automatic correction. Note there is no limit to how many steps the Z motors can be off, so if you miss more steps over time the error just keeps growing.

My solution was to lower the nozzle to just barely above the print bed (on the side that was “lower”), then turn off the power. I measured the nozzle gap with a feeler gauge, then turned the opposite Z axis lead screw by hand until the nozzle matched that distance on that side. This re-sync’d the left and right Z axis steppers/lead screws, which in turn brought the X axes (of the print carriage and the buildplate) into alignment. The noise went away, and I stopped having (those) extrusion problems.

This is easy to test and easy to fix, if you know about it. Hopefully this helps someone.

I had this exact symptom on my TAZ 6. This quick re-alignment/ synch procedure fixed me right up! Thank you for sharing this tip!