Modifying Lulzbot Mini to print with toolhead at room temperature

Hi All,

I have a bit of a strange application for a Lulzbot Mini: I would like to print viscous liquid cellulose through the classic Mini Tool Head v.2. In order to do this, I’ve made a few hardware modifications, including the installation of tubing and pumps in place of plastic filament. (I’ve printed parts to turn the gear which latches on to filament in order to force it into the heated nozzle assembly into a roller wheel pump.) However, in both Cura and Matter Control, whenever I do a dry run, I find that extrusion is prohibited because the tool head is at room temperature. For ordinary plastic filament, this is a great safety feature. For a viscous fluid that will boil above 100 C, this is a terrible feature. How do I disable the low-temperature tool head exception? Is there some setting in the control/slicing software or is this a firmware issue?


There is a minimum temperature extrusion allowed firmware value you will want to change to enable that. It’s in place to prevent damage to the extruder normally. but it can be changed or disabled. It should be in configuration.h if I remember right.

Thanks for your help so far. How would I access and modify the firmware? When I do a search for firmware, I find that it’s in hexadecimal, so changing it and reflashing it would be tricky.

The hex file is a compiled variant of the firmware. There should be an uncompiled version around somewhere. Here’s an older version of it that may or may not work for editing purposes. . Once you have the firmware, you compile and uploa it using the arduino IDE. Please note that a power outage during a firmware flash can brick your device. There are several tutorials out there on how to do the edits and uploads. Look for “3d printer marlin firmware” for general guidelines.

I would try the M302 - Allow Cold extrudes command in your print gcode file first.

I tried the M302 command in the start G-code and that did the trick! Thanks!