Open GL errors using Remote Desktop

My question is super specific and clearly related to NVIDIA and specifically GeForce drivers. I am just hoping someone has some ideas or some similar experience. Here is my setup:

  • I have a single PC than runs my entire 3D lab (2 TAZ 6s, multiple MakerBots, and multiple Forms2) all hardwired and using OctoPrint for the LulzBots.
  • Everything works great except when I use remote desktop and only when using Cura.
  • The server PC runs Windows Server 2016 R2 fully updated and well maintained. I am an admin on this system but not a server expert. I just recently put a NVIDIA GeForce 1080 Ti in this PC.
  • Cura runs fine locally as does OctoPrint and every other CAD/CAM software I use.
  • But, when I remote into the server, most software applications work (including SolidWorks and other CAD/CAM programs) but Cura gives me the following error “Failed to probe OpenGL. Could not probe OpenGL. This program requires OpenGL 2.0 or higher. Please check your video card drivers.”
  • We have tried to enable every RemoteFX setting we could fine in gpedit on the server but none helped.
  • I do know the entire system works perfectly locally and remotely when using a NVIDIA Quadro GPU so my current best option if I cannot make this work is to go back several GPU generations and use a K1200 Quadro rather than the GeForce 1080 (this would be very disappointing).

Sadly NVIDIA support is no help. They simply say that Windows Server is not supported on the GeForce line even though the Win10 drivers work fine in what appears to be every way but remote desktop.

Any help would be greatly appreciated. My very crappy solution right now is users must use Cura on their own PC, then remote in, and send the gcode file using OctoPrint web interface (which works fine remotely). Thanks in advance.

It’s been a few month since I’ve tried this so excuse me if this information is wrong or doesn’t work anymore. I was able to get Cura working with a remote desktop session by using a software implementation of OpenGL.

Nvidia wants you to buy their premium GPUs to do things like this. That’s basically why this feature is locked out by default from my understanding.

If I remember correctly I was able to get OpenGL working remotely with Mesa3D. Mesa3D is a software OpenGL renderer that runs separate from your normal Nvidia GPU OpenGL and can work around some issues like this in my experience.

I was able to find this guide for using Mesa3D on Windows

same issue here!..i spent 12 hours trying different things including tech support here and with nividia got to the point where i accidentally uninstalled my nividia graphics card and i don’t have the cd to install it … i can open an older version of cura with the stock intel card but it will not show the overhang window… i’m going to a computer repair guy to see if i can get my nividia somehow reinstalled i’m not too happy right now really not happy…although not glad but good to find someone with the same issue i’ll look at your link after i see if i can get my graphics card issue fixed… if not can i print using a tablet or something cheap any suggestions thanks