Printer will not connect on Windsows 10 Pro

Background:

This has been an ongoing problem for about a year now and I am really at my wit’s end. I’ve connected with other computers at that time but I would like to resolve this on my current set up.

I bought the printer in 2018 and love it but at some point, I upgraded my Cura software and now it will not connect. I don’t recall what I was running before and I’ve tried earlier versions of the software since then with the same error.

My problem:

I connect the printer (I get the windows chime indicating something has been connected) Cura indicates that “USB devices are available”. I hit “connect” in “monitor” and I get “Scanning available serial ports for printers” forever and my printer will not connect.

What I’ve done:

  • Installed numerous versions of Cura making sure to clear my cache every time.
  • Ensured that my USB ports and cables are functioning properly with a paper printer.

My system:

Without being able to connect to the printer I am unable to ensure my printer is running the latest driver software.

Any advice is much appreciated.

Thanks,

Chris Brown

While it is Windows 10, it appears to be a Surface Book. I’m guessing that if a serial port is created from the USB port, it probably isn’t recognized by Cura. See this post that might be related.

Another alternative would be to try Printrun. Pronterface is the GUI for that. Scroll down on the page to find the precompiled files for Windows. This may also fail for the same reason above, but it might be worth a shot.