TAZ 4 EEPROM settings

I recently upgraded my TAZ 4 from the 2014Q2 firmware to 2014Q3 firmware, and forgot to jot down the EEPROM settings before uploading the latest version to my printer… Now all the prints are coming out off. Ugh.

Could someone post their TAZ 4 EEPROM settings by sending the M503 command to their printer via Printrun/Pronterface?

Thanks in advance.

Aren’t all the necessary calibration values listed on the factory acceptance paperwork that comes with each TAZ?

Hello wingman,

Here’s what I got:

  • <-echo:Steps per unit:
    <-echo: M92 X100.50 Y100.50 Z1600.00 E858.00 E1800.00
    <-echo:Maximum feedrates (mm/s):
    <-echo: M203 X192.00 Y208.00 Z3.00 E50.00
    <-echo:Maximum Acceleration (mm/s2):
    <-echo: M201 X9000 Y9000 Z100 E10000
    <-echo:Acceleration: S=acceleration, T=retract acceleration
    <-echo: M204 S500.00 T3000.00
    <-echo:Advanced variables: S=Min feedrate (mm/s), T=Min travel feedrate (mm/s), B=minimum segment time (ms), X=maximum XY jerk (mm/s), Z=maximum Z jerk (mm/s), E=maximum E jerk (mm/s)
    <-echo: M205 S0.00 T0.00 B20000 X8.00 Z0.40 E10.00
    <-echo:Home offset (mm):
    <-echo: M206 X0.00 Y0.00 Z0.00
    <-echo:PID settings:
    <-echo: M301 P6.00 I0.30 D125.00

Good luck!

Best Regards,

Keep in mind that unless you enable EEPROM chitchat, you won’t be able to see all the responses.

Make sure that if you reflash your firmware, you enable this line by deleting the two leading //:


Once you do so, you’ll see the controller responses when issuing EEPROM commands. Don’t forget to update your extruder steps per unit by issuing the M92 command, then save it to EEPROM.

prstein and Orias, thanks for the posts and all your help! Much appreciated!!

brouhaha, there are some, but not all of the settings are written down on the initial paperwork.

I’ve been playing with the settings, but had to revert back to the older 2014Q2 firmware. For one reason or another I can’t get the latest version to print properly even after calibrating the extruder feed rate. With the newer 2014Q3 firmware, the z-axis isn’t moving up properly so my prints are “squished”. I’ve attached a picture of 2 donuts that I printed. The one that looks normal was printed with the older firmware. The newer one was printed with the new firmware and is about 1/2 the size of the properly printed one.

Anyone else experienced this issue?

The Z steps changed going from the Taz 3.2 to the Taz 4. The Taz 4 is the one with the fully supported leadscrews with bearings top ad bottom and aluminum Z couplers. If you happen to have the slightly older 3.2, the new firmware will not have the correct z steps value in it to work with your existing threaded rod. If you have a Z Nut spring instead of the solid leadscrew mount, you might be dealing with something older than a Taz 4.