Taz 5 FlexyDually V2 Flexy Extruder Chattering


This is my first post here, and i’d appreciate any info any of you can share!

I’m not a total noob at this stuff (i built a printer from scratch previously) but this one has got me confused.

I am having an issue with my newly purchased FlexyDually V2, here’s the situation:

I have a taz 4 converted to a taz 5 (i think, i did the harness mod and have been printing with the upgraded single extruder for a while now) and I was running taz 5 firmware

I installed the FlexyDually V2 Taz 4/5 Firmware via Cura, Extruder 1 (the solid, first extruder) works fine, but Extruder 2 (the flexystruder) refuses to move. Heres a video of the action:(https://www.youtube.com/watch?v=t1PNr1yz670&feature=youtu.be)

The set screw for the small gear is tight, and it is a consistent issue between 2 versions of the firmware that i’ve tried.

It appears to me that the stepper current is not set correctly, on ramps boards you can adjust the little trim pot on the stepper drivers, but i cannot figure out how to effectively change the current being fed, i tried playing around with these from the config file:

#define DIGIPOT_MOTOR_CURRENT { ((950 -750)/5+135), ((950 -750)/5+135), ((1275 -750)/5+135), ((875 -750)/5+135), ((875 -750)/5+135) }
#define DIGIPOT_I2C_MOTOR_CURRENTS { 1.0, 1.0, 1.0, 1.0, 1.0, 1.0, 1.0, 1.0 }

i have yet to touch the DIGIPOT_MOTOR_CURRENT values cause that looks like a whole lot of stuff i dont understand
the DIGIPOT_I2C_MOTOR_CURRENTS values are supposed to be the amount of amps provided (i’ve read elsewhere that 1.6 is the max).

Regardless, no matter what i set the values to i get the same result its almost like the digipot is not operating at all. Am i looking in the wrong place, or did receive a defective unit?

Hey, I also had to convert my Taz 4 to a Taz 5 in order to attach the flexydually v2 as well. As far as I can tell, you have to get this attachement.

Did you attach that? Because I didn’t have to go through any of the other steps you had to do. I saw the video, I never had that happened to me. I don’t know how else I can help you.

I would check the four motor wires very carefully. It looks like you are missing one of the pairs, so it can not advance to the next step position.