Taz 6 - Flexystruder Wipe Failure

I have the Flexystruder firmware flashed on the Taz 6 but when it wipes it fails to probe and then it shows “Rewiping” and then it rewipes again and tries to probe and fails again, then an error is displayed, “Failed nozzle cleaning” or something similar. Any ideas?

I ensured the nozzle was clean and tried it a few more times and it did not work. I also tried making a simple electrical connection between the nozzle and the probe washer and it did not trigger a probe event.

Startup LCD reads: Taz 6 Flexy - Firmware

Is it the v1 or v2? AFAIK only the later ones include the proper connections for bed leveling. I’m not sure if the difference is in the hotend, or the cabling, or both (probably?)

It’s the V2. On the side of the hot end there is a red wire that I assume is the lead for one side of the bed-leveling circuit.

Your frame may be out of square or your X-axis may be off.

< FIRMWARE_NAME:Marlin LulzBot Flexy SOURCE_CODE_URL:https://code.alephobjects.com/diffusion/MARLIN/ PROTOCOL_VERSION:1.0 MACHINE_TYPE:LulzBot TAZ 6 EXTRUDER_COUNT:1 UUID:XYZ.

I’ve used scotchbrite to clean the nozzle and it still fails.

I used a multimeter to test the voltage at the extruder and it reports 4.9 volts when it first powers up. However, when I measure during probing the voltage is only 0.4 volts.

Call support and ask for Brent. I’ve been having similar issues and we have not yet resolved it.

Here’s a video of the voltage drop midway through the wipe.


I solved my wipe issue over the weekend. I’ll try to post the solution this week. It involves a new wipe housing and revamped gcode. The stock setup does not sufficiently clean the nozzle, at least not on the flexydually.

On the extruder, check the crimped loop connector that ties the ground wire to the extruder head. On my printer the crimp had failed and the wire was loose. Removed the screw that holds the loop connector on and make sure the wire is solidly attached.

Problem is, I’m seeing the voltage drop on the female header at the toolhead connector. I have a perfect connection between the male header toolhead connector (pin 3) and the extruder assembly.