V3 dual purge sequence on E2 not purging material

V3 dual on TAZ6 purge sequence, it appears to be the same for E1 and E2 but E2 never drops anything; loading the same way on both heads. I always have to print a brim because E2 takes so much longer to start extruding material.
It is FW, so after leveling, the table goes away from the head and it extrudes some filament off the edge, not sure if that is unique to the head rev of the FW or the current FW rev, my earlier FW rev single did not do that.

Any ideas?

I’m on FW and it does the same thing. Extruding off the edge for the first nozzle seems to be the new norm, I don’t print a skirt cause it’s primed and ready from the off edge extrusion. Confirm for the 2nd nozzle, it “purges” but nothing comes out. I see the gear turning, stops then waits for the bed to heat up. Then I usually start off with the first nozzle. I guess I haven’t paid too much attention. I haven’t had too much luck with dual extrusion prints, assumed it was the code and was just waiting for new updates. I tried “priming the towers” with PVA, failed miserably, where the towers print in the corner would eventually lose adhesion and stick to my nozzle and turn into a failed print. I assumed it was the nozzle not heating up fast enough and I’ve seen temperature swings, I’ve been waiting for an updated. And partially assumed it was the cheaper E-SUN PVA material. You bring up a good point and I can confirm the same problem.

I’m doing OK with priming towers, PLA and PolyDissolve. I cut the size of the tower down to 15-20mm but made the walls thicker- 3mm. Probably not good for prints with a higher Z level printing, I’ve been under 3cm so far. As for the temp swings, possibly bad crimps on the thermistor connector, they’re hidden in the looms between the thermistor and the main print head connectors. Poke at the harnesses while it’s sitting idle but connected and observer the temps, if they vary, that’s the temp fluctuation issue. I had zero success until I got that resolved.

Actually there’s a VERY simple solution to this (and lulzbot should clearly explain this because it’s pretty important!):
In cura there’s a machine setting that has startup scripts. Settings ->Printer->Manage Printers-> Machine settings

Early on in this script, there’s HUGE retraction occurring. If you are fine with the stupidly large purge, just change these settings slowly. If you want to minimize the purge and fix the retraction, monkey with both this and the purge amount towards the end of the script. Both can be much more optimized for a tiny bit of purge (a mm or two vs like 15mm).

Aha you have not answered our concerns and have only pointed out a large amount of retraction and extraction in the startup G-Code.
Retraction and Purge are opposite functions. Yes the Startup G-Code retracts 15mm of filament, then waits to heat things up, heats up the nozzles and the bed and positions the extruders. When the elements reach their set temperature the G-Code extracts (purges) 15mm of filament on the first extruder (and you actually see filament extruding from the nozzle). Then it switches to the 2nd extruder and also extrudes 15mm of filament (or at least its supposed to the way the code reads) ; however, in reality nothing ever comes out of the 2nd extruder even though you can see the gear turning in the anti-clockwise direction. The question still remains, why doesn’t any filament come out of the 2nd extruder?

FYI btw, I said in my earlier post in this thread that I haven’t had any success with the v3 dual print head and eSUN PVA. Then the service bulletin came out - (https://www.lulzbot.com/sites/default/files/Thermistor_Service_Bulletin_2.pdf). Mine fell within that possible affected range. So I sent my v3 dual head back to Lulzbot and they replaced the hot-end just to be safe. Just yesterday I am now successfully printing with PLA and eSUN pva. Though I am now getting successful dual head prints I am still not getting any filament from the 2nd extruder during the “Purge” sequence. I’ll print a skirt with the 2nd extruder and it seems to be enough to get the 2nd extruder primed (don’t need much, can set it low from 250mm to 50mm).

Its just that as bot_nic pointed out, that this is strange that the 2nd extruder doesn’t push out any filament during the purge process. Why is that?

The reason why E2 (T1) doesn’t purge is because Marlin does not maintain current E for each extruder, only a global E value.

At the beginning of the Start Gcode, T0 and T1 are set to 0 (G92 E0) and then retracted -15 (G1 E-15 F100). (Global E is -15)

After “M117 Purging…”,
T0 is moved to E0, set to E-15, and moved to E0. This works because Global E is -15 from above.
T1 is selected and moved to E0 but wait, it is already there because of the global E value being set last by T0! Marlin needs to be told that T1 is at E-15 first! Solution, add another “G92 E-15” after “T1”.

The Purging section of the Start Gcode should be:

M117 Purging...              ; LCD status message
T0                           ; select this extruder first
G1  E0 F100                  ; undo retraction
G92 E-15                     ; set extruder negative amount to purge
G1  E0 F100                  ; purge XXmm of filament
T1                           ; switch to second extruder
G92 E-15                     ; set extruder negative amount to purge
G1  E0 F100                  ; undo retraction
G92 E-15                     ; set extruder negative amount to purge
G1  E0 F100                  ; purge XXmm of filament
G1 Z0.5                      ; clear bed (barely)
G1 X100 Y0 F5000             ; move above bed to shear off filament
T0                           ; switch to first extruder
M190 S{material_bed_temperature_layer_0}; get bed temping up during first layer

Repro is pretty simple, just note the timing of e1/e2 during the Purge cycle. E2 is noticably shorter. Did someone file a bug on this yet? I think aleph had a customer ticket system.

Bingo. Thanks! It also appears to have solved my initial brim warping/stringing issues with PolyDissolve because it begins with a full bead deposit rather than the purge being the beginning of the brim.

Does configuration count as a code bug?

Already done. https://code.alephobjects.com/T2124