Wipe Nozzle Direction

Hi all,

First, a little background on the setup. I am using slic3r and printing with a large diameter extruder. Basically, I am running into trouble with the wipe direction. When it lays down one continuous bead, at the end it does a wipe. This is working fine about half the time. It either wipes forward or backward, and this is where I am running into trouble.

The backward swipe would work great if I was using a small diameter bead. However, I am using a large bead size, and often it doesn’t have enough time to adhere and solidify, and so on the backward swipe gets caught up in the freshly laid bead. I love the way it wipes forward (over a cool bead) because it doesn’t change the look on the final print. I am trying to edit G-Code, does anyone know any way to change the G-Code to always have forward swipes? Thanks!


I changed some of the settings and found that the wipe direction swipes forward on perimeter beads, and backward on infill beads. I can change all my beads to perimeter beads, which is great, but then it adds a little sideways swipe before wiping forward. I attached 2 photos to show what I am talking about.

If anyone has any ideas on how to get rid of the sideways swipe so it only wipes forward, that would be great.



Hi all,

I ended up figuring it out, and wanted to share. Basically the way I got it to swipe forward every time was by going into output settings, then checking the box that says “verbose g-code”. Then I exported G-Code, and went into that file and deleted every line that said something about an inward swipe. This is a fairly unique case as my printed bead size is about 13mm… But I am sure the same principles could be applied to a desktop printer, and may result in a smoother print. This is because the extruder nozzle does not wipe over the “fresh” material that is still very pliable and thus resulting in a more rough finish.

This would be helpful if printing with nylon or something that is meant to be very smooth and low friction.