Workhorse / Octoprint... Smoke!

If using OctoPrint with your workhorse and upon connection you have the SD card that comes with your workhorse inserted in the machine, the hotend will invariably try to heat to over 300 degrees. If you remove the card and reconnect, this will no longer happen. The issue does not occur with any other SD Card I have tried.

Here’s the link to the OctoPrint forum topic.

Hope this helps someone out there.

1 Like

This is interesting… I use OctoPi/OctoPrint and for the entire time I used it, I never had a problem. UNTIL… I finally did.

Baffled… I realized that the printer only went crazy if I tried to connect via OctoPrint. If I did tell the software to connect, I didn’t have a problem.

HOWEVER… I’ve been printing lots of face-shields and… enough that I threw the job on the SD card (I never used the SD card to print before). It wasn’t until I read your post that it connected the dots.

BTW… I upgraded from OctoPrint 1.3 to the new 1.4 (finally out of beta). After doing that, I didn’t have the problem anymore. I’m not sure which SD card is in the printer… (e.g. if it’s the original card that came with the printer vs. a blank card.)

But thanks for posting this and…

Hope this helps someone out there.

… yes… it definitely helped me! Thanks again!

Glad to hear @TheVirtualTim!

The card included with the Workhorse is a Verbatim 8GB Class 10. It comes with firmware, etc, on the card if I’m not mistaken. Not sure if what’s on the card causes the issue or the card itself, however, I bet if you checked it’s probably the Verbatim 8GB you have in there and not any other blank card.

I also want to mention that I was able to reproduce with OctoPrint version 1.4, so heads up!

I’m printing face shields too - keep up the good work! :slight_smile:

I just checked the printer … the card currently in the printer (and not causing a problem) was a 32GB card and not the card that came with the printer. I am able to use OctoPi/OctoPrint with the card still inserted without a problem.

I presumed that the upgrade from OctoPrint 1.3 to 1.4 fixed the problem and didn’t realize it’s probably that I swapped cards.

Are you sure the current card was the definitely one that was in the workhorse when the overheat occurred? Any chance you had the verbatum in there? Can you also provide info on the 32GB card?

The card used when the over-heat occurred was definitely the original 8GB factory card that came with the printer.

The card that I am using right now (not overheating) is a 32GB Transcend brand card (Class 10).

I normally use Sandisk cards in most of my cameras … so it’s kind of a fluke that I had this 32GB Transcend card laying around. But I didn’t want to steal a card from a camera.

Thanks @TheVirtualTim. I believe your issue was not resolved by updating OctoPrint to v1.4 as I know of at least two individual instances where it was reproduced on that version (@mhenstell and myself).

I’m not sure if what’s on the card causes the issue, but this 8GB Verbatim card that comes with the workhorse is certainly the root cause.

OctoPrint’s startup sequence includes SD card commands so it can display what is on the card. If the SD card got corrupted somehow, then these commands may cause the issue described here.

What I would do is mount the SD card on a desktop computer (you can buy a cheap USB to SD card reader) and verify that the files are intact. If the desktop likes the card, copy everything off of it, reformat it, and put the files back. See if that fixes the issue. If not, you’ve got a copy of the files in case you need them later. If the desktop doesn’t like the card either (and it doesn’t reformat), then its a bad card and should be discarded.

Many people are having this issue, It’s not a single corrupt card.

+1 confirm removing the SD card stops the printer from locking up, and entering a thermal runaway state, when OctoPrint connects.

1 Like