Y axis controlling Z

I turned my printer on today and found my z axis wasn’t reponding to the Z+ commands from MatterControl1.1 after trying the Z- i found that to move the Y axis + slowly. moving to the Y+ and Y- controls moved the Z axis as if they were the right controls i tried restarting the printer unpluging it for 30sec restarting my pc all that jazz and no change. when printing i get NaN returns from the printer on the axis’ when i watch it on the terminal and there is no movement :angry: idk what happened it worked fine last night

That’s rather odd. NaN is “not a number”. Would you be willing to reload your firmware?

I reflashed the firmware but there’s no change ;(

So yeah before printin when just using the movement controls the terminal shows:

->G1 F315
->G1 X0 Y10 Z0

This happens clickin the Z- movement control

amd when print i see:


What about when printing with known-good gcode on your sdcard, using the Graphical LCD Controller? If it still persists, please send in an email to Support@LulzBot.com with the following information:

  • Order number

  • 3D printer serial number

  • Contact information

  • Shipping information



I have a kitTAX :angry: so no lcd or card reader i tried reloading the driver and re-installing Mattercontrol ; ; no change still :slight_smile: guess its time for support

Aha! A KITTAZ! Well that changes things tremendously.

Thanks for getting that email in!

I Still haven’t heard anything back from support yet, but i was wondering if it was possible to pass a movement command through the terminal?
so i disided to install cura and give that a try its workin fine :confused: i wonder what happend to mattercontorl. guess ill roll with cura now :slight_smile:

Would you mind resending in your information to support@lulzbot.com? I’ve PM’d you my email as well, if you can cc me, we’ll make sure you’re taken care of.

Worked it out with mattercontrol support apparently this kinda thing can happen when the auto-leveling is corrupted and simply disabling then reconfiguring it fixes the problem :smiley: