Page 1 of 1

LulzBot Mini Firmware Upgrade Fail

Posted: Thu Aug 15, 2019 6:05 pm
by beodd
So, I have a LulzBot Mini 1. I followed the instructions on Cura to update the firmware. It failed during the upgrade with the error message "Firmware update failed due to an unknown error.".

I tried it with the console open and I am getting the following error:
"Exception while trying to update firmware: <IapError('Timeout',)>"

I have tried different versions of the .hex file. I went back to the version that came with Cura , all with the same error. I am still able to print with no problems but every time I launch Cure, it tells me it cannot determine the firmware version.

Any thoughts or suggestions are more than welcome.

Re: LulzBot Mini Firmware Upgrade Fail

Posted: Fri Aug 16, 2019 3:55 pm
by Galadriel
A timeout error indicates that it took too long for the firmware data to be transfered. The only time I can think of off hand that I have seen this error during firmware flashing was when an especially long USB cable was used to hook the printer to the computer. Have you tried using a different USB cable at all?

Re: LulzBot Mini Firmware Upgrade Fail

Posted: Fri Aug 16, 2019 4:24 pm
by beodd
I am actually running the printer off of a VM (ESXi 6.7) with USB passthrough. :lol: Has been working just fine for a long time, until trying to update. I'll connect it up to something physical and see if it will take the upload. Thanks for the feedback.

Re: LulzBot Mini Firmware Upgrade Fail

Posted: Fri Aug 16, 2019 4:31 pm
by mwester
Yeah, that's probably not going to work. The RAMBO board is like the arduino IIRC - I think it identifies as a different device when it's running (a serial port) but switches to another USB device ID when the firmware loads. This causes issues for VMWare, since VMWare uses the USB device ID as the identifier to determine if the host's device is a candidate to be passed through in the first place. So, even if you passed through both devices, it's dubious if the timing would end up such that firmware loading would work reliably.

Re: LulzBot Mini Firmware Upgrade Fail

Posted: Fri Aug 16, 2019 7:33 pm
by beodd
Flawless Victory! Connected it to my laptop and it updated with no problems at all. I really appreciate the insight. Guess it's a good thing I am not trying to run a BBS through a passthrough serial port. Working on my VCP but you never get these kind of quarks in the lab.

You wouldn't happen to have a profile for Simplify 3D to make it work with the Mini 1?