Auto bed probing and compensation with G29 Development

Want to use the Open Source Hardware documentation to make your LulzBot 3D Printer do even more? Start here!
vitormhenrique
Posts: 156
Joined: Tue Jan 20, 2015 4:04 pm

Re: Auto bed probing and compensation with G29 Development

Post by vitormhenrique » Wed Jan 21, 2015 10:26 am

saramos wrote:I wonder if it is the Y rails sagging under the weight of the print head rather than the bed being warped?
You meat the X right? I think that is exactly what is happening (per other threads on this forum).

saramos
Posts: 195
Joined: Fri Sep 19, 2014 1:05 am

Re: Auto bed probing and compensation with G29 Development

Post by saramos » Thu Jan 22, 2015 12:05 pm

Oops, my bad. X axis is correct.

ninjanick
Posts: 8
Joined: Sun May 24, 2015 11:06 pm

Re: Auto bed probing and compensation with G29 Development

Post by ninjanick » Sat Jun 20, 2015 1:24 am

Sorry to dig an old thread up, but I modified my TAZ3 and the gcode works, except for the offset home setting. Any time I set an M206 Zx command, it still defaults to gives me "echo: M206 X0.00 Y0.00 Z0.00". I tried setting the Z Offset via LCD screen as well, but it doesn't have any effect. Is there a write bit I'm not enabling? #define EEPROM_SETTINGS is uncommented.

voi9viper
Posts: 56
Joined: Sat May 30, 2015 5:09 pm

Re: Auto bed probing and compensation with G29 Development

Post by voi9viper » Fri Aug 21, 2015 12:29 pm

I finally got the parts printed and mounted. or the X, Y, and Z offsets I made the following aasumptions. X0, Y0 is the front left, The deployed probe is behind and to the left of the nozzle, so the X offset should be positive, Y is negative , and the probe hits before the nozzle/z minimum endstop, so Z offset is negative. My values -5, 70, -3, does that sound right? After I run the G29 script Z-offset is set 4 and the nozzle is way too high. Where did I screw up?

voi9viper
Posts: 56
Joined: Sat May 30, 2015 5:09 pm

Re: Auto bed probing and compensation with G29 Development

Post by voi9viper » Wed Aug 26, 2015 1:27 am

Ninja, you also need to enable EEPROM_CHITCHAT to write new values. If you use the LCD Z_OFFSET has a minimum value of 0.50. When making changes via CONFIGURATION after making the changes be sure to use STORE VALUES to wrtie them back to the EEPROM. I'll take a look at the code for M206 and see what's up.

changing #define min_software_endstops false // If true, axis won't move to coordinates less than HOME_POS. in Configuration.h will allow negative Z values

at line 1025 in ultralcd.cpp this change lets you define a negative z-offset, down to -0.5 minimum, 50 max

MENU_ITEM_EDIT(float32, MSG_ZPROBE_ZOFFSET, &zprobe_zoffset, -0.5, 50);


M206 adds addition homeing offsets and you need to use M500 to write changes.


I still don't have the auto leveling working right. When printing starts i get the z_probe_z_offset height, around 5mm for me. Maybe I need to define the z_offset as a negative

inventabuild
Posts: 166
Joined: Fri Aug 15, 2014 8:39 pm

Re: Auto bed probing and compensation with G29 Development

Post by inventabuild » Thu Aug 27, 2015 8:05 pm

This is great, does anyone have a parts BOM and proven software for doing this on the TAZ 4? Will it work if I have Lulzbot's Dual Extruder Firmware loaded?

voi9viper
Posts: 56
Joined: Sat May 30, 2015 5:09 pm

Re: Auto bed probing and compensation with G29 Development

Post by voi9viper » Fri Aug 28, 2015 12:03 am

Go to the thingiverse project in the first post , the endstop deployment one. That is all the hardware needed. I think the latest dual extruder is 2015Q1, which does have some G29 code in it. The latest stuff MESH LEVELING has not been added to the main Marlin branch yet, so it is not in TAZ firmware.

mikronano
Posts: 63
Joined: Wed May 13, 2015 2:42 pm
Location: Chicago, IL

Re: Auto bed probing and compensation with G29 Development

Post by mikronano » Fri Mar 18, 2016 3:33 pm

Hi,

I chose to post in here my problem, instead of creating a new post, even if it is old, because I feel somebody in here will know what am I doing wrong.

I have a TAZ5 and I have flashed the new 2015Q3 firmware with the support for the G29 and servos.
I have installed a sub miniature endstop switch on a servo, in a way to go right beneath the nozzle.
Probe-right-up.jpg
Probe-front-down.jpg
Probe-left-up.jpg
I have successfully defined the servo pins, the servo number and the angles for the servo endstops.
I have also calculated the probe x,y,z offsets from the nozzle (hotend-probe).
I have even run the M206, re-calculated the Z-offset and store it with M500.
My start gcode is:

G28 X0 Y0 ; home only X, Y
G29 ; probe 2x2 points (basically the four corners)

But, I can't get it to work unless I select:
#define min_software_endstops false
and then on Simplify 3D set the Global G-Code Offset for the Z-axis to -10.00mm (my actual z-offset, "hotend-probe")

I have tried to run a full G28.
I have tried to run a G1 Z-10 following the G29.
Nothing works.
Unless I do the aforementioned steps (define min_software_endstops false, z-offset in S3D), right after it completes the G29 it starts printing high up in the air, on a virtual plane 10mm above the bed plate!!
It's like the "#define X_PROBE_OFFSET_FROM_EXTRUDER" etc, etc, in the configuration.h are just a "decoration"!

Can anybody, please, tell me what am I doing wrong? or missing to do?
Press a key to continue or any other key to quit

Weekend_warrior1999
Posts: 15
Joined: Fri May 27, 2016 12:52 am

Re: Auto bed probing and compensation with G29 Development

Post by Weekend_warrior1999 » Fri May 27, 2016 12:58 am

Define probe as z end stop
Remove x0 y0 reference in g28 command just use "g28"
Ensure eeprom settings and chitchat are enabled

This should activate probe during g28 command
G29 command activates probe for bed leveling

Eeprom settings and chitchat enable the printer to recall the probe measurements for tram correction.

Weekend_warrior1999
Posts: 15
Joined: Fri May 27, 2016 12:52 am

Re: Auto bed probing and compensation with G29 Development

Post by Weekend_warrior1999 » Fri May 27, 2016 1:26 am

Also how I setup the "z" offset is to temporarily disable min_software_endstop for z. Then set z extruder offset to "0". I then upload the firmware and run g28. I then manually (via the smart controller) lower the z till the nozzle is at the desired height. Then read the DRO for Z on the LCD, it should be a negative number, this will be your new "z" offset. Change it, re-upload, test. Once happy, re-enable min software endstops.

Post Reply