Marlin 1.1.x for Taz 5

Look here for custom firmware, networked 3D printer hosts like OctoPrint, and more!
discojon
Posts: 432
Joined: Sat Mar 07, 2015 1:54 pm

Marlin 1.1.x for Taz 5

Post by discojon » Sun May 14, 2017 9:18 pm

DO NOT USE wrote:I've gotten 1.1 working pretty well on my Taz and wanted to share it here. I have attached a build for a stock Taz (untested) and my custom build with auto leveling.[ /s ]

As always, use at your own risk.

Both builds include linear advance, thermal protection, and have FW retraction enabled but not active. The stock build uses mesh bed leveling (untested) while the custom leveling build uses bilinear leveling and requires a probe.

http://www.thingiverse.com/thing:1149597

Compiled versions you can use with Cura are inside each file.

Please back up your settings prior to any flashing and follow Lulzbot's OHAI guide to flash if you aren't familiar with the process.
Disregard the above. The z-hop bug is still in there. I believe 1.1 is still unusable.
Attachments
Marlin 1.1 Discojon.zip
(1.02 MiB) Downloaded 83 times
Stock Taz.zip
(1 MiB) Downloaded 83 times
Last edited by discojon on Mon May 15, 2017 4:57 pm, edited 5 times in total.
TAZ 5, Open rails X,Y,Z. Marlin 1.1 RC2. Mangrove dual fan, reinforced extruder mount

User avatar
piercet
Posts: 4022
Joined: Sun Aug 25, 2013 1:37 am
Location: Battleground, WA
Contact:

Re: Marlin 1.1.x for Taz 5

Post by piercet » Sun May 14, 2017 11:20 pm

Have you seen a noticeable improvement with it? I'll probably have to grab that one and add the blinky front light code into it. Linear advance seems very useful.

discojon
Posts: 432
Joined: Sat Mar 07, 2015 1:54 pm

Re: Marlin 1.1.x for Taz 5

Post by discojon » Mon May 15, 2017 4:27 am

So far it seems to be noticeable in corners and top layer thanks to linear advance. The Blinky lights and status led code is in there just not enabled in what I posted
TAZ 5, Open rails X,Y,Z. Marlin 1.1 RC2. Mangrove dual fan, reinforced extruder mount

discojon
Posts: 432
Joined: Sat Mar 07, 2015 1:54 pm

Re: Marlin 1.1.x for Taz 5

Post by discojon » Sun Jun 11, 2017 6:13 pm

UPDATE!!

Recompiled a build today and the bugs seem to be worked out. I have a build with autoleveling, FW retract, yada yada working. I haven't figured out the new vendor boot screen yet so it's not included. The file below is for a taz with a capacitive toolhead mounted probe like i have in my Taz 5 hybrid toolhead. So far everything seems to be working. I disables Linear Advance for now as it was a bit aggressive on the retracts for me.

DO NOT USE ON STOCK TAZ 5!!!

https://www.thingiverse.com/thing:1149597


EDIT.. The bug is still in there
Last edited by discojon on Sat Jul 01, 2017 9:37 pm, edited 1 time in total.
TAZ 5, Open rails X,Y,Z. Marlin 1.1 RC2. Mangrove dual fan, reinforced extruder mount

Rp1030
Posts: 92
Joined: Tue Apr 28, 2015 9:20 am

Re: Marlin 1.1.x for Taz 5

Post by Rp1030 » Sat Jun 17, 2017 7:45 pm

When I install this firmware and home my axis. My servos make a grinding sound almost like I jogged too far on one of the axis.

PS. Sorry I've been away from the forums for a while :D

Sebastian
Posts: 514
Joined: Sun Sep 13, 2015 5:54 am

Re: Marlin 1.1.x for Taz 5

Post by Sebastian » Sun Jun 18, 2017 1:46 am

Which servos do you mean, a servo mounted probe? Or do you mean the end stop isn't stopping the stepper of the homed axis?

Rp1030
Posts: 92
Joined: Tue Apr 28, 2015 9:20 am

Re: Marlin 1.1.x for Taz 5

Post by Rp1030 » Sun Jun 18, 2017 8:13 am

I had to double check just now, I guess I should've said motor instead of servo. It's my Z axis. Anytime it moves up or down (only when homing) it sounds like it's struggling and doesn't move

Sebastian wrote:Which servos do you mean, a servo mounted probe? Or do you mean the end stop isn't stopping the stepper of the homed axis?

discojon
Posts: 432
Joined: Sat Mar 07, 2015 1:54 pm

Re: Marlin 1.1.x for Taz 5

Post by discojon » Sun Jun 18, 2017 1:40 pm

I'll check the build again its the one I'm using on my printer currently
TAZ 5, Open rails X,Y,Z. Marlin 1.1 RC2. Mangrove dual fan, reinforced extruder mount

Rp1030
Posts: 92
Joined: Tue Apr 28, 2015 9:20 am

Re: Marlin 1.1.x for Taz 5

Post by Rp1030 » Sun Jun 18, 2017 6:45 pm

I was told that the noise is the motor oscillating. It happens for about 3-4 seconds upon pressing the home button, and I think it moves normally after that. I don't really know because I shut off my machine as soon as I heard that noise.

discojon
Posts: 432
Joined: Sat Mar 07, 2015 1:54 pm

Re: Marlin 1.1.x for Taz 5

Post by discojon » Sat Jul 01, 2017 9:36 pm

Once again the z-hop bug has resurfaced. Looks like it's still not ready....
TAZ 5, Open rails X,Y,Z. Marlin 1.1 RC2. Mangrove dual fan, reinforced extruder mount

Post Reply