Taz 6 Retracting too much before leveling?

A forum dedicated to the stock LulzBot TAZ 3D Printer
Post Reply
Patrick Allen
Posts: 3
Joined: Sun Oct 23, 2016 8:39 pm

Taz 6 Retracting too much before leveling?

Post by Patrick Allen » Fri Nov 18, 2016 11:31 am

Working with a brand new Taz 6 and some nGen blue PLA.

So far most of the prints are turning out great. But there have been some issues in starting prints recently.

It seems like the printer is retracting too far before cleaning the nozzle. Even with a large skirt around my part, the extruder is often still just pushing air when it should be printing the part.

This means cancelling and cleaning/auto-leveling all over again.

Is there some way I can prevent this from happening?

nopick
Posts: 1012
Joined: Mon Sep 09, 2013 11:14 am

Re: Taz 6 Retracting too much before leveling?

Post by nopick » Fri Nov 18, 2016 11:52 am

You can use some purge gcode in your startup gcode to make sure the nozzle is primed before printing.

I have Taz 5 machines so, you might need to adjust the x / y positions for a Taz 6.

This is the code I use just after homing the printer before the print starts:
G91 ; relative positioning
G1 Z+10 E+10 X+20 F3000 ; move Z up a bit and purge filament move right
G1 Z-10 E+3 X+20 ;return Z to original position
G1 E-0.25 ;suck up a bit of filament
G90 ; absolute positioning

aramis
Posts: 12
Joined: Mon Nov 07, 2016 12:58 pm

Re: Taz 6 Retracting too much before leveling?

Post by aramis » Fri Nov 18, 2016 5:00 pm

I apologize if this sounds silly, but is there any chance that your previous print failed / was aborted (maybe during auto-leveling but before extruding), and you had to try again? If so, then (when combined with this last print attempt) you effectively had retracted 2x the normal filament but the printer didn't know, and so it tried to extrude just one retract's worth when you printed again...which wasn't enough.

If auto-leveling fails or something that causes you to abort the print after wiping, make sure you always re-prime the extruder maually.

I don't remember how much Cura tries to retract...I'm using Simplify3D and I'm retracting 12mm worth of filament, which when it re-extrudes actually gives me a bit too much ooze out right before the print starts.

Patrick Allen
Posts: 3
Joined: Sun Oct 23, 2016 8:39 pm

Re: Taz 6 Retracting too much before leveling?

Post by Patrick Allen » Fri Nov 18, 2016 7:14 pm

Thanks for the reply!

Now that I know where I can modify and inject code into the start-up, I should be able to tweak this and some other issues away. :P

User avatar
DougZ
Posts: 140
Joined: Wed Jun 01, 2016 8:02 pm
Contact:

Re: Taz 6 Retracting too much before leveling?

Post by DougZ » Sat Nov 19, 2016 8:00 am

I think I'll give this a shot too.

@aramis: I've experienced the same thing. I find it is dependent on the initial layer height. If left at Cura defaults (.425 & 125%) I don't have the problem. I realize those are set that way to promote bed adhesion. If you modify them however, say you set the initial layer height to match your slicing layer height and you change the initial line with to 100%, it appears to prime at that same rate which I often find is not enough to achieve a proper prime before the skirt is done especially when using high detail.

It can be dealt with in many ways but one way I do it is when the toolhead is waiting in the home position for the nozzle and bed to reach temp I quickly open the idler and shove the filament down to take up the negative space.
--
Lulzbot Mini
Lulzbot TAZ6
Follow me on Twitter! @tech3_design

PdxSteve
Posts: 173
Joined: Tue Apr 12, 2016 2:27 pm

Re: Taz 6 Retracting too much before leveling?

Post by PdxSteve » Sat Nov 19, 2016 12:07 pm

If you look at the start g-code, you will see it sucks up more before leveling than it extrudes back after leveling. IIRC I just made the values the same and it fixed it.

Post Reply