Page 1 of 1

Taz 6 Retracting too much before leveling?

Posted: Fri Nov 18, 2016 11:31 am
by Patrick Allen
Working with a brand new Taz 6 and some nGen blue PLA.

So far most of the prints are turning out great. But there have been some issues in starting prints recently.

It seems like the printer is retracting too far before cleaning the nozzle. Even with a large skirt around my part, the extruder is often still just pushing air when it should be printing the part.

This means cancelling and cleaning/auto-leveling all over again.

Is there some way I can prevent this from happening?

Re: Taz 6 Retracting too much before leveling?

Posted: Fri Nov 18, 2016 11:52 am
by nopick
You can use some purge gcode in your startup gcode to make sure the nozzle is primed before printing.

I have Taz 5 machines so, you might need to adjust the x / y positions for a Taz 6.

This is the code I use just after homing the printer before the print starts:
G91 ; relative positioning
G1 Z+10 E+10 X+20 F3000 ; move Z up a bit and purge filament move right
G1 Z-10 E+3 X+20 ;return Z to original position
G1 E-0.25 ;suck up a bit of filament
G90 ; absolute positioning

Re: Taz 6 Retracting too much before leveling?

Posted: Fri Nov 18, 2016 5:00 pm
by aramis
I apologize if this sounds silly, but is there any chance that your previous print failed / was aborted (maybe during auto-leveling but before extruding), and you had to try again? If so, then (when combined with this last print attempt) you effectively had retracted 2x the normal filament but the printer didn't know, and so it tried to extrude just one retract's worth when you printed again...which wasn't enough.

If auto-leveling fails or something that causes you to abort the print after wiping, make sure you always re-prime the extruder maually.

I don't remember how much Cura tries to retract...I'm using Simplify3D and I'm retracting 12mm worth of filament, which when it re-extrudes actually gives me a bit too much ooze out right before the print starts.

Re: Taz 6 Retracting too much before leveling?

Posted: Fri Nov 18, 2016 7:14 pm
by Patrick Allen
Thanks for the reply!

Now that I know where I can modify and inject code into the start-up, I should be able to tweak this and some other issues away. :P

Re: Taz 6 Retracting too much before leveling?

Posted: Sat Nov 19, 2016 8:00 am
by DougZ
I think I'll give this a shot too.

@aramis: I've experienced the same thing. I find it is dependent on the initial layer height. If left at Cura defaults (.425 & 125%) I don't have the problem. I realize those are set that way to promote bed adhesion. If you modify them however, say you set the initial layer height to match your slicing layer height and you change the initial line with to 100%, it appears to prime at that same rate which I often find is not enough to achieve a proper prime before the skirt is done especially when using high detail.

It can be dealt with in many ways but one way I do it is when the toolhead is waiting in the home position for the nozzle and bed to reach temp I quickly open the idler and shove the filament down to take up the negative space.

Re: Taz 6 Retracting too much before leveling?

Posted: Sat Nov 19, 2016 12:07 pm
by PdxSteve
If you look at the start g-code, you will see it sucks up more before leveling than it extrudes back after leveling. IIRC I just made the values the same and it fixed it.