TAZ 6 Reboots Manually Loading Filament

A forum dedicated to the stock LulzBot TAZ 3D Printer
Post Reply
User avatar
DougZ
Posts: 140
Joined: Wed Jun 01, 2016 8:02 pm
Contact:

TAZ 6 Reboots Manually Loading Filament

Post by DougZ » Sat Dec 17, 2016 2:30 pm

Hi there...in what seems like an ever growing list of issues with my 6 in the process of loading filament to run a 3DBenchy gcode file Lulzbot support sent me the machine rebooted in the process of doing so. The steps are reproducible, here's what I did, curious if anyone else's machine does it. I have video of it and will post the Vimeo link. I apologize in advance that I ended up turning my phone sideways to show the display and toolhead at the same time so you'll have to turn your head.

Also, I've had odd behavior, for example, while moving the z axis up to 240 (per Lulzbot support instructions as part of an x carriage alignment test) I've had the toolhead move to the right by itself, and I've also had the display crap out as shown in the picture below. When I told Lulzbot about the issue they replied that it is normal and built-in protection for the LCD from turning the knob too far and to instead turn it a little, then wait, then turn it a little, then wait... That sounds like BS to me.

Here's the video of it rebooting: https://vimeo.com/196106831
IMG_1518.JPG
Display corrupt
Thanks for any suggestions.
--
Lulzbot Mini
Lulzbot TAZ6
Follow me on Twitter! @tech3_design

User avatar
piercet
Posts: 4025
Joined: Sun Aug 25, 2013 1:37 am
Location: Battleground, WA
Contact:

Re: TAZ 6 Reboots Manually Loading Filament

Post by piercet » Sat Dec 17, 2016 2:52 pm

There is a voltage pulse protection built into the firmware for the lcd knob. The potential issue is that turning the knob quickly can generate voltage that feeds back into the Rambo board. If you spin the knob too quickly for too long, that pulse could theoretically damage the lcd channel, and at least a handful of machines were damaged in that exact manner. The restriction value in firmware might be a bit too restrictive though. But yes, that is a known thing and not just bs. A different lcd knob electrical design would fix the issue, a few on board diode, etc. But that's a fix for a future version of the lcd board, and one that no one has designed yet.

User avatar
DougZ
Posts: 140
Joined: Wed Jun 01, 2016 8:02 pm
Contact:

Re: TAZ 6 Reboots Manually Loading Filament

Post by DougZ » Sat Dec 17, 2016 2:58 pm

Hi piercet. Who would have thunk it. But, what about the manual extrude issue in the video, is that the same thing and it caused the machine to reboot?
If so it seems silly, honestly.
--
Lulzbot Mini
Lulzbot TAZ6
Follow me on Twitter! @tech3_design

User avatar
piercet
Posts: 4025
Joined: Sun Aug 25, 2013 1:37 am
Location: Battleground, WA
Contact:

Re: TAZ 6 Reboots Manually Loading Filament

Post by piercet » Sat Dec 17, 2016 4:50 pm

DougZ wrote:Hi piercet. Who would have thunk it. But, what about the manual extrude issue in the video, is that the same thing and it caused the machine to reboot?
If so it seems silly, honestly.
That particular reboot might have been caused by your hand position and the less than ideal placement of the primary power switch, which is on a hair trigger. It didn't look like you were turning the knob too fast, but it does look to me like your hand was in contact with the power switch and it takes almost no force to interrupt the power temporarily on that style of switch. You may want to repeat the experiment with your hand away from the switch and see if it occurs again. Mine do not do that from the lcd alone, though the wire path on mine does go a different route and use a different firmware.

User avatar
DougZ
Posts: 140
Joined: Wed Jun 01, 2016 8:02 pm
Contact:

Re: TAZ 6 Reboots Manually Loading Filament

Post by DougZ » Sat Dec 17, 2016 7:38 pm

Thanks piercet. My hand was only in that position because of the way I was holding my phone to try capturing the toolhead and display at the same time. Normally it is not like that and I can reproduce the issue over and over and over and over...literally.
--
Lulzbot Mini
Lulzbot TAZ6
Follow me on Twitter! @tech3_design

User avatar
piercet
Posts: 4025
Joined: Sun Aug 25, 2013 1:37 am
Location: Battleground, WA
Contact:

Re: TAZ 6 Reboots Manually Loading Filament

Post by piercet » Sat Dec 17, 2016 8:40 pm

That doesn't seem normal to me then. Maybe a short in the knob button?

Post Reply