Taz 5 e3Dv6 PT100 Thermocouple

A forum dedicated to the stock LulzBot TAZ 3D Printer
Post Reply
nickhuanghq
Posts: 4
Joined: Thu Feb 02, 2017 12:05 pm

Taz 5 e3Dv6 PT100 Thermocouple

Post by nickhuanghq » Thu Feb 02, 2017 12:24 pm

Anyone here tried to install a thermocouple on their RAMBO boards? I'm trying to print some higher temp material and purchased the PT100 upgrade kit. Any input would be appreciated! Thanks!

Here's the upgrade: http://e3d-online.com/V6-PT100-Sensor-Kit?search=PT100

SislerChief
Posts: 4
Joined: Wed Jan 18, 2017 9:30 am

Re: Taz 5 e3Dv6 PT100 Thermocouple

Post by SislerChief » Fri Feb 03, 2017 2:33 am

I haven't installed this kit, but you (or the seller of the kit) should know that a PT100 is an RTD (resistance temperature detector), not a TC (thermocouple). If you connect an RTD as a TC, it won't work...
Mahalo,

Sisler Chief

Tim in D
Posts: 13
Joined: Mon Jan 18, 2016 6:09 pm

Re: Taz 5 e3Dv6 PT100 Thermocouple

Post by Tim in D » Fri Feb 03, 2017 4:43 pm

Sisler is correct. A thermocouple generates a voltage proportional to temperature. A thermister changes its' resistance as temperature varies.

Tim in D

rexsolomon
Posts: 12
Joined: Sun Aug 14, 2016 6:42 am

Re: Taz 5 e3Dv6 PT100 Thermocouple

Post by rexsolomon » Sun Feb 05, 2017 8:58 pm

Hello Nick,

Yes I am using the PT100 kit from E3D, plus their Titan and hardened nozzles on my Taz5.

Here are the pins that you need to connect to your PT100 (use the E3D PT100 AND use the E3D paired sensor kit):

On the PT100's three pins you need to connect
Pin 1 (5V Analog Ext)
Pin 2 (GND Analog Ext2)
and Pin 4 (Ext 6 Analog ext pin #93)

The PT100 amplifier board has the legend for which pin is 5V, GND and signal printed on it, so just follow that.

Rambo analog extension pins below where X has a connector, 0 is open (if you are looking directly at the Rambo board):

X 0 X 0
X 0 0 0

The two pins on the other end of the PT100 connects to the paired sensor.You'll need to disconnect the Hexagon's old sensor connector and reconnect to the two pins of the PT100 (orientation is irrelevant here).

Change your pins.h and recompile in Marlin. Check your config.h as well - it must have the PT100 definition in there to work. You may have to use newer tables from Marlin which has the PT100 (but don't use the newest Marlin set since it is sure to fail on compile - just add the sensor table alone).

This setup worked for me. I hope this helps you.

Rex

nickhuanghq
Posts: 4
Joined: Thu Feb 02, 2017 12:05 pm

Re: Taz 5 e3Dv6 PT100 Thermocouple

Post by nickhuanghq » Mon Feb 06, 2017 3:30 pm

Hi Rex,

Thanks for your input. I'm glad that someone has been successful in this upgrade. I appreciate all the information, it will be very helpful once the parts come in and I begin the build.

Can you clarify on the tables? How would I go about updating those if necessary?

rexsolomon
Posts: 12
Joined: Sun Aug 14, 2016 6:42 am

Re: Taz 5 e3Dv6 PT100 Thermocouple

Post by rexsolomon » Tue Feb 07, 2017 4:45 pm

Hello Nick,

I can sympathize, since my very first post in this forum was on exactly the same problem. The PT100 is not defined in the original Taz 5 Marlin code.

So you have to look for the newer thermistor tables, one that has the PT100 definitions. What I did was to just copy that information over, editing the tables.h, config.h and pins.h (there may be others I can't remember right now) rather than using the newest .h files.

I used to be a programmer, so it wasn't that much of a big deal. You may need help if you don't code, since an errant character or space will mess your compile.

Best keep separate folders for your existing setup. Make a new Marlin folder named for each improvement (i.e. PT100 board + sensor), so that if you ever need to roll back to the Hexagon, you can compile from your older folder and you won't get the Maxtemp error message when Taz5 boots up.

I hope this helps.

Best,

Rex

nickhuanghq
Posts: 4
Joined: Thu Feb 02, 2017 12:05 pm

Re: Taz 5 e3Dv6 PT100 Thermocouple

Post by nickhuanghq » Tue Apr 18, 2017 2:39 pm

Rex,

I just got all the hardware install thanks to your help.

Where did you download your version of Marlin that also includes PT100 definition?

rocketman123
Posts: 8
Joined: Mon Jan 15, 2018 3:33 pm

Re: Taz 5 e3Dv6 PT100 Thermocouple

Post by rocketman123 » Fri Jan 19, 2018 3:33 pm

Hello,

I am having the same issue having my PT100 thermistor as well. I am getting a MINTEMP error. Did you resolve your issue?

mikronano
Posts: 63
Joined: Wed May 13, 2015 2:42 pm
Location: Chicago, IL

Re: Taz 5 e3Dv6 PT100 Thermocouple

Post by mikronano » Fri Jan 19, 2018 4:22 pm

Hi all. I have described this exact upgrade in an older thread. You might find something there to help you out:
"TAZ6 Thermocouple with MAX6675 installation"
viewtopic.php?f=7&t=7019

@rocketman123: I believe the description in the aforementioned thread will help you with your MINTEMP error and the temperature ceiling. My guess for the error you're getting is that you haven't updated the information in the "pins.h" file.

Best of luck all
Press a key to continue or any other key to quit

rocketman123
Posts: 8
Joined: Mon Jan 15, 2018 3:33 pm

Re: Taz 5 e3Dv6 PT100 Thermocouple

Post by rocketman123 » Tue Jan 23, 2018 10:21 am

I changed the pins.h file to:

#define HEATER_0_PIN 9
#define TEMP_0_PIN 5

and it worked! 8-)

but, the wire snapped on the PT100 and I need to order a new one. Any suggestions?

Thanks, mikronano.

Post Reply