Rambo 1.0e Marlin settings

A forum dedicated to the stock LulzBot AO-101/AO-100 3D Printer
Post Reply
drmacro
Posts: 50
Joined: Mon Apr 15, 2013 5:03 am

Rambo 1.0e Marlin settings

Post by drmacro » Tue Oct 03, 2017 7:22 am

I am in the process of replacing the hot end and need to re-load the Marlin code to the Rambo 1.0e board on my A-101.

I used the gcode to get settings from the currently loaded version, but that doesn't appear to give things like step settings for the motors, settings for the heatbed (and it's sensor). as well as whether the endstops use pullups. etc.

Is there a list of these settings anywhere?

or possibly a A-101 specific Marlin stash of the source code where I could plagiarize these settings?

Also, does anybody know if the current Marlin (1.1.x) code will even load on a Rambo 1.0e?

Mac

Brent.I
Aleph Objects | LulzBot
Posts: 502
Joined: Mon Jan 20, 2014 8:21 am

Re: Rambo 1.0e Marlin settings

Post by Brent.I » Tue Oct 03, 2017 7:46 am

You can find our last stable release of the A101 firmware here: http://download.lulzbot.com/AO-101/soft ... /firmware/

We haven't made any A101 Firmware with the 1.1.x firmware, and would recommend sticking with the tested firmware above.

drmacro
Posts: 50
Joined: Mon Apr 15, 2013 5:03 am

Re: Rambo 1.0e Marlin settings

Post by drmacro » Tue Oct 03, 2017 8:09 am

Brent.I wrote:
Tue Oct 03, 2017 7:46 am
You can find our last stable release of the A101 firmware here: http://download.lulzbot.com/AO-101/soft ... /firmware/

We haven't made any A101 Firmware with the 1.1.x firmware, and would recommend sticking with the tested firmware above.
Correct me if I'm wrong...but, using that code precludes any new features that Marlin might have added. For instance bed levelling.

Is the A101 version (apparently 1.0.0 of Marlin) that heavily modified for the the A101?

drmacro
Posts: 50
Joined: Mon Apr 15, 2013 5:03 am

Re: Rambo 1.0e Marlin settings

Post by drmacro » Tue Oct 03, 2017 10:14 am

I downloaded the A101 version of Marlin.

Got it to compile and upload. And did an autotune for my hotend. :)

Is there a #define that tells the code to turn the extruder fan on any time the hotend is turned on?

A M106S255 turns the fan on, so I can confirm it does turn on... but, it appears to be on or off since S127 doesn't slow the fan, but it stops.

Post Reply