Upgrading the firmware on the LulzBot Prusa

A forum dedicated to the stock LulzBot Prusa 3D Printer
User avatar
Orias
Aleph Objects | LulzBot
Posts: 1482
Joined: Wed Mar 27, 2013 1:24 pm
Location: US

Upgrading the firmware on the LulzBot Prusa

Post by Orias » Fri Aug 30, 2013 2:28 pm

We do not have a copy of the LulzBot Prusa firmware posted on download.lulzbot.com at this time. If you would like to change anything firmware related on your LulzBot Prusa you will need to start with a clean copy of the firmware. I've taken the liberty of preparing the Configuration.h file for you. Please keep in mind that the values may not be correct. This should be considered experimental. Your extruder will more than likely need to be recalibrated. A guide can be found here: richrap.blogspot.com/2012/01/slic3r-is-nicer-part-1-settings-and.html


You will need:
https://github.com/ErikZalm/Marlin/arch ... lin_v1.zip
Download and install this version of the Arduino IDE: http://download.lulzbot.com/AO-100/soft ... indows.zip
Digital calipers
Note taking equipment

Extract the Marlin folder using 7-zip or any other archive manager.

Navigate through the Marlin folder and rename the file named Configuration.h to Configuration.h.bak . This will serve as a backup of the original file. Copy the attached Configuration.h file into the current directory.

Connect the USB cable to the computer and the RAMPS electronics. The printer does not need to be plugged in at this time.

Open the Arduino IDE and open Marlin.ino.

Select Sketch > Verify/Compile.

Once finished select File > Upload. If you encounter errors you may want to hold the reset button on the board (if applicable) or plug in the board at the same time you select Upload.

Once the sketch is successfully flashed to the RAMPS electronics, unplug the USB cable from the RAMPS. Power on the printer and reconnect the USB cable. Connect to the printer In Pronterface

If you have trouble connecting, make sure that the baud rate selected is 115200. Once connected, Home the X axis. Be prepared to pull the power cable if the printer moves in the opposite direction. If the X Axis homes correctly, Home the Y axis, then the Z axis. Again, be prepared to cut power to the printer if the behavior is not correct. Contact support@lulzbot.com for help, post your Configuration.h file here or review the movement/endstop behavior in Configuration.h if you are comfortable doing so.

The max travel in the firmware is not currently set. Once the movement settings are verified correct and the endstops respond appropriately you can determine the maximum amount of travel for each axis. It is highly recommended that you set the range in Configuration.h on lines 326 - lines 336. You can determine the maximum range of travel by manually moving each axis in Pronterface and recording the travel. Once entered into Configuration.h, save and reflash the board using the same procedure you followed above. Home all three axes before testing the movement again.
Attachments
Configuration.h
Version 1, Current Marlin branch
(24.64 KiB) Downloaded 197 times

classicaviator
Posts: 5
Joined: Mon Sep 16, 2013 5:18 pm

Re: Upgrading the firmware on the LulzBot Prusa

Post by classicaviator » Tue Sep 17, 2013 10:30 am

Hey Orias,

I've gotten as far as running the Arduino IDE and verifying the sketch for the file you've specified. I've been able to successfully upload a Marlin.h update with the config file you've provided once, but noticed that Y and Z directions are reversed (pulled the power plug as you have suggested). Any suggestions on how to fix the direction issue? I am available to chat on the phone too if you have time - 206-953-4817. Thanks!

Stephan.

User avatar
Orias
Aleph Objects | LulzBot
Posts: 1482
Joined: Wed Mar 27, 2013 1:24 pm
Location: US

Re: Upgrading the firmware on the LulzBot Prusa

Post by Orias » Tue Sep 17, 2013 10:45 am

Lines 311-316 will need to be checked, if one of the axis is moving in the opposite direction, change the values and reflash the board.

classicaviator
Posts: 5
Joined: Mon Sep 16, 2013 5:18 pm

Re: Upgrading the firmware on the LulzBot Prusa

Post by classicaviator » Tue Sep 17, 2013 1:34 pm

Okay, one more issue. The printer axis work fine now, moving in correct directions and homing properly. Except I've noticed a bit of a bounce in each axis as it hits the stop. I've also noticed sloppy movements when printing a test part. Any thoughts?

User avatar
Orias
Aleph Objects | LulzBot
Posts: 1482
Joined: Wed Mar 27, 2013 1:24 pm
Location: US

Re: Upgrading the firmware on the LulzBot Prusa

Post by Orias » Tue Sep 17, 2013 2:18 pm

The bounce is a feature!

As each axis homes, it will do so kind of quickly. Once it activates the endstop, it will reverse direction, then re-approach the endstop at a slower rate, to help improve the consistency and accuracy of the homing towards the origin point.

You may want to try printing at a slower speed for right now, until you've tested the new firmware's operation. Can you post a video of what you mean by sloppy movements?

classicaviator
Posts: 5
Joined: Mon Sep 16, 2013 5:18 pm

Re: Upgrading the firmware on the LulzBot Prusa

Post by classicaviator » Tue Sep 17, 2013 4:26 pm

Printing at slower speeds works! I also went back to original 100% extrusion rate setting and that helped too. I guess having a more up-to-date firmware really makes a big difference. More to come!..

User avatar
Orias
Aleph Objects | LulzBot
Posts: 1482
Joined: Wed Mar 27, 2013 1:24 pm
Location: US

Re: Upgrading the firmware on the LulzBot Prusa

Post by Orias » Wed Sep 18, 2013 8:15 am

I'm glad to hear that. Just take it one tweak at a time!

classicaviator
Posts: 5
Joined: Mon Sep 16, 2013 5:18 pm

Re: Upgrading the firmware on the LulzBot Prusa

Post by classicaviator » Tue Sep 24, 2013 2:28 pm

Okay, one more big question. I recently started working with PLA (tonerplastics 87425 black PLA 3mm filament) and immediately started running into issues of extruder clogging. I initially started with lower temps (190-200) then increased slowly and now I'm up to 230. Still, the same problem. It seems to just bunch up in front of the extruder main plate (just bought a new one from you by the way). Any thoughts or suggestions? Thanks!

User avatar
Orias
Aleph Objects | LulzBot
Posts: 1482
Joined: Wed Mar 27, 2013 1:24 pm
Location: US

Re: Upgrading the firmware on the LulzBot Prusa

Post by Orias » Tue Sep 24, 2013 3:16 pm

You may want to mount a fan: https://www.lulzbot.com/support/3d-prin ... c-filament PLA holds onto heat rather well.

jebba
Site Admin
Posts: 689
Joined: Mon Mar 25, 2013 4:11 pm

Re: Upgrading the firmware on the LulzBot Prusa

Post by jebba » Tue Sep 24, 2013 9:57 pm

You definitely want to lower the temp. Start at 165C or 170C and work your way up. A fan helps, as noted above, or you can print faster. :) If you are printing fast enough, and it isn't over hot, it likely won't jam. If the printer is just sitting there, it is more prone to happening.

Post Reply