Lulzbot Mini requires huge maintenance

A forum dedicated to the stock LulzBot Mini 3D Printer
Keebie81
Posts: 80
Joined: Sat Dec 20, 2014 12:53 pm

Re: Lulzbot Mini requires huge maintenance

Post by Keebie81 » Tue Nov 27, 2018 8:50 pm

I dont see how that switch could have caused any of your issues. Thats the one on the right side of machine. The mini doesnt home to that side at all. The only purpose of that switch is to stop the toolhead from hitting right side of machine if code has it move outside its travel limit.

The mini homes to the rear left washer area. then travels to other spots. The only time it wont make it properly is if the steps/mm are off or theres some binding causes it not to move well.

IDEngineer wrote:
Wed Nov 14, 2018 8:16 pm
Lacking a second 3D printer to generate a "formal" part, and not knowing if the Lulzbot print file is still misdesigned to generate the bad part on my Mini, I resorted to the original 3D printing material - JBWeld! (Specifically, JBKwik so it didn't take 24 hours to cure.)

I first created a rough support structure to backstop the "extension" to the original, misdesigned Lulzbot part. Then I built a dam that extended the shape of the original part. Next I filled the dammed area and let it cure. Finally, I carefully hand filed the top (active) surface of the extension to be coplanar with the original part.

Here is the switch approaching the newly corrected 3D part:
Image

If you compare this to the photos in the earlier post, you can see that the extension fills in the curved-off area in the original, misdesigned Lulzbot part that was causing the problem.

In this next photo the switch has just barely been actuated. You can see that the switch has some overtravel - standard for microswitches like this.
Image

When fully depressed, the switch actuator is just barely below the surface of the switch body. This means something needs to absorb the force of the switch body hitting the original, misdesigned Lulzbot part in case the stepper doesn't stop fast enough. That's why I carefully filed the face of the new extension to be flat relative to the original Lulzbot part; if the carriage overtravels, you want the force to be taken by the original part, not the (somewhat cantilevered) extension.

And thus, at full travel, we have this:
Image

Now the switch body touches the original misdesigned Lulzbot part, the latter taking the force rather than the new extension.

After taking these photos I reconnected the Mini and ran through a test self-leveling cycle without filament (due to the separate filament problem). Success! All four washers are now properly touched by the end of the nozzle.

So it appears there are at least TWO possible causes for the Mini's failure to properly touch one or more washers. The first is the low-quality stepper motors whose shafts are subject to breakage, as documented in other threads herein. This second failure mechanism is this badly designed 3D part from Lulzbot. I'm not sure how this ever worked at all, but at least now we know what was wrong and how to fix it even if you only have one 3D printer available.

Hope this helps someone... thanks!

fastrobplus
Posts: 14
Joined: Thu Sep 27, 2018 10:57 am

Re: Lulzbot Mini requires huge maintenance

Post by fastrobplus » Fri Nov 30, 2018 12:29 am

My mini is an early 1.03 unit. I would say it's been fairly reliable.
Like everyone says:
-The early heat sink cooling was very inadequate.
-It's noisy.

IDEngineer
Posts: 33
Joined: Sun Feb 05, 2017 2:36 pm

Re: Lulzbot Mini requires huge maintenance

Post by IDEngineer » Sat Dec 01, 2018 11:27 am

Keebie81 wrote:
Tue Nov 27, 2018 8:50 pm
I dont see how that switch could have caused any of your issues. Thats the one on the right side of machine. The mini doesnt home to that side at all. The only purpose of that switch is to stop the toolhead from hitting right side of machine if code has it move outside its travel limit.
I believe the code for leveling "finds" the right side washers by using the switch. That's sure how it behaves, anyhow. Normally I would agree with you, that the switch only protects from over-extension due to bad GCode, but fixing it as shown instantly resolved the head positioning problems on the right side. YMMV.

Post Reply