New Marlin 2.0 G29 behaviour

Get answers & advice for all of your 3D printing & Free Software needs here!
Post Reply
User avatar
mrvanes
Posts: 144
Joined: Sun Sep 18, 2016 3:40 am

New Marlin 2.0 G29 behaviour

Post by mrvanes » Thu Jun 20, 2019 6:26 am

I just upgraded my Mini (1) to Marlin 2.0.0 using the Lulzbut Marlin git repo devel branch, which compiles nearly perfect (couple of warnings) and flashes well. There was one awkward change in G29 behaviour though:

My preprint custom g-gcode amongst other things puts everything in absolute mode (G90) homes all axis and heats to 170C to prepare for leveling with G29. Just before G29 I slowly retract some filament using G1 Z150 E-20 F25 and after this finishes start the G29, just like the original Lulzbot start g-code.

In the new firmware, the G29 nulls the E-20 of the previous move, the Z150 seems to be honoured but it may very well be eaten by the G29 as well, but there is no filament retract. I have to put an M400 after the G1 Z150 E-20 to succesfully retract 20mm of filament.

Does anybody know if this new behaviour is by-design?

User avatar
mrvanes
Posts: 144
Joined: Sun Sep 18, 2016 3:40 am

Re: New Marlin 2.0 G29 behaviour

Post by mrvanes » Fri Jun 21, 2019 11:11 am

Also, my mini now suffers from this issue: https://github.com/MarlinFirmware/Marlin/issues/12723
It's not bad enough to downgrade. Just a heads-up for those contemplating the upgrade.

Raised an issue for the encountered behaviour: https://github.com/MarlinFirmware/Marlin/issues/14355

User avatar
mrvanes
Posts: 144
Joined: Sun Sep 18, 2016 3:40 am

Re: New Marlin 2.0 G29 behaviour

Post by mrvanes » Wed Jun 26, 2019 12:54 am

The retract before probing bug has been fixed, as well as the FW_RETRACT micro pauses.

Post Reply