ColorChange plugin is bugged

Get answers & advice for all of your 3D printing & Free Software needs here!
Post Reply
NYCRepRapper
Posts: 2
Joined: Sat Aug 31, 2019 3:27 am

ColorChange plugin is bugged

Post by NYCRepRapper » Sat Aug 31, 2019 3:38 am

Using Cura Lulzbot Edition 3.6.18

I added a post-processing steps to do a Color change. There is a script actually named Color Change where you can enter the layer. I have used it a few times an noticed it always paused for color change a little earlier than i wanted. I defeated this by simply using a higher layer number, but this last time it paused at Layer 14, and not Layer 17 which i requested. I opened the G-Code, and sure enough, I found the plugin had inserted the color change command at Layer 14, despite me plugging in Layer 17.

(apparently this is a known bug in the Cura world, that may have been fixed but i think Lulzbot is using an old version of Cura)

all the plugin does, is insert the following line of Gcode- so its pretty easy to do that manually to your G-code at the correct layer:

M600 E300.00 L30.00 ; Generated by ColorChange plugin

Also note that G-Code layer's are zero based, and Cura is 1 based. So if your desired layer in Cura is 17, you need to put this snip at Layer 16: here is a snippet of my code (you can paste your M600 command after the MESH tag:

;LAYER:16
;MESH:
M600 E300.00 L30.00 ; Generated by ColorChange plugin
G0 X70.82 Y43.684 Z3.925

b-morgan
Posts: 302
Joined: Fri Aug 11, 2017 8:53 am

Re: ColorChange plugin is bugged

Post by b-morgan » Sun Sep 01, 2019 5:13 pm

ColorChange probably suffers from the same issue that PauseAtHeight suffered from. The changes to PauseAtHeightorLayer (or is it LayerorHeight) can be copied over to fix it. The issue has to do with rafts, start gcode Z changes, etc. The plugin needs to identify the "real" layer 1 and start counting from there.

Post Reply