Using Cura 2.3.1 with LulzBot 3D Printers

Get answers & advice for all of your 3D printing & Free Software needs here!
nickthetait
Aleph Objects | LulzBot
Posts: 168
Joined: Fri May 08, 2015 2:40 pm
Location: Fort Collins, CO
Contact:

Using Cura 2.3.1 with LulzBot 3D Printers

Post by nickthetait » Tue Nov 01, 2016 3:34 pm

Since my last update on Cura 2, there have been many great improvements made by Ultimaker. Version 2.3.1 was recently released so peruse the release notes https://ultimaker.com/en/products/cura- ... ease-notes. Most notably for LulzBot users, is the ability to create a custom printer without having to modify files. This makes using the software with non-Ultimaker printers much easier. Below is instructions on how to configure it. Please post questions and any problems you run into.
  1. Download version 2.3.1 from software.ultimaker.com
  2. Install Cura like you would any other software on your platform
  3. Launch Cura
  4. Create a configuration for your printer
    Settings -> Printer -> Add Printer ...
    Custom -> Custom FDM printer
    Give your printer configuration a name (in the lower left corner)
    Add Printer
    Now grab settings from your current slicer (here is a screenshot with Cura LulzBot Edition on the left and Ultimaker's Cura v2.3 on the right, using settings for a LulzBot Mini)
    Migrating-Machine-Settings.png
    The most important number to enter is your nozzle size! Most LulzBots use 0.5, but some of the older TAZs are 0.35
    before closing that window you still need to:
  5. Insert the Start and End GCODE sections
    Download a profile of your favorite printer and material from http://download.lulzbot.com/print-profiles/cura/
    Extract the start/end gcode then paste into the appropriate boxes of Cura
    Some of the settings have changed names, so in the start section you need to modify these two variable names. Note: some profiles reference these variables more than once.
    print_bed_temperature -> material_bed_temperature
    print_temperature -> material_print_temperature
    Should now look something like this:
    Done-migrating.png
    Check these links to read more about the inner workings of GCODE specifically for Mini and TAZ 6

    Close Machine Settings window
    Close Preferences window
  6. Import a profile
    Settings -> Profile -> Manage Profiles...
    Import
    (Down at the bottom) change "Files of type" field to "Cura 15.04 profiles (*.ini)"
    Navigate to, then select the profile which you downloaded earlier
    Open
    Close preferences window
  7. Prepare to print
    (In right hand panel, near the top) Change the "Profile" field to the one you just imported
    Disable "Print Build Plate Adhesion"
    Load a model with File -> Open File
    Save the sliced GCODE file somewhere (SD card or your file system)
  8. Start printing and experimenting!
    Rocktopus.png
Challenges
Many of the below problems will be fixed over time, but they have not been taken care of yet.

Interoperability
* On Linux, Cura 2.3 cannot be installed side by side with existing Cura Original
* Cura 2.3 automatically attempts to connects with printers when it is started up, so ongoing USB print jobs may be killed

Performance – Compared to 2.1, significant improvements have been made. However not all features are faster then the previous generation of Cura.

Regressions – these features were not deliberately removed, they just have not been re-implemented on the new code base yet. Compared to 2.1 there are less.
* Minimal print controller interface
* No way to import/display GCODE files

Experimentation/Ease of use –
LulzBot profiles include a wipe temperature in the start gcode section, this number is material specific. Until this is extracted as a setting of the User Interface, it is difficult to swap between materials. For now you will have to open the printer settings and modify this hard-coded number in the start GCODE section :o

Z-offsets may require tweaking to achieve optimal first layer adhesion


Caveats
This has only been tested on Linux (Debian Jessie). But everything *should* work the same on other platforms.
Do not trust the GCODE that it produces. There may be bugs lurking, so please do not start a multi-day print then leave your printer unattended!

"What happened to version 2.2?" you ask. Well, a PinkUnicorn had a nasty collision with a train. The mythical being is fine, but the SteamEngine had to be completely re-built. It was a mess.... please don't ask about it.

Edit: add a few links
Edit2: version 2.3.1 is now released, updated information

martinbogo
Posts: 26
Joined: Sun Jun 21, 2015 12:03 pm

Re: Using Cura 2.3 with LulzBot 3D Printers

Post by martinbogo » Tue Nov 22, 2016 5:01 pm

Cura 2.3.1 was released --- any updates?

nickthetait
Aleph Objects | LulzBot
Posts: 168
Joined: Fri May 08, 2015 2:40 pm
Location: Fort Collins, CO
Contact:

Re: Using Cura 2.3.1 with LulzBot 3D Printers

Post by nickthetait » Wed Nov 30, 2016 11:17 am

Good question martinbogo. 2.3.1 solves a few problems and simplifies a few steps. I have edited my post to reflect this.

konsumkid
Posts: 7
Joined: Sun Dec 11, 2016 11:27 am

Re: Using Cura 2.3.1 with LulzBot 3D Printers

Post by konsumkid » Sun Dec 11, 2016 11:59 am

I'm right that there is no dual extruder support? i installed a new printer but no option for second print head..

nickthetait
Aleph Objects | LulzBot
Posts: 168
Joined: Fri May 08, 2015 2:40 pm
Location: Fort Collins, CO
Contact:

Re: Using Cura 2.3.1 with LulzBot 3D Printers

Post by nickthetait » Tue Dec 13, 2016 10:27 am

There is support for Dual extrusion, but these items are deliberately hidden for printers which don't have multiple nozzles configured. So far it is not possible to change the number of nozzles by using Cura itself, you need to modify some files which is quit messy. You can take a peek at the available multi-extrusion settings from "Settings" -> "Configure settings visibility..." page. Here's a screenshot
Screenshot.png

vesteroid
Posts: 11
Joined: Sun Jan 01, 2017 4:47 pm

Re: Using Cura 2.3.1 with LulzBot 3D Printers

Post by vesteroid » Sun Mar 12, 2017 7:14 pm

tried this with the 2.4 version that is on the site now, and I get a fan min / max error every time I try to slice looks like the max is set in mm somehow and not %

Not sure how to fix it

tastycode
Posts: 1
Joined: Sun Mar 26, 2017 10:14 pm

Re: Using Cura 2.3.1 with LulzBot 3D Printers

Post by tastycode » Sun Mar 26, 2017 10:25 pm

@vesteroid: All I did to get the fan min / max error to go away was change the number in "Regular/Maximum Fan Speed Threshold" to 30.

I'm actually printing right now with the latest version of Cura (2.4). My steps are pretty similar to the initial post in this thread, but here's an overview.

1. Add a custom printer
2. Copy the settings you see in the 2.1 version of Cura to the Machine Settings page (See screenshot)
3. For the gcode, just go to the 2.1 version of cura in expert mode and go to the "Start/End Gcode" section. Copy the both gcode sections into Cura 2.4.
4. Import a taz 5 profile
5. You'll get an error for "fan min / max". Solve it as above (You can find fan by going to custom and searching for fan, the field with the error will be in red..)
6. Click "Print via USB".

Cura will say "Not connected to a printer", but the Taz will actually print. No control panel though.. so, not sure if the print messes up how i'll abort everything. If you close Cura completely, it'll stop printing as well. I might just keep simplify3d open, because its control panel works fine (and doesn't have that annoying delay in "Connecting" that Cura 2.1 had.

Image

wedge
Posts: 2
Joined: Wed Apr 27, 2016 11:56 am

Re: Using Cura 2.3.1 with LulzBot 3D Printers

Post by wedge » Sat Apr 15, 2017 1:12 am

I tried printing with 2.4 and it was printing really erratic. very jumpy and not smooth. Can anyone who's had success post their machine profile and print profiles?
Using Taz 5

kmanley57
Posts: 1080
Joined: Sun Feb 01, 2015 3:53 pm

Re: Using Cura 2.4 and OctoPrint with LulzBot 3D Printers

Post by kmanley57 » Sat Apr 15, 2017 2:47 pm

I made these today.

Taz 6:

Forgot to enable the web Cam before I started the print.
Capture-1.PNG
Mini:
Capture.PNG
I will express my CRAZY ideas at any time! So you have been warned. None of my opinions are Lulzbots and can be wrong at any second.

akrumsee
Posts: 12
Joined: Fri Jul 01, 2016 1:38 pm

Re: Using Cura 2.3.1 with LulzBot 3D Printers

Post by akrumsee » Sat Apr 29, 2017 12:05 pm

Just getting started with this. Two quick questions:

1) I see that on the Ultimaker site they are now making a 2.5 version of Cura available. Should I stick with 2.3.1 for this effort or experiment with 2.5?
2) When I look at the Taz6 profiles I see sections like start2.gcode and end3.gcode. Do I include those in what I paste into Cura's start and end gcode sections? Or do I just include "start.gcode" and "end.gcode"?

Post Reply