Changing Taz 5 Ceiling Temperature

Get answers & advice for all of your 3D printing & Free Software needs here!
rocketman123
Posts: 8
Joined: Mon Jan 15, 2018 3:33 pm

Changing Taz 5 Ceiling Temperature

Post by rocketman123 » Mon Jan 15, 2018 5:09 pm

Hello everyone,

I am very new to all of this but I want to modify the Marlin software and change the Heater & Bed temperature of my stock Lulzbot Taz v5 printer. I am trying to push the capabilities of my machine and change the max temperature of heater to be 350 degrees Celsius and change the bed max temperature to 150 degrees Celsius. I currently have Arduino IDE 1.8.5 and have some versions of Marlin that are supposed to be compatible with the Lulzbot Taz 5, however I am having problems with verifying and uploading the Marlin after I change the max temperatures. Has anyone had this similar issue? Does anyone know where I can find a reliable Marlin file that has the stock settings for the TAZ 5? Again, I am a super newbie at this and I could be making a minor mistake and not be catching it. I have been successful on uploading a Marlin and making the necessary changes in the firmware but after I uploaded the firmware through the Arduino IDE environment it causes my printer to have a MINTEMP error when I open up Cura and also causes the LCD screen to be unresponsive. I fix this issue by opening up Cura and installing the default firmware. Has anyone encountered this problem before?

If someone knows what problems I am going through and has an easy solution I would be very grateful because at the moment I have spent so many hours trying to get this work and I am getting no where even after watching countless youtube videos and looking at some other forum threads. Again, I am super new at this so please respond in layman's terms.

Thank you for your time.

User avatar
Orias
Aleph Objects | LulzBot
Posts: 1339
Joined: Wed Mar 27, 2013 1:24 pm
Location: US

Re: Changing Taz 5 Ceiling Temperature

Post by Orias » Tue Jan 16, 2018 8:20 am

Your Arduino IDE may need additional libraries to compile the firmware correctly. We have a guide available here on adding them: https://ohai.lulzbot.com/project/arduin ... -flashing/

However, before you continue, why are you setting the hot end and heated bed max temp so high? The hot end thermistor will not read over 300C. The bed should not go that high either. What are you looking to do with this tweaked firmware?

Some advanced users have modified their LulzBot 3D Printers to reach massively higher temps, but for your stock TAZ 5 it is not recommended. Here's how some of our more advanced users did so: https://www.lulzbot.com/learn/NASA-high ... e-printing

Depending on what you're trying to accomplish we can make some recommendations that will be safer for your printer.

rocketman123
Posts: 8
Joined: Mon Jan 15, 2018 3:33 pm

Re: Changing Taz 5 Ceiling Temperature

Post by rocketman123 » Tue Jan 16, 2018 1:36 pm

Thank you, Orias.

I added the libraries to compile the firmware correctly however when I went to upload the Marlin it caused the printer to be unresponsive. Any clue on why that is?

I need to reach these high temperatures for the filament I am using. What about going slightly over the 300 degrees Celsius, like 310? I looked at the NASA document and I am trying to do something similar.

Thanks,
rocketman123

User avatar
Orias
Aleph Objects | LulzBot
Posts: 1339
Joined: Wed Mar 27, 2013 1:24 pm
Location: US

Re: Changing Taz 5 Ceiling Temperature

Post by Orias » Tue Jan 16, 2018 1:43 pm

What material are you trying to use? You'll need to explore reprinting the tool head potentially, in a different material, or add enough cooling to ensure that the hot end does not soften the extruder body.

Additionally, the hot end temperature limitation is due to the thermistor, which has a 300C upper limit. You'd need to replace that with a different sensing component, like another thermistor, RTD sensor, or thermocouple: https://dyzedesign.com/2016/06/comparis ... rs-part-1/

Your marlin selections may not be compatible, without posting your configuration.h file or a better yet a diff, it's going to be hard for anyone to assist.

rocketman123
Posts: 8
Joined: Mon Jan 15, 2018 3:33 pm

Re: Changing Taz 5 Ceiling Temperature

Post by rocketman123 » Tue Jan 16, 2018 7:31 pm

It's a material that requires slightly above 300 degrees Celsius.

Attached is my configuration folder. I got this file from an online data base: http://download.lulzbot.com/TAZ/5.0_0.5 ... .1/Marlin/

Thanks
Attachments
Configuration.h
(30.84 KiB) Downloaded 18 times

rocketman123
Posts: 8
Joined: Mon Jan 15, 2018 3:33 pm

Re: Changing Taz 5 Ceiling Temperature

Post by rocketman123 » Wed Jan 17, 2018 1:34 pm

I used the Marlin from here: https://github.com/commonslabgr/marlin_taz and followed this method: https://ohai.lulzbot.com/project/firmwa ... -flashing/

And was successful in uploading the Marlin. Now I am just going to adjust the max temperatures.

User avatar
Orias
Aleph Objects | LulzBot
Posts: 1339
Joined: Wed Mar 27, 2013 1:24 pm
Location: US

Re: Changing Taz 5 Ceiling Temperature

Post by Orias » Fri Jan 19, 2018 12:57 pm

Glad you're rolling through it! Remember, the fewer variables you change at once, the easier future troubleshooting will be.

rocketman123
Posts: 8
Joined: Mon Jan 15, 2018 3:33 pm

Re: Changing Taz 5 Ceiling Temperature

Post by rocketman123 » Fri Jan 19, 2018 1:25 pm

Yeah I am trying! So now I am having an issue with the heater nozzle temperature. I have an E3D volcano kit. I have a PT100 thermistor and I changed the pin.h to this:
#define HEATER_0_PIN 9
#define TEMP_0_PIN 93 //0

I also changed the configuration.h:
//===========================================================================
//=============================Thermal Settings ============================
//===========================================================================
//
//--NORMAL IS 4.7kohm PULLUP!-- 1kohm pullup can be used on hotend sensor, using correct resistor and table
//
//// Temperature sensor settings:
// -2 is thermocouple with MAX6675 (only for sensor 0)
// -1 is thermocouple with AD595
// 0 is not used
// 1 is 100k thermistor - best choice for EPCOS 100k (4.7k pullup)
// 2 is 200k thermistor - ATC Semitec 204GT-2 (4.7k pullup)
// 3 is mendel-parts thermistor (4.7k pullup)
// 4 is 10k thermistor !! do not use it for a hotend. It gives bad resolution at high temp. !!
// 5 is 100K thermistor - ATC Semitec 104GT-2 (Used in ParCan & J-Head) (4.7k pullup)
// 6 is 100k EPCOS - Not as accurate as table 1 (created using a fluke thermocouple) (4.7k pullup)
// 7 is 100k Honeywell thermistor 135-104LAG-J01 (4.7k pullup)
// 71 is 100k Honeywell thermistor 135-104LAF-J01 (4.7k pullup)
// 8 is 100k 0603 SMD Vishay NTCS0603E3104FXT (4.7k pullup)
// 9 is 100k GE Sensing AL03006-58.2K-97-G1 (4.7k pullup)
// 10 is 100k RS thermistor 198-961 (4.7k pullup)
// 60 is 100k Maker's Tool Works Kapton Bed Thermister
//
// 1k ohm pullup tables - This is not normal, you would have to have changed out your 4.7k for 1k
// (but gives greater accuracy and more stable PID)
// 51 is 100k thermistor - EPCOS (1k pullup)
// 52 is 200k thermistor - ATC Semitec 204GT-2 (1k pullup)
// 55 is 100k thermistor - ATC Semitec 104GT-2 (Used in ParCan & J-Head) (1k pullup)


#define TEMP_SENSOR_0 20 //5 to 20
//~ #define TEMP_SENSOR_1 5
//~ #define TEMP_SENSOR_2 0
#define TEMP_SENSOR_BED 7

and I have the thermistortables.h:

#if (THERMISTORHEATER_0 == 20) || (THERMISTORHEATER_1 == 20) || (THERMISTORHEATER_2 == 20) || (THERMISTORBED == 20) // PT100 with INA826 amp on Ultimaker v2.0 electronics
/* The PT100 in the Ultimaker v2.0 electronics has a high sample value for a high temperature.
This does not match the normal thermistor behaviour so we need to set the following defines */
#if (THERMISTORHEATER_0 == 20)
# define HEATER_0_RAW_HI_TEMP 16383
# define HEATER_0_RAW_LO_TEMP 0
#endif
#if (THERMISTORHEATER_1 == 20)
# define HEATER_1_RAW_HI_TEMP 16383
# define HEATER_1_RAW_LO_TEMP 0
#endif
#if (THERMISTORHEATER_2 == 20)
# define HEATER_2_RAW_HI_TEMP 16383
# define HEATER_2_RAW_LO_TEMP 0
#endif
#if (THERMISTORBED == 20)
# define HEATER_BED_RAW_HI_TEMP 16383
# define HEATER_BED_RAW_LO_TEMP 0
#endif
const short temptable_20[][2] PROGMEM = {
{ 0*OVERSAMPLENR , 0 },
{ 227*OVERSAMPLENR , 1 },
{ 236*OVERSAMPLENR , 10 },
{ 245*OVERSAMPLENR , 20 },
{ 253*OVERSAMPLENR , 30 },
{ 262*OVERSAMPLENR , 40 },
{ 270*OVERSAMPLENR , 50 },
{ 279*OVERSAMPLENR , 60 },
{ 287*OVERSAMPLENR , 70 },
{ 295*OVERSAMPLENR , 80 },
{ 304*OVERSAMPLENR , 90 },
{ 312*OVERSAMPLENR , 100 },
{ 320*OVERSAMPLENR , 110 },
{ 329*OVERSAMPLENR , 120 },
{ 337*OVERSAMPLENR , 130 },
{ 345*OVERSAMPLENR , 140 },
{ 353*OVERSAMPLENR , 150 },
{ 361*OVERSAMPLENR , 160 },
{ 369*OVERSAMPLENR , 170 },
{ 377*OVERSAMPLENR , 180 },
{ 385*OVERSAMPLENR , 190 },
{ 393*OVERSAMPLENR , 200 },
{ 401*OVERSAMPLENR , 210 },
{ 409*OVERSAMPLENR , 220 },
{ 417*OVERSAMPLENR , 230 },
{ 424*OVERSAMPLENR , 240 },
{ 432*OVERSAMPLENR , 250 },
{ 440*OVERSAMPLENR , 260 },
{ 447*OVERSAMPLENR , 270 },
{ 455*OVERSAMPLENR , 280 },
{ 463*OVERSAMPLENR , 290 },
{ 470*OVERSAMPLENR , 300 },
{ 478*OVERSAMPLENR , 310 },
{ 485*OVERSAMPLENR , 320 },
{ 493*OVERSAMPLENR , 330 },
{ 500*OVERSAMPLENR , 340 },
{ 507*OVERSAMPLENR , 350 },
{ 515*OVERSAMPLENR , 360 },
{ 522*OVERSAMPLENR , 370 },
{ 529*OVERSAMPLENR , 380 },
{ 537*OVERSAMPLENR , 390 },
{ 544*OVERSAMPLENR , 400 },
{ 614*OVERSAMPLENR , 500 },
{ 681*OVERSAMPLENR , 600 },
{ 744*OVERSAMPLENR , 700 },
{ 805*OVERSAMPLENR , 800 },
{ 862*OVERSAMPLENR , 900 },
{ 917*OVERSAMPLENR , 1000 },
{ 968*OVERSAMPLENR , 1100 }
};
#endif

Did I miss anything?

Again, I can't stress how new I am to this.

So right now as is when I run and upload the Marlin I get a Mintemp error. I don't know if my PT100 thermistor is broken. I also have a some other thermistors that have a blue wire and copper cylinder. I am not too sure if those are also PT100 thermistors.

Again, thanks. Any help, helps!

User avatar
Orias
Aleph Objects | LulzBot
Posts: 1339
Joined: Wed Mar 27, 2013 1:24 pm
Location: US

Re: Changing Taz 5 Ceiling Temperature

Post by Orias » Fri Jan 19, 2018 1:36 pm

You're going to need additional hardware to use that sensor. From: https://e3d-online.com/pt100-sensor-cartridge
Please be aware that a PT100 is not the same as a thermistor and unless your electronics explicitly supports RTD Sensing devices you will need an amplifier board.
This thread may help you out: https://e3d-online.dozuki.com/Wiki/E3D_ ... umentation Note, this thread refers to RAMPS, while your TAZ 6 uses the RAMBo electronics.

Since this is a modification we've have not performed ourselves, it's going to be hard to make recommendations.
It's a material that requires slightly above 300 degrees Celsius.
...
Again, I can't stress how new I am to this.
What material are you trying to use? More specific information will help, as there may be a way you can print this with one of our tool heads. The MOARstruder Tool Head for example has a massive, extra-long heater block. This lets the MOARstruder 3D print polycarbonate at 250C, instead of the typical 290C.

rocketman123
Posts: 8
Joined: Mon Jan 15, 2018 3:33 pm

Re: Changing Taz 5 Ceiling Temperature

Post by rocketman123 » Tue Jan 23, 2018 10:13 am

There was a PT100 sensor "thermistor" already inside the lulzbot(it has been modified before). What happened was I was using the printer and ended up doing a default firmware reflash through cura therefore making it a stock lulzbot firmware wise. This limited our high temperature capabilities all together. I was new at Arduino and Marlin but I have got it working now and managed to get a reading from the PT100 sensor installed at 350C. I fixed the error by changing the pins.h file under the motherboard 301 section:

#define HEATER_0_PIN 9
#define TEMP_0_PIN 5

and of course changing the configuration.h file in the thermal setting section:

//20 PT100 with INA826 amp on Ultimaker v2.0 electronics

#define TEMP_SENSOR_0 20
//#define TEMP_SENSOR_1 5
//#define TEMP_SENSOR_2 0
#define TEMP_SENSOR_BED 7

Oh also make sure to double check the thermistortables.h and make sure the 20 you are calling out is there and that it is the PT100.

BUT the metal wire came out of the sensor and now I need a new PT100 sensor because I get a maxtemp error indicating that my sensor is broken. I just need to order a new one and I should be good.

Thanks Orias for your feedback and help! :D

I am using a material similar to what NASA used in this: https://www.lulzbot.com/learn/NASA-high ... e-printing

Post Reply