Page 1 of 1

Problem installing Cura Luzbot Edition on Ubuntu 18.10

Posted: Sat Dec 01, 2018 11:46 am
by mcamou
Hi,

I'm trying to install Cura Lulzbot Edition on my Ubuntu 18.10 (cosmic) laptop. I've added the following to /etc/apt/sources.list.d/cura-lulzbot.list:

Code: Select all

deb http://download.alephobjects.com/ao/aodeb stretch main
After doing apt update I get the following:

Code: Select all

# apt install cura-lulzbot
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 cura-lulzbot : Depends: libssl1.0.2 but it is not installable
E: Unable to correct problems, you have held broken packages.

Re: Problem installing Cura Luzbot Edition on Ubuntu 18.10

Posted: Mon Dec 03, 2018 8:25 am
by Galadriel
Sorry to hear about the difficulty! It sounds like this is the same issue as was reported here: https://code.alephobjects.com/T4636
On that page there is a link to the debian package you should need to resolve this. I am also including the link here just for the sake of ease: https://packages.debian.org/buster/libssl1.0.2

Re: Problem installing Cura Luzbot Edition on Ubuntu 18.10

Posted: Mon Dec 03, 2018 9:37 am
by mcamou
Wouldn't it be better to depend on a proper Ubuntu package instead of a Debian dependency that has to be manually installed? Say https://packages.ubuntu.com/cosmic/libssl1.0.0. Also, if something needs to be done, the article should be updated accordingly.

Re: Problem installing Cura Luzbot Edition on Ubuntu 18.10

Posted: Tue Dec 04, 2018 9:48 am
by alexei
mcamou wrote:
Mon Dec 03, 2018 9:37 am
Wouldn't it be better to depend on a proper Ubuntu package instead of a Debian dependency that has to be manually installed? Say https://packages.ubuntu.com/cosmic/libssl1.0.0. Also, if something needs to be done, the article should be updated accordingly.
Hi mcamou,
We are building CuraLE on Debian buster, therefore all the dependencies are taken from Debian, not Ubuntu.
I have added libssl1.0.2 to our repo.
Also I noticed you do have a stretch repo added in your first comment. since 18.10 is based on buster, the repo line should be

Code: Select all

deb http://download.alephobjects.com/ao/aodeb buster main

Re: Problem installing Cura Luzbot Edition on Ubuntu 18.10

Posted: Tue Dec 04, 2018 10:54 am
by mcamou
Great! Thanks @alexei. I was able to install it now. Perhaps it would be a good idea to update https://www.lulzbot.com/learn/tutorials ... ion-ubuntu ? That's where I got the installation instructions from (and the first result when Googling "install cura lulzbot linux").