Cura 3.6.13 consistent print failure due to E-

Get answers & advice for all of your 3D printing & Free Software needs here!
Post Reply
Malwolficus
Posts: 3
Joined: Thu Jun 06, 2019 12:35 pm

Cura 3.6.13 consistent print failure due to E-

Post by Malwolficus » Mon Aug 05, 2019 11:44 am

We've had an abundance of print failures since upgrading to Cura 3.6.13 and we've noticed that it has *got* to be the filament extraction protocol. If, when the print is just starting, we quickly snap open the filament clasp and push the filament down until it stops, all prints work as expected. If we don't, filament just sputters and doesn't feed properly.

We suspect that the initial pre-wipe GCODE is over-retracting. Here's what we see in a typical gcode file, pre-wipe (note that we have a dual extruder):

G1 E-15 F100 ; suck up XXmm of filament
T1 ; switch extruders
M82 ; set extruder to absolute mode
G92 E0 ; set E to 0
G1 E-15 F100 ; suck up filament

So TWICE we push filament back OUT of the extruder for 100. Twice. This seems excessive, and while I can manually edit the gcode it seems like this should at LEAST be an option that I can turn off somewhere....

b-morgan
Posts: 317
Joined: Fri Aug 11, 2017 8:53 am

Re: Cura 3.6.13 consistent print failure due to E-

Post by b-morgan » Mon Aug 05, 2019 8:16 pm

The gcode you posted extracts each extruder 15mm. The F100 is the feed rate.

There should be 3 lines (I added them in the first code block below) before the ones you posted. Each extruder is set to absolute mode, zeroed, and then retracted.

I don't have any problems with my dual extruder V3 using this start code.

Further down in the start gcode is the second code block below which feeds the 15mm retracted above back and then extrudes 15mm more from each extruder (while hanging over the edge) and then attempts to shear the filament off against the edge of the bed.

If your start gcode matches mine, then I can't explain why you need the extra manual help. I don't believe it is the extraction protocol. You can edit the start gcode to do less retraction at the beginning (-15 -> -10) and purge more (-15 -> -20) at the end.

Code: Select all

T0                           ; select this extruder first
M82                          ; set extruder to absolute mode
G92 E0                       ; set extruder to zero
G1  E-15 F100                ; suck up XXmm of filament
T1                           ; switch extruders
M82                          ; set extruder to absolute mode
G92 E0                       ; set extruder to zero
G1  E-15 F100                ; suck up XXmm of filament

Code: Select all

T0                           ; select this extruder first
G1  E0 F100                  ; undo retraction
G92 E-15                     ; set extruder negative amount to purge
G1  E0 F100                  ; purge XXmm of filament
T1                           ; switch to second extruder
G92 E-15                     ; reset global E
G1  E0 F100                  ; undo retraction
G92 E-15                     ; set extruder negative amount to purge
G1  E0 F100                  ; purge XXmm of filament

Malwolficus
Posts: 3
Joined: Thu Jun 06, 2019 12:35 pm

Re: Cura 3.6.13 consistent print failure due to E-

Post by Malwolficus » Tue Aug 06, 2019 7:49 am

My gcode is very similar to yours (a few extra lines). I'll just plan on manually editing the code - but it *would* be nice if Cura had an option for controlling the amount of retraction. Who can I suggest that to?

b-morgan
Posts: 317
Joined: Fri Aug 11, 2017 8:53 am

Re: Cura 3.6.13 consistent print failure due to E-

Post by b-morgan » Tue Aug 06, 2019 10:30 pm

Send your concerns to support@lulzbot.com

JoeBowler300
Posts: 119
Joined: Thu Apr 28, 2016 12:20 am

Re: Cura 3.6.13 consistent print failure due to E-

Post by JoeBowler300 » Wed Aug 07, 2019 1:24 am

You say TWICE but you don't show all the detail.

Here's more of the section that you left out:

T0 ; select this extruder first
M82 ; set extruder to absolute mode
G92 E0 ; set extruder to zero
G1 E-15 F100 ; suck up XXmm of filament
T1 ; switch extruders
M82 ; set extruder to absolute mode
G92 E0 ; set extruder to zero
G1 E-15 F100 ; suck up XXmm of filament

The first "suck up XXmm of filament" belongs to the first extruder (T0),
The second "suck up XXmm of filament" belongs to the 2nd extruder (T1).

No need to bother with support@lulzbot.com just change that E-15 value where you found it;
Settings > Printer> Manage Printers > LulzBot Taz 6 Dual Extruder v3 > General > Machine Settings

However I doubt this is your problem. This setting has been there since the Dual Extruder v3 came out.
If you didn't just change the filament (and failed to feed it all the way through), then you need to "prime" the extruders before you print.

After loading your model into the virtual build plate under the Monitor tab
Go to your printing options on the right side then,
Go to Build Plate Adhesion
Set it to Skirt
Line Count 1
Skirt/Brim Minimum length 25mm

Those are the minimum settings you can set it to and will prime your extruder just before printing your project file.

I don't see any point of extruding more than the minimum as you just need to get the flow going; anything beyond that is a waste.

Post Reply