Odd Manual Stepper Movement after Marlin 1.1.6+

Want to use the Open Source Hardware documentation to make your LulzBot 3D Printer do even more? Start here!
Post Reply
Rp1030
Posts: 94
Joined: Tue Apr 28, 2015 9:20 am

Odd Manual Stepper Movement after Marlin 1.1.6+

Post by Rp1030 » Sun Aug 18, 2019 6:52 pm

I thought that creating a specific thread for my situation would help. Outsourcing if you will call it that, so...

Upon installing Marlin 1.1.6 and/or 1.1.9 I ham having issues with the movement of my steppers (in any axis direction).
There is a delay after each input from the encoder, and each input (no matter the value) will only move the axis by a few mm.

I've posting a video to demonstrate the problem.
https://streamable.com/w4fit

I have a TAZ 5 with the Openbuilds x and y axis mod, my own custom optical sensor probe, and an Aluminum Heated Bed.
Within Marlin, I have these values.

Code: Select all

DEFAULT_AXIS_STEPS_PER_UNIT   { 100.5, 100.5, 1600, 866 }
ENCODER_PULSES_PER_STEP 3
ENCODER_STEPS_PER_MENU_ITEM 1
Babystepping is commented
DogLCD is commented
UltraLCD is commented

Thanks, and I appreciate any help I can get.

jimbalny
Posts: 15
Joined: Tue Apr 14, 2015 5:27 am

Re: Odd Manual Stepper Movement after Marlin 1.1.6+

Post by jimbalny » Sun Aug 25, 2019 1:17 pm

Have you considered trying the new version of marlin 2.0? https://github.com/SBachman/BLTouch-Taz-5 is a good place to start as he has bed leveling enabled, also recommend enabling z babystepping - it's been super handy on my taz 5 with BLTouch.

Rp1030
Posts: 94
Joined: Tue Apr 28, 2015 9:20 am

Re: Odd Manual Stepper Movement after Marlin 1.1.6+

Post by Rp1030 » Mon Aug 26, 2019 7:39 pm

Thanks. Will try this soon

Rp1030
Posts: 94
Joined: Tue Apr 28, 2015 9:20 am

Re: Odd Manual Stepper Movement after Marlin 1.1.6+

Post by Rp1030 » Sun Oct 13, 2019 3:37 pm

I am still working on this and one part of the firmware is and has been making me wonder..

Line 601 - 603 in Configuration H where I define my stepper driver.
"a4988 is assumed for undefined drivers" so if I leave this commented, well you know what that means.
The option to define stepper drivers was not an option in Marlin 1.1.0-RC2 (The only version I can get to work with my printer)

To the best of my knowledge, I was able to determine that my printer (TAZ 5) I do not know the year. Is equipped with a Rambo 1.3 board that has A4982 integrated 1/16th stepper drivers.

So my questions are: Will I be defining this? does it matter? Could this be my problem?

Post Reply