Disable Dual Extrusion CURA 2.6.69

Have questions? Want advice?
radensb
Posts: 61
Joined: Sun Jul 23, 2017 3:21 pm

Disable Dual Extrusion CURA 2.6.69

Post by radensb » Sat Feb 17, 2018 5:47 pm

I just installed and tuned my Dual extruder V3 and printed the test print successfully. I wanted to print a part out using only one extruder, but cannot figure out how to tell CURA to disable the second extruder. Yes, I realize I can swap back to the single extruder and flash the proper firmware and re-cal my z-offset, but I would like to keep the dual installed. Is there a setting I am missing? I am using CURA 2.6.69 (current version).

Galadriel
Aleph Objects | LulzBot
Posts: 279
Joined: Mon Sep 25, 2017 10:23 am

Re: Disable Dual Extrusion CURA 2.6.69

Post by Galadriel » Sat Feb 17, 2018 10:52 pm

In the machine settings (Settings> Printer> Manage Printers> Machine Settings) there is an area that says number of nozzles, you can switch this setting to 1 instead of 2 and it should shut off your second extruder turning your dual extruder into a single extruder! :)

radensb
Posts: 61
Joined: Sun Jul 23, 2017 3:21 pm

Re: Disable Dual Extrusion CURA 2.6.69

Post by radensb » Sun Feb 18, 2018 3:20 pm

Thanks for the reply. So when I tell Cura there is 1 extruder, it still knows that the Dual v3 is actually installed and doesnt change any of the offsets, limits, or autobed leveling gcode, correct? I know it uses the left extruder to zero on the left bed washers and the right extruder to zero on the right bed washers and wasnt sure if that gets messed up or if there are gcode considerations that need to be taken into account. I just want to keep the second extruder from heating up for prints that dont need it. Thanks again!

radensb
Posts: 61
Joined: Sun Jul 23, 2017 3:21 pm

Re: Disable Dual Extrusion CURA 2.6.69

Post by radensb » Sun Feb 18, 2018 5:41 pm

So maybe Im still missing something...

I set the settings to 1 extruder. The Cura GUI changed such that only one extruder was available for manipulation and the slicer re-generated the gcode. I moved the gcode to my printer host (octoprint) and loaded it. It still activated the second extruder during preheat.

radensb
Posts: 61
Joined: Sun Jul 23, 2017 3:21 pm

Re: Disable Dual Extrusion CURA 2.6.69

Post by radensb » Sun Feb 18, 2018 9:33 pm

So, I noticed that no matter how many extruders I select in the "Number of Extruders" dropdown, the "Start Gcode" block always has references to T0 and T1:

Code: Select all

M104 S{material_soften_temperature_0} T0               ; soften filament
M104 S{material_soften_temperature_1} T1               ; soften filament
M140 S{material_bed_temperature}; get bed heating up
...
M117 Heating...              ; LCD status message
M109 R{material_soften_temperature_0} T0               ; wait for temp
M109 R{material_soften_temperature_1} T1               ; wait for temp
...
T1                           ; switch extruders
M82                          ; set extruder to absolute mode
G92 E0                       ; set extruder to zero
G1  E-15 F100                ; suck up XXmm of filament
M104 S{material_wipe_temperature_0} T0                 ; set to wipe temp
M104 S{material_wipe_temperature_1} T1                 ; set to wipe temp
...
Same with the End Gcode block;

Code: Select all

M400
M104 S0 T0                     ; T0 hotend off
M104 S0 T1                     ; T1 hotend off
Shouldn't these blocks change when the number of extruders change?

radensb
Posts: 61
Joined: Sun Jul 23, 2017 3:21 pm

Re: Disable Dual Extrusion CURA 2.6.69

Post by radensb » Sun Feb 18, 2018 11:50 pm

Well, I got Cura to generate a gcode file that controlled the printer as I wanted using only E1 (T0). It required commenting out all the commands for E2 (T1) in the Start Gecode block and End Gcode block.

Yuck.

Did I just figure out the most inconvenient way of doing this? Or is there a better option?

Aha
Posts: 36
Joined: Sun Feb 18, 2018 8:25 am

Re: Disable Dual Extrusion CURA 2.6.69

Post by Aha » Mon Feb 19, 2018 9:15 pm

The way I found out over the weekend requires the printer to be connected by USB. I simply left it as dual extruders, picked one material to slice the whole thing in, and then set the 2nd extruder temp to 0 when I started printing.

Alternatively, you can go to filament settings for your second extruder. Maybe make a custom one called "off." Then go to the temp settings and set them all to zero for all stages. The preheat script will still run, but turning it to 0 will mean it won't heat up or matter. (Do triple check that though, there's always a chance that the software will read that wrong, read that the extruder is at 20C, then say "cooling" but never manage to cool the filament to 0C!)

radensb
Posts: 61
Joined: Sun Jul 23, 2017 3:21 pm

Re: Disable Dual Extrusion CURA 2.6.69

Post by radensb » Thu Feb 22, 2018 12:31 am

I really liked the custom material profile workaround idea. I tried this tonight by creating a profile called OFF and setting all the material settings to 0 and temps to 0C. I then created a gcode file using some random filament in extruder 2, then another gcode file with my custom 'OFF' profile to compare. At first, it looked good. All the commands for T1 (E2) were set to 0, essentially making them useless. Then I came across the section that purges the filament. It still sets the temp of T1. This may be a safety precaution, and it makes sense to ensure that the hotend is hot enough to purge in the case of a mis-configured profile. But, because the purge commands are part of the start block, it will do this regardless of the material profile. So, I am back to hacking the Start block...

The only thing I can think of is to have a setting in Cura that can disable an extruder and modify the start and stop gcode blocks automatically so that if Extruder 1 is disabled, all referances to it and commands for it are removed. Likewise if Extruder 2 is disabled.

Hmmm...

How about it devs??
:)

Aha
Posts: 36
Joined: Sun Feb 18, 2018 8:25 am

Re: Disable Dual Extrusion CURA 2.6.69

Post by Aha » Thu Feb 22, 2018 12:35 pm

I hate the start block purge and retract stuff; I deleted pretty much all of mine because it's executing horrendously. It purges at a bad place, for no gain, then improperly retracts a ridiculous amount! I've deleted almost all of the section related to priming, purge, and retracting, opting instead for a much larger skirt (there's an option to force the skirt to be a certain amount of filament). It would be different if it didn't uselessly purge then retract 45 mm of material, retracting extruder two basically out of it!

radensb
Posts: 61
Joined: Sun Jul 23, 2017 3:21 pm

Re: Disable Dual Extrusion CURA 2.6.69

Post by radensb » Sun Jun 17, 2018 1:50 pm

In case anyone was interested, the workaround that I am currently using seems to be the best solution for this.

I just created a new printer profile in Cura called "Lulzbot TAZ 6 DualExtruder v3 (T0 Only)". It is exactly the same as my "Lulzbot TAZ 6 DualExtruder v3" printer profile, except I have modified the start and end blocks by removing all commands related to T1.

The main problem with the material profile modifications to "disable" the second extruder was that it still heated up and purged, which takes more time and energy unnecessarily. This way, the second extruder does nothing and I dont have to mess with material profiles. Now, when I select the "T0 Only" profile, my dual extruder functions exactly like a single extruder for the prints that dont require dual. :D

Cheers!

Post Reply