Need a smooth first layer / e-step and z offset woes

A forum dedicated to the stock LulzBot Mini 3D Printer
Post Reply
mnemosyne
Posts: 9
Joined: Sun Feb 18, 2018 5:43 pm

Need a smooth first layer / e-step and z offset woes

Post by mnemosyne » Wed Mar 13, 2019 9:55 am

My first layers are not smooth. With the current version of Cura, I don't understand how to compensate for z-offset.

Previously, I had dialed everything in to a nice smooth finish and I'd like to repeat that result.

I have done a quick calibration test of my e-steps and that is close enough, but I'd like to know how people are compensating for that too. Changing the flow rate hasn't shown me any clear change in quality.

I would welcome any help - I've been searching for an answer without any luck. Perhaps someone knows the answer (or the relevant search terms I should have used in the first place). If all else fails I can go back to the old firmware and cura, but it's really bugging me that I don't understand how to do it now. Plus I'd prefer to be able to use the current versions of everything.

How are you handling your z-offset now? How do you calibrate your extrusion?
(and - what am I not thinking of?)

thanks all

kcchen_00
Posts: 1686
Joined: Thu Feb 19, 2015 12:42 am

Re: Need a smooth first layer / e-step and z offset woes

Post by kcchen_00 » Thu Mar 14, 2019 11:45 pm

Try increasing the "initial layer line width". It needs to be enabled in the "Quality" section by clicking the gear next to the arrow.

mnemosyne
Posts: 9
Joined: Sun Feb 18, 2018 5:43 pm

Re: Need a smooth first layer / e-step and z offset woes

Post by mnemosyne » Thu Mar 21, 2019 11:21 am

I've played a bit with this setting already and don't get much result from it. I'll read up on it, thanks. Maybe if it can go to greater than 100% there's something there.

Brent.I
Aleph Objects | LulzBot
Posts: 477
Joined: Mon Jan 20, 2014 8:21 am

Re: Need a smooth first layer / e-step and z offset woes

Post by Brent.I » Thu Mar 21, 2019 3:03 pm

mnemosyne wrote:
Wed Mar 13, 2019 9:55 am
How are you handling your z-offset now?
After updating your firmware, you will need to reset your Z offset to what it was previously using a M851 command in the console. If you did not jot it down, you can adjust it on the fly while your first layer is printing.

After starting a print, open the console from the monitor tab and enter the following commands
M851 ---> This reports the current Z offset
M851 Z-x.xx ---> This updates the current Z offset to x.xx
M500 ---> This saves your settings, so you do not need to reset it each time you power cycle the computer

Feel free to adjust the Z offset multiple times, and just use the M500 once you have it where you like it.
mnemosyne wrote:
Thu Mar 21, 2019 11:21 am
Maybe if it can go to greater than 100% there's something there.
First layer flow rate should be able to go above 100%, however we recommend getting your Z offset set properly first. The first layer flow rate should only be used to compensate for die swell differences between the filaments. Once the Z offset is saved to EEPROM, this is how you will tune in each specific filament brand/manufacturer.

mnemosyne
Posts: 9
Joined: Sun Feb 18, 2018 5:43 pm

Re: Need a smooth first layer / e-step and z offset woes

Post by mnemosyne » Fri Mar 22, 2019 5:49 pm

Thanks for your reply Brent, but this is exactly what I can't do in the software.

I would be very happy if I could fine tune it as increasing the layer width helped somewhat but is still not the smooth surface I am looking for.

In Cura 3.6.3, the updated firmware seems to no longer use z offset. I can not get the printer to respond to the M851 command sent from console.

Post Reply