Cura won't run on Ubuntu 18.04 wrong GLIBC required

Get answers & advice for all of your 3D printing & Free Software needs here!
Post Reply
etothex23
Posts: 3
Joined: Wed Sep 27, 2017 9:21 pm

Cura won't run on Ubuntu 18.04 wrong GLIBC required

Post by etothex23 » Thu May 23, 2019 8:57 pm

I have a fresh install of 18.04. Cura installs but when I try to open it I get the following error:
/usr/share/cura-lulzbot/cura-lulzbot: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.28' not found (required by /usr/share/cura-lulzbot/cura-lulzbot)

output of ldd --version:

ldd --version
ldd (Ubuntu GLIBC 2.27-3ubuntu1) 2.27
Copyright (C) 2018 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
Written by Roland McGrath and Ulrich Drepper.

You can see that the required library is 2.28 but Ubuntu 18.04 has 2.27. I have updated the OS

User avatar
Orias
Aleph Objects | LulzBot
Posts: 1451
Joined: Wed Mar 27, 2013 1:24 pm
Location: US

Re: Cura won't run on Ubuntu 18.04 wrong GLIBC required

Post by Orias » Fri May 24, 2019 8:05 am

Try installing this version: http://download.alephobjects.com/ao/aod ... _amd64.deb and use the instructions here to install: https://www.lulzbot.com/learn/tutorials ... ion-ubuntu
Once downloaded, in a terminal navigate to the directory containing the file and send the following command:

Code: Select all

sudo dpkg -i cura-lulzbot-version.deb
If that version works for you, great! If not, reach out to the support team at https://LulzBot.com/Support and they'll be able to help.

bpbutler1234
Posts: 1
Joined: Fri Jun 14, 2019 1:40 pm

Re: Cura won't run on Ubuntu 18.04 wrong GLIBC required

Post by bpbutler1234 » Fri Jun 14, 2019 1:43 pm

I have the exact same problem. It seems like the Ubuntu version was built against the wrong library version.

I would rebuild from source, which should resolve the problem, but I can't seem to find the source anywhere.

Post Reply