Cura LE 3.6.4 not changing Flow from Initial Layer Flow Rate

I noticed that when I set a specific flow rate for the first layer, the entire model will pint at that flow rate (observed on the LCD and in the gcode as there is only one m221). I do not have Equalize Filament Flow turned on.

I worked around the problem using a post processing script under Extensions -> Post Processing -> Modify G-code and adding a TweakAtZ on layer 1 to set the flow rate to 100. I verified the m221 s100 was after layer 0 and before layer 1 (you could even do the fist couple layers at a higher flow rate this way).

Well, the m221 s100 is present at my desired layer in the g code, but according to the lcd, my feedrate stayed at 103% and did not change to 100% (I let it run for many layers after the m221 s100)

The line calls up T0 (M221 T0 S100) does that matter? I assumed this was for multiple extruders as each tool code i.e. T0 for 1st extruder T1 for second, but there are no other T blocks in the entire program.

This may be the mistake. I accidentally selected “Tweak Flow Rate 1” instead of just “Flow Rate”. The difference is Tweak Flow Rate 1 generates a tool number T0 on the line, and Flow Rate does not (I thought I selected flow rate, but perhaps I got a little click happy). Going to try on the next print…

Update, that fixed the issue with the workaround. It would be nice if the feature worked as it is intended though.

Just ran into this as well. I’m finding it quite impossible to get high quality prints with this version of Cura. :frowning: Will try to make this workaround happen.