Error: Temperature heated bed switched off. MAXTEMP triggered !!

Hello all, finally got everything wired up to test my homebuilt mini. Limit switches seem to work, homing seems to work. But when going to run a test print cycle i run into this error that the max temp of my bed has been reached. I believe it only made it to about 122, which i doubt is the max. plus it was only slightly warm, not hot. Extruder temp was only about 34. I’m suspecting either the thermistor which came with my heat bed is bad or this is some sort of weird software issue. I am using Lulzbot Cura 17.10 and used it to reflash the firmware for the mini to the mini rambo board.

The closest thing i found was this thread from the ultimaker forum which hints at a software bug and/or the software looking for the wrong thermistor value.

I have not ohmed out my thermistor yet, but i will soon.

Recv: Error:Temperature heated bed switched off. MAXTEMP triggered !!
Changing monitoring state from 'Connecting' to 'Error: Temperature heated bed switched off...'
Recv: Error:Printer stopped due to errors. Fix the error and use M999 to restart. (Temperature is reset. Set it after restarting)

Full Error Log:

Recv: Error:Temperature heated bed switched off. MAXTEMP triggered !!
Changing monitoring state from ‘Connecting’ to ‘Error: Temperature heated bed switched off…’
Recv: Error:Printer stopped due to errors. Fix the error and use M999 to restart. (Temperature is reset. Set it after restarting)
Changing monitoring state from ‘Offline’ to ‘Opening serial port’
Connecting to: /dev/ttyACM0 with baudrate: 115200 (configured)
Connected to: Serial<id=0x7fb98f7dd350, open=True>(port=’/dev/ttyACM0’, baudrate=115200, bytesize=8, parity=‘N’, stopbits=1, timeout=5, xonxoff=False, rtscts=False, dsrdtr=False), starting monitor
Changing monitoring state from ‘Opening serial port’ to ‘Connecting’
Recv: start
Recv: echo:Marlin1.0.0
Recv: echo: Last Updated: May 12 2015 10:00:43 | Author: (Aleph Objects Inc, Mini-2015Q1)
Recv: Compiled: May 12 2015
Recv: echo: Free Memory: 4882 PlannerBufferBytes: 1296
Recv: echo:Hardcoded Default Settings Loaded
Recv: echo:Steps per unit:
Recv: echo: M92 X100.50 Y100.50 Z1600.00 E833.00
Recv: echo:Maximum feedrates (mm/s):
Recv: echo: M203 X800.00 Y800.00 Z8.00 E40.00
Recv: echo:Maximum Acceleration (mm/s2):
Recv: echo: M201 X9000 Y9000 Z100 E1000
Recv: echo:Acceleration: S=acceleration, T=retract acceleration
Recv: echo: M204 S2000.00 T3000.00
Recv: echo:Advanced variables: S=Min feedrate (mm/s), T=Min travel feedrate (mm/s), B=minimum segment time (ms), X=maximum XY jerk (mm/s), Z=maximum Z jerk (mm/s), E=maximum E jerk (mm/s)
Recv: echo: M205 S0.00 T0.00 B20000 X12.00 Z0.40 E10.00
Recv: echo:Home offset (mm):
Recv: echo: M206 X0.00 Y0.00 Z0.00
Recv: echo:PID settings:
Recv: echo: M301 P28.79 I1.91 D108.51
Recv: Error:Temperature heated bed switched off. MAXTEMP triggered !!
Changing monitoring state from ‘Connecting’ to ‘Error: Temperature heated bed switched off…’
Recv: Error:Printer stopped due to errors. Fix the error and use M999 to restart. (Temperature is reset. Set it after restarting)

The maxtemp bed for the TAZ is 150°, I assume it’s the same for the Mini.
You write “I believe”, do you run another test to be shure at which temperature the error is raising? Is the temperature shown when the printer is cold = ambient temp.?

Yes it shows the temps when first starting up and pressing print. Both start around 22 degrees. The reason i said “i believe” is because unlike the extruder temp which updates every second the bed temp for the most part does not, which is most strange. In fact most of the time it seems to stay around 34 degrees without updating at all, then perhaps 10 seconds later with no update the error occurs and says that the bed temp has reached the max temp, but the temp for the bed has then disappeared completely or alternatively never changed from ~34 degrees. Sometimes when i then close the print dialog and reopen it, it will then show the bed temp somewhere around 112 and falling, sometimes it does not and shows no temp for the bed. This does not appear to be normal behavior from other minis that i have tried.

I have also tried on a windows machine with the latest version of cura and updated the firmware. No dice.

The thermistor tests fine around 100k ohms at room temperature.

The only thing i can say for sure is that the bed temp is nowhere close to being near 100 degrees c as it is only slightly warm. So somehow my mini is getting false readings. Could this mean the mini rambo board is bad?

Anyone have any ideas on how i can fix this. I’m a bit stumped. Especially since the thermistor seems to measure good. Any ideas on what would cause it to think it is too hot when it’s really not?

You have a 100K thermistor, NTC (Negative Temperature Coefficient), and you’ve measured it to be close to 100K at room temp. So that’s good.

There should be a pull-up resistor for the voltage divider circuit, and I’m wondering if that might be the wrong value. But, you’re reading the right temperature at room temp before you start. That doesn’t make sense.

Thermistors can have different “curves” for R vs. T, but they are fairly close and yours is waay off.

100C is “spit sizzlin’ hot” and you’d know if it was that hot I think.

A shorted thermistor might show a high temperature readback, but you say it reads high and is steadily dropping. That also doesn’t make sense.

It sounds like software, but I’d suggest checking your heater wiring and thermistor wiring for the bed. Make sure they aren’t mixed up, and also that they aren’t shorted somehow, one to another.

You could also look at a table for your thermistor and heat the bed gently with a heat gun while measuring the resistance. See if it agrees with the table. 35C is about 100F I think, so that’s a datapoint. Or you could set it outside (I see you’re in Loveland) and get a reading for the zero degree C value and compare that as well.

Good Luck!

How did you test the thermistor? Did you measure from the connector that plugs into the Rambo, or directly at the thermistor? Measuring from the connector will test for a wiring problem as well as thermistor resistance. If you already measured the thermistor from the board-end of the wires, then I don’t know what would explain incorrect temperature readings. :frowning:

As for the bed temperature not updating on-screen during heating…

I recommend you manually try setting just the bed temp from a console command, rather than starting a normal print. If you manually send a “M140 S120” by itself, then as the bed heats Cura (or pronterface, or S3D, etc.) will be able to query/display the temperature as heating progresses.

Programs like Cura and S3D periodically send an M105 command and interpret the output to get temperatures, then display them on screen. They also interpret the periodic output from modal commands like M109, because these commands block most other commands (including M105) until they complete.

Unfortunately, the M109 command (set and wait for extrusion temp) does not include the Bed temp in its periodic output. The standard mini start scripts use an M140 to set the bed temp, followed immediately by an M109 to set the extruder temp. Until the M109 completes (i.e., until the extrusion temp is achieved) the host program cannot get the bed temp because the once-per-second output from M109 doesn’t include bed temp, and M105 queries can’t be sent/processed while M109 is processing. That’s why you aren’t seeing the bed temp updated onscreen during the time when both Bed and Extruder (via M109) are heating.

Personally, I fixed this by adding Bed temp to the M109 output and recompiling the firmware. It’s a 2-line change in the Marlin_main.cpp module. This allows Cura, S3D, Pronterface, etc to monitor/display both the extruder temp and bed temp during the M109 wait. Here are the surrounding lines, with the (2) lines that need to be added:

{ //Print Temp Reading and remaining time every 1 second while heating up/cooling down
            SERIAL_PROTOCOLPGM(" E:");
            //---- Add bed temp report ----
            SERIAL_PROTOCOLPGM(" B:");
            //---- End addition of bed temp report ----
            #ifdef TEMP_RESIDENCY_TIME
              SERIAL_PROTOCOLPGM(" W:");
              if(residencyStart > -1)

But for testing purposes, just manually use a M140 command to set the bed temp. Then the host program should still be able to monitor and display (via M105 commands) the bed temp as it heats up.

Thanks guys! It turns out the two thermistors were plugged in to the opposite ports. Thanks to the “M140 S120” gcode command i was able to easily see that the “extruder temp” was going up even though the command was heating the bed (i also unplugged the extruder heat just in case too). It was obvious the bed was getting hot even though the software said otherwise. lol. So all in all just a simple case of some swapped wires. The good news in this issue is solved.

The bad news is i now have another issue where the print head is about 3/4" above the plate when going to wipe and touch the washers, and when it goes to print it prints off to the left instead of the center where the model is. I’m wondering if that is some sort of issue with the software having the wrong estep value? Not sure, i’ll try to tackle that one in a few days and if i can’t figure it out i will open a new thread for that.

Thanks again!