First prints with Slic3er and Pronterface....

Not good at all…

I ended up cancelling the print as the nozzle was being dragged over the surface, or more accurately through it. It’s like it is over-extruding even though as far as I can tell, the extrusion is set for 100%


I know you’ve done other prints successfully using Cura, so I’m going to assume your E-steps are good and it isn’t a hardware issue. That only leaves two things that come to mind with a lot of over-extrusion after switching to Slic3r… You already checked the flow multiplier, the other would be filament diameter. Is it possible the filament diameter is set way too small?

Yes, the prints with Cura were a lot better than this, albeit not always perfect.

Where is the multiplier that you quoted, looks like I should see what that’s set to



Should be on the “Filament Settings” tab… Though I haven’t used it for a long time, so I’m going from memory.

Make sure the Diameter field has the actual diameter of your filament, and the “Extrusion Multiplier” is “1”.

I checked, and the multiplier is set at 1. The filament is 2.85mm, measured, the only advanced setting in the printer settings at anything other than ‘0’ is first layer at 100%

Part of the reason for using Slic3er was to better control the production of overhangs and small features. By having the fan turn on after a certain number of layers I was hoping to improve the small features, and the supposedly better slicing and support characteristics of Slic3r would help with the overhang. It was at least part correct, take a look at these two prints

Cura printed on the left in every case

As you can see at the lower levels and the main body, Cura is miles ahead, but once it gets to the top small feature, Slic3r and Pronterface clearly are able to create the details much better.

I suppose if there was a was of making the fan come in halfway through the print in Cura as you can select on Slic3r, it would be able to reproduce this upper feature better too


I’m out of ideas as to why why you’re getting so much more extrusion with Slic3r… With the same multiplier and filament diameter, you should be getting virtually identical extrusion amount.

On the Cura / Fan issue, you can tell Cura to start the fan at a specific height. You have to do it in mm, rather than layers, so if you want a specific layer you’ll have to calculate. Go to the advanced settings, and look for “Fan full on at height:” option. That “full on” refers to whatever you set as the “Fan speed max” value.

If you also have a “min layer time”, cura will try to slow down quicker layers but cannot go below the “minimum speed” you set. If a layer time falls below that, then Cura will set a speed somewhere between “Fan speed min” and “Fan speed max” for that layer, based on how much the actual layer time falls short of your “min layer time”.


Found the fan control and have activated it to start after five layers to see if it works, test printing now

Thanks, just checking that out, hopefully I can find it, however the min layer time was always set


ok, despite the fan control being set to come on at 0.5mm height, it has refused to do so. I know the fan works because Slic3r was able to activate it, not sure why Cura is not activating it


At what speed? You’ll likely need a value over 30% in order to “spin up” the fan. Other than that, it has always worked perfectly for me.

You’re right, min and max were both set to 0. obviously now have to wait for the print to finish before I can change it, so I’ve borrowed the fan from my sons room to cool down the feature at the top during printing, just to see if it makes any difference

While it is printing, you can use the console in Cura to send “M106 S102”. That will turn the fan on at 40%. (The scale for M106 command is 0-255, so 40% is 102).

Progress! With min 25% / max 100% on the fan, and layer height set at 0.2 mm Cura now has a vastly improved small feature reproduction ability; not perfect but comparable to the Slic3er / Pronterface result in this area. I still want to run to ground why the Slic3r / Proterface issues are occurring, as I feel there is a bit more to come in terms of ultimate quality of printing, but this is a bloody good start. With finer layer sizes I expect there will be be improvements on the Cura effort too

Thanks for all the help and the patience in dealing with me and my stupid errors!


Looking much better! Still looks a little over-extruded – you might try dropping the flow multiplier to 90% just to see what kind of difference it makes. Have you done an E-Steps calibration and set E-Steps in firmware?

Always glad to help. Hopefully someone more versed in Slic3r will chime in with some suggestions on it. I’m pretty good with Cura and S3D, but my experience with Slic3r is very limited.

Not, to be honest I had never even heard of the e-calibration steps. Will definitely do that, thanks for the tip


The default E-steps in the mini firmware is 833. Most people find that is a bit high, which contributes to some over-extrusion.

Here’s a link to a Lulzbot calibration procedure:

That is written for the Taz, but most of the process is the same. Just skip step 6, which refer’s to the Taz’s LCD, and instead follow step 7 to enter the new value into the firmware and save it to EEPROM.

Step 4 recommends using a speed of “100”. Personally, while the difference won’t be very big, I recommend 50 as it is closer to “real world” extrusion rates.

The console is the right hand pane in this, correct?


Yep. The field at the bottom right. You can type commands there and hit Enter to send them, then see the response in the window above.

Start by just putting M503 in there and hitting enter. That will produce a list of all the current settings. Scroll towards the top of that, find the line with “M92” and see what your E-steps currently are – it will probably be the default, so it will show “E833.00”.

Then do the calibration to come up with a better number. Let’s say, for example, you come up with 805. You would then go to that field, type “M92 E805” (without the quotes) and hit enter. Then M500 to save the value to EEPROM. (If you don’t send M500, any changes you have made will disappear the next time the printer restarts.)

The procedure says to set extrusion speed to 100, but I’m not sure the Pronterface GUI has that feature. But you can send Gcodes that will perform the extrusion at a specific speed. For example, to extrude 100mm at 50mm/min, you would send this command (be sure your extruder is at extrusion temperature first):
G1 E100 F50

perfect, thanks, when I did a print at 0.1 layer height with the fan control set, it didn’t start the fan, so that M106 S102 code saved that


Great! Just beware that in some cases, the manual M106 will be “temporary”. That’s because the slicer, if it controlling the fan layer-by-layer due to the “minimum layer time” and min/max fan speeds, may inject an M106 with a different value at the start of the next layer.

So if you have specified NO fan, then your manual M106 commands will probably last for the duration of the print. But if you have specified a min/max fan and “minimum layer time”, Cura may decide to inject a different M106 command (with 0 fan, or something between min/max) at the beginning of the next layer.

I do wish they would update that procedure. I used a speed of 40, and it made a significant difference in my results. (I suspect some filament types/temperatures may be more sensitive than others to that 100 speed?)