How does self leveling work?

Is there a voltage applied to either the nozzle or leveling washers?
How is the ‘contact’ of nozzle to leveling washer sensed?
I see there is a red nozzle ground wire in the toolhead connector diagram, where does it attach to the control board?
My self leveling just stopped working, nozzle pushes hard on the washer , apparently doesn’t sense the contact, and then rewipes etc etc.

The nozzle acts as the contactor in a limit switch. It’s tied into the Z minimum limit switch normally open loop. When the nozzle contacts the bed washers which are also part of that same circuit, it closes the circuit completing the circuit and closing the normally open loop. That loop is a low voltage, low amperage sensing loop

If your self leveling stopped working, it’s usually a loose washer, a loose wire attached to the bed mount frame plate (which also acts as part of the circuit) or a short in the wire leading up to the nozzle. it can also fail if you clean the nozzle with the printer powered on with a wire brush and short important circuits together melting your Rambo board. Never use a wire brush to clean your nozzle.

I recently had auto-leveling stop working. In my case, I had a massive PETG print failure that encased my print head in petg goo. After getting it fairly clean things were working but slowly the leveling became finicky and finicky (I would need a pristine nozzle to get it to level). Finally, it stopped working completely. As far as I can tell, some of the petg residue oozed into the threads of the nozzle and ended up insulating it enough to cause the sensing to fail.

To diagnose, I checked continuity at various points in the nozzle. In particular between the wire used for sensing (I’m being vague because I was using the itworks3d e3d aero toolhead which is different) and the heatbreak. This was fine but I did not have continuity from the wire to the nozzle. I did this checking with the machine turned off because all the warnings I’ve read make me paranoid about touching the nozzle with a metal probe.

Swapping out the nozzle fixed the problem for me but your problem could be completely different.

Thank you for the information. Using M119 which reports the end stop states I found that with the z min stop was activated with the nozzle shorted to bed until I moved the print head to about 2 inches above the bed using z positioning, then zmin became open, very repeatable, so verified it with an ohm meter measuring the resistance between the red wire attached to the hot end and the red wire that connects to the z min end stop on the controller board and sure enough when the nozzle gets to a z height a couple inches or less above the bed the red line resistance goes from near zero ohms to open. I’m assuming it’s a broken red wire somewhere between the hot end and control board, next , looks like a real chore installing a replacement wire along that pathway. thanks again.

I just had this start happening on my Mini as well. When gcode gets to G29 ; start auto-leveling sequence, it aborts/halts after three attempts to “level” first washer (rear left), but the head is clean.

Recv: Rewiping
Recv: Rewiping
Recv: Rewiping

I never experienced this on any previous Mini firmware. I have been on the caveated firmware found in Lulzbot Cura 2.6.66 (v., am using updated .gcode, and had many successful prints on the new firmware in ABS.

I was running reliably with ABS. I wanted to switch to PLA, so I ran some cleaning filament through the extruder, and then swapped in PLA, cycled it through twice until I had a nice clean stream.
I didn’t mess with anything on the toolhead/extruder other than engaging/disengaging the spring tensioner.


Send: N1 M115*39

Lulzbot Cura 2.6.66
Lulzbot Mini v2.1 toolhead (have been using for a while too)

I’ll try to follow the wiring/continuity troubleshooting tomorrow as time is running short for me tonight.

Is there somewhere I can source a wiring diagram of this z-limit sense/auto-level circuit? (i.e., where it is wired to other components and how it interacts in with board)

This didn’t seem to have what I need:

OK, I used the toolhead assembly instructions to see how the zero sense was wired in. Found at step 11 (“Zero volt sense harness installation”) that there is a specific lead that connects to nozzle on hot-end (for reference, it’s wired through Mini toolhead wiring harness at pin 16)

With my Mini powered off and unplugged, I used a DMM (mine has a specific “continuity/diode test” setting that conveniently beeps to let you know) to check continuity between nozzle and screw connector lead on hotend, and between that lead and wiring harness pins on the toolhead. And even from there to the bed leveling washers. Everything passed.

One thing i did find was that the nozzle needed some searching for a spot or my DMM probe to dig in before it would register sometimes, so this was a clue. I tried to rub some of the oxidation off nozzle, and flipped over the wiping sponge, and what do you know? Now it works fine. So I guess the essence of this trial is that when you have bed auto-level issue on first washer-- first make sure the nozzle is extra clean. :smiley:

I had a similar experience last week. I’d been printing a bunch of gray NGen, and started having problems with probing (not complete failure, but seeing the washers get pushed downward during probing). I’d stop it, manually clean the nozzle, and try again – only to have the same thing happen. Was really scratching my head, and starting to think I had a bad connection somewhere.

Then I looked at the wiper pad, and it had a significant film of gray NGen on it. I suspect when it was “wiping”, it was getting more ON the nozzle that it was getting OFF the nozzle. Put on a clean pad, and viola – no more problems!

So just as you found… Sometimes “PROBE FAIL - CLEAN NOZZLE” just means the pad is dirty! :slight_smile: