Lulzbot Mini startup/auto-level fail - around probe points

forgive me if I was unable to locate a thread with someone else having a similar problem.

my Mini started failing in startup/bed leveling. Once it gets to the part of the startup sequence where it probes each of the corners, the print head never descends but rather ascends at each corner, and sets it’s initial z-height at that far height about the bed, making it impossible to do any prints.

This happens on .gcode that was successful in the past, always with the same result, and I’ve tried all sorts of things short of swapping replacement print head. This is a Lulzbot Mini, with a v2.1 extruder head.

here is a youtube, as a video is worth a thousand pictures, or something like that

Short vid of Mini bed leveling fail

trying embed too

The symptoms suggest to me that perhaps there’s a “short” (always closed) in the continuity/level point sensing? but I do not know what to do with that.

I would be grateful for suggestions or next steps.

That’s looking like both z axis motors are reversed, the reverse axis switch is set in firmware, or rare but possible the Rambo board is shorted and going the wrong way. If you are under warranty I would call support.

I had a similar thought earlier. However, manual controls, as well as most of the sequence is performing as normal, so I am unable to understand how it could be z-axis motors are reversed?

It looks to me as if the “search” for contact on the auto-level routine comes back as “true”/“circuit complete” immediately each time/everywhere, right?

Did you happen to update your Cura software recently?

With an Ohm meter measure between the extruder nozzle and one of the steel washers of the bed with the power cord unplugged. Low reading means your board is dead, should be around or greater than 5000.

I tried this

measuring with a DMM in Ohm mode:

  • washer to washer : 2.4 Ohms
  • washer to nozzle on print head : 5M Ohms to 10M Ohms

I am not familiar with details of extruder wiring or circuitry, but is it possible that the wiring for the sense path got internally shorted? Close inspection of the affected v2.1 extruder has what appears to be ruffled red insulation— near to where it “connects” to hot end…

I use an octoprint/octopi setup on the Mini. The same .gcode’s (have prior printed successfully) all exhibit this problem.
I also tried a direct streaming connection from recent Cura (macOS) and it also exhibited same undesired behavior.

what is the result of M119 in the terminal window of Octoprint. (with the X/Y sitting in the middle of their travel area. So the X/Y do not show as triggered.)

If you show a triggered state for Z min then your RAMBo has died.

Sorry I should have been more specific, the reason why I asked if you had updated your software recently is that if you have upgraded from an older version of Cura this could just be an issue of needing to clear your cache. The old Cura had different start and end gcode and we have found that if the old gcode is imported into the new Cura when you flash the firmware it can cause the issues you are seeing. If this sounds like it might apply to you I have included a link to how to clear your computers cache for the MacOS.



with the head positioned roughly in the middle of the build volume, I do indeed get Z_min triggered.

Send: M119
Recv: Reporting endstop status
Recv: x_min: open
Recv: x_max: open
Recv: y_min: open
Recv: y_max: open
Recv: z_min: TRIGGERED
Recv: z_max: open
Recv: ok P15 B4

I think I am going to swap out the v2.1 extruder (I have an old one I can swap in) just to verify that its not internal to it.

Has anything metallic or conductive been used to clean your nozzle? The z-min being triggered usually is a sign that the RAMBo board has been shocked, and the most common reason for this, is when someone uses something metallic to clean the nozzle and in turn shocked the board.

I’ve never used a wire brush or anything like that to “clean” the nozzle. that being said, I have often used the metal tweezers that came with my Mini to pinch off extra oozing filament from the tip of the nozzle.

I finally got a chance to swap out extruder with another one and an M119 command came back Zmin triggerred, so I guess I have a bad board.

What’s a recommended way to replace/get that fixed these days? Is there a certain board or supplier I should look into?

This is a gen1 Mini purchased in July 2015…

There are a couple options for getting the board replaced, in terms of a specific board you will want to make sure you are getting a Mini-RAMBo v1.3a made by Ultimachine. We sell it on our website in the parts section here: (the version number of this board will most likely be different than yours but it is still compatible)
And we have an assembly guide for the Mini 1.03 that you could use to uninstall the old board and reinstall the new one here: (I recommend taking additional photos and labeling your wiring harnesses before unplugging old board to make install of new board easier)
If you are located in the USA you could look into our out of warranty repair service here:
Depending on where you live there are also people who offer 3D printer repair as a service, though of course there are no guarantees as to their familiarity with our products or overall quality of the repair since they would be a 3rd party so you would want to make sure you did your research if you went this route.
Once you replace the board if you need to clean off the nozzle we recommend raising the printhead off the bed, and bring to extrusion temperature. Using a thick leather glove and a clean blue shop towel gently wipe off the outside of the nozzle. Using a non-conductive Scotch Brite pad to clean the nozzle is also very effective.

If you decide to change it out yourself, make sure you flash the firmware. It will probably have Ultimachine firmware that will give ‘strange’ operation if you try to move the motors.

thanks for all the information.

I do live in Loveland, CO of all places actually :smiley: , but I will probably attempt to do the repair/replacement myself.

Got a chance to swap the mini RAMbo out of mini today.

With a couple hex wrenches, a label maker, and an iphone with a flashlight (and to take photos in case), it took only about an hour to swap out bad/swap in a new board.

Everything appears to be working, and am halfway through a first “test” print as I am typing this.