Skip Auto-Leveling between multiple prints?

I am printing multiple parts in multiple print runs consecutively on the Mini with default firmware. I am running S3D but have the start and end gcode generated from Cura included.

Can the auto-bed leveling check be skipped after the first print since nothing is changing between setup/prints? The machine is not power cycled or disturbed between print runs so I would think the Z-height would be correct upon restart.

M109 S140		; set to probing temp
M204 S300		; Set probing acceleration
G29		; Probe

I tried just commenting out the probing code but my Z level seems to be off every time it goes to print after that code.
Is there ending code that needs to be tweaked? (its the stock start/end code from Cura prints)

I seem to remember reading that the firmware clears the auto leveling data after another command. Home perhaps? There was some discussion about changing that, but I don’t think anyone made a firmware update that did that.

It would be interesting as an experiment, if nothing else. The probe data is quite consistent between runs on my machine. Perhaps save a gcode for the clean/probe routine so you can run it as desired and use the saved data the rest of the time…

@ egus: did you find a solution, to interrupt auto-bed-leveling in S3D? I’m still wondering, whether I should buy S3D…

I have not looked into it further yet.

I would think the next step would be to examine the firmware/source code and see if it is doing a of reset, perhaps on G28.

As far as S3D, it has worked very well so far, and has generated dozens of reliable good looking prints.
There have been a couple models with errors that Cura has been able to slice successfully and S3D’s engine could not, even after experimenting with S3D’s repair options. (S3D’s repair functionality seems not as robust as Cura’s.)
But depending on your printing demands, it may be debatable whether you’d find $149 in value vs other alternatives.

The stock firmware does clear the bed level correction matrix when a G28 Home is executed. At that point, Z=0 is the effectively the top of the wiper pad (not the bed). So even if your bed were perfectly level, you really couldn’t print until doing a G29 (or using a big negative Z-offset).

There is a version of the Marlin 1.1 RC3 code available, customized for the Mini by forum member jrhubott. It includes code in the G29 routine that saves the matrix to EEPROM. The G28 routine has code that reloads the last matrix. There is also “off-bed” logic that makes sure the wiper script uses the normal G28 uncorrected Z position (where top of wiper is Z=0, as measured from Z-Max) rather than the G29 probe coordinates (where the bed is Z=0 as compensated from the washer contacts). NOTE: Technically, with stock or this firmware, after G29 the surface of the bed is typically at about Z=0.07 due to the M851 z probe compensation value. That value typically has a negative value of slightly more magnitude than washer thickness, to ensure some “squish” in the first layer. Don’t ever go to Z=0 after G29, or you will run the nozzle into the bed!
So in theory, with that firmware and assuming you are comfortable that your bed plane hasn’t physically changed, you can skip G29’s (after the initial one), go straight to G28, and be using the last G29 matrix.

I haven’t tried that firmware, and some problems have been reported by those who have. You can find more (and perhaps query people who have actually used it) here:

Thank you for that insight ScottW!

I did look into jrhubott’s repo and decided I did not need all the tweaks (along with possible issues) his firmware was providing. So I am still at working through the stock source.

A side note; I have been following your other very helpful discussions in regards to Z-axis/stop-switch issues. Very informative and I am interested to see where you go with that.
I had a serious issue with my Mini when new with a hard bed crash after I unpacked it. The X-axis drag chain had gotten tweaked in shipping and it struck the Z-column when traversing during probe causing the head not to move all the way over the disc and proceeded to bury itself into the bed. Working over-travel Z-stops/limits like your discussion would have prevented that.