0.6mm nozzle on TAZ Pro Long Bed

Hi, new to forum, we own 6 taz workhorses and now acquired a Taz Pro Long Bed. I am having a issue since I changed the 1.2mm nozzle to a 0.6mm one. the perimeter outer line does not follow the correct definition from the gcode, and it leaves a gap on chamfers and fillets versus the inside wall line.

have pictures, don’t know how to add them to this post!

Easy way for pictures is just copy them to clipboard and post: (Windows+Shift+S works wonders for doing screenshots from in the slicer)

Have you changed the nozzle width in Cura? It’s in machine settings:

Yes Wrathernaut, changed the nozzle size in the machine settings. PETG is printing perfect except for the outer perimeter lines being further out, inside ones look ok.

does any one know if the nozzle hole diameter is tied to the machine firmware?

just compared the out of the box hs 1.2 vs the 0.50 machine settings and they look the same for the Pro XL. I did notice that the BLtouch is not selected:

The BLTouch checkbox I think only helps it determine which firmware it will load, but could also modify the startup GCODE.

To answer the question about firmware, yes, Marlin does have a nozzle diameter setting, but it is used for some of the built-in features that can be enabled such as a test pattern for bed leveling. It would not be causing what you’re seeing.

Can you post a screenshot of what that spot looks like in the slicer at the same angle? Marlin doesn’t really re-interpret anything sent via gcode, so usually something like that comes down to a mechanical cause, but the slicer may be using a different speed or other setting on the outer perimeter lines.