Bed level issue

I am reaching the end of my wits and patience.

Everything about the levellinflg process seems fine. The nozzle does not dig in, it barely touches the washers and moves on. I have no adhesion issues on 3/4 of my bed.

However, the entire left side is unprintable on. Ive attached a pic so you can see what I mean. It’s like it crosses this imaginary line and everything is fine, but before that it barely sticks.

Ive tried sanding the bed, cleaning the nozzle, cleaning the washers. Ive lowered the z axis down to the green brackets so that the x axis is paralel to the bed.

It started happening after I updated my firmware with cura 2.6. I saw my z offset changed to -1.38 (which is the default i understand) and I’ve changed it back to -1.43 which is the value I had in my quality assurance cert.

Anyone have any ideas? Im pretty much out of any by now.

A long shot - but easy to do…

Mine had a major z-offset problem after I updated the firmware – the problem turned out to be a long-standing issue with my print bed washers where one or two of them weren’t tight enough, and thus had tipped up. The new firmware has a different probe order for the washers, so I think it may end up with a different set of numbers to compute the correction matrix (I don’t know for sure, because the new firmware no longer prints that set of coordinates – a shame, I think).

Anyway, to get to the point, gently squeeze the glass to the base at each corner with your thumb and forefinger, just enough to remove the pressure on the washer - then snug down each screw. Don’t over-torque – when you release the bed, it should pop up to the washer but not move the washer at all – and you shouldn’t be able to rotate the washer with your fingers. Two of mine were loose, and after tightening things, everything went back to normal.

Thanks for the suggestion. One of the washers was just a bit untight so i screwed it in a bit further.

It’s definitely a bit better, at least the prints stick, but it’s still not perfect. I’ll try some more.

Also, The levelling order hasn’t really changed? It just skips washer #4 (left-back corner when looking from the front)

What version firmware are you using? The latest public releases should hit all 4 washers. Some of the earlier (beta) releases were using 3 washers, and those solicited several reports of bed level problems very similar to what you are seeing.

Go to console and send an M115, and see what is reported as FIRMWARE_VERSION. It should be – that’s what was packaged with the Cura 2.6.52 public release in late November.

I think you are absolutely right. My firmware got updated when I downloaded (the then still beta) Cura 2.6.44. My firmware is…

I’ll update to the latest now and see what happens.

Thanks a lot!