Cura top layers underextruding


I downloaded the latest version of Cura from the Lulzbot page and I’m absolutely loving it, but I seem to have a problem that I haven’t found an answer to on these forums or on other Cura forums.

When printing the top layers, they print fine, but just aren’t thick enough to create a solid layer and you can easily see the layer below it. (Sadly I don’t have a picture of the print right now)

The thing is, if I print the same object with Slic3r, the top layer prints completely fine. The filament diameter and the nozzle width are the same in both slicers, and in Cura I don’t see any options for extrusion width. Also, the bottom layer prints fine in Cura too.

Maybe it’s something trivial that I have overlooked, but I’m pretty sure it’s not mechanical because it happens just on Cura. Is there a setting that could fix it, do you have any idea what might be causing it?

I’m using the Lulzbot provided profiles on both Cura and Slic3r and other than this are working fine, I was printing with ABS when this happened, haven’t printed on Cura with PLA yet as I’m waiting a shipment.

Thanks in advance.

What profile are you using? What material? You can force a specific top-surface layer thickness, but you’ll have to change it in the configuration file. Before you do that, or switch to Full Settings, the above info may help, as would a picture of the print and the gcode file.

I had the same problem when using Cura on “another brand” of printer with one of my designs. Slic3r and my TAZ 3 printed fine, but the other printer left gaps in the top layer of the same design.

It looked like the last layer was never actually printed (as though there were an off-by-one error in counting remaining lines of code to excite).

I solved it by telling Cura to make the top layer thicker (3x the thickness of one extrusion layer instead of the default 2x). Worked fine…I would expect the same to work with Cura for my TAZ if it has the same problem (I’m on the road at the moment and can’t test until I’m home).