[Fixed] My Z endstop is acting up again

After a couple of weeks without printing, tonight I try to home the Z axis and it will only move up, not down.

The problem is the endstop getting stuck, it’s the third time now and this time I can’t “unstuck” it.

Last time I had purchased replacements at a local electronics store (almost identical endstops), but when I removed the rubber sheaths on the endstop’s contacts, I saw the leads were welded. Damn. Do they have too? I have no welding iron here, I actually never used one, I’ve never been an electronics kind of guy…

Norm, who’s gonna go to bed unhappy because he wasn’t able to print… :frowning:

Edit 2013-10-22: problem now fixed, but I have a new one…

So I just replaced my endstop and it still won’t work.

Either I don’t have a good enough contact (since I didn’t weld the leads), or the problem was not the endstop.

Damn. :imp:

Some more info: in Pronterface, if I move Z 1mm up, I can then move it 1mm down. But it won’t go further.

Have you tried homing the Z axis before doing this?
Most firmware seem to treat your bootup position as home until you home the machine, so you may not be able to move down at first, but up would work.

In pronterface, in the terminal, send M119 to get the endstop status. Then push on the endstop to activate it and send M119 again. The status should change when held down. Did you make sure to match the NO/NC (Normally open/normally closed) wiring? It may be different with your endstops.

Uh… Did you read my post carefully?

I’ve tried to home the Z axis like a billion time last night…

Among things I tried with no result:

  • closed Printrun, turned printer off, turn printer on, open Printrun, try to home
  • removed the switch (the screws are too big for the holes and made threads in the plastic casing), reput it
  • remove switch again, apply pressure on it with pliers until I heard a “click” sound, that’s what solved the problem last time
  • remove switch, cut the wires, replace with new switch
  • all the while hitting the f… Home Z button like crazy

Thanks Orias,

Endstop status before and while holding the Z endstop button is unchanged:

x_min:H x_max:H y_min:H y_max:H z_min:H z_max:H

X and Y are indeed homed, but Z is about at 80mm height from bed and won’t go down.

Well I have no idea which wire should be attached to which lead. The original switch leads are labeled “1, 3, 2” which is useless. The new one is labeled “C, NO, NC”.

I’m getting sick of this.

Well instead of creating a new topic, I should have continued the one I started before.


1013 suggested I check the wiring with a multimeter. I now have a multimeter, but I have no idea how to use it. As I said, I know zilch about electronics. :unamused:

Set the multimeter to resistance (omega symbol) and see what the resistance is of C to NO and C to NC. both with the button depressed and released. One should measure 00.00 while the other measures open. When you push the button the opposite should occur.

This video may help, at around 10 minutes in:


According to the technical diagrams for that black switch, it should match the pins of the blue one. THe middle pin is Normally Open, the outer pin is Normally Closed


You really do want to get a proper soldier joint or crimp fitting on that switch though. Just wrapping that type of wire around like that might mean you aren’t getting enough connectivity for the loop to know it is actually closed. The heat shrink tubing on the red lead may theoretically have compressed the wiring off of the switch entirely. There also could be a break somewhere in the wire, or a loose connection back in the RAMPS board.

Thanks for the replies.

The switches I bought are green (I bought three).

The Canal switch’s pins are labeled 1, 3, 2. How do I know which number match C, NO and NC?

FYI I attached the black wire to NC, and red wire to C. It is how the X endstop switch is wired, if I assume 1=C, 2=NC and 3=NO.

Rather than the Ω setting I used the continuity setting as shown in the video at 11:15.

When I connect the leads to C and NC, with button released, the multimeter beeps, and when the button is depressed, there’s no sound. For C to NO, it’s the opposite.

I got the same result for the new green switches and the original Canal switch placing the leads on the same pins.

I guess this means there was nothing wrong with the switch after all, and the trouble is somewhere else? :confused:

Yeah, now I regret cutting it off!!!

Yeah 1 is C, 2 is NO, 3 is NC. Sounds like your switch is fine, so it’s either your wireing harness back to the RAMPS board, or the RAMPS board itself. I’d check for a loose connection on the RAMPS board, or maybe a pin in the wrong spot? There also might be some fuses in there.

You may want to consider ordering a new RAMPS board, since the ones that shipped with the AO-100 don’t have the pins for adding an LCD in. A new RAMPS 1.4 board with all the pins runs about $20 on ebay and it wasn’t too traumatic to install.

If you don’t know how to soldier, you can always go the crimp fitting route. Go to your local hardware store, find one of these http://www.grainger.com/Grainger/wire-disconnects/wire-connectors/electrical/ecatalog/N-iq4?Ndr=basedimid10071&sst=subset that looks like it will fit your switch, strip the wire back on the wire harness, then use either a crimp tool or a really stout pair of pliers to crimp the fitting downl

Thanks, I brought my printer to work so a collegue who’s a lot more knowledgeable than I can help me out (he’s designed some of our steel workshop’s machinery, I figure it’ll go faster with him!) Before leaving work tonight I installed the required Arduino driver and Pronterface on a workstation, we’ll have a look at it tomorrow.

But before I left, I did try something: I plugged the X endstop wiring to the Z endstop pins on the RAMPS board. I’m happy to report that homing the Z did work, after a fashion… Only the right motor ran! :unamused: Before I could hit the X switch manually the whole X axis had come down on the right side quite a lot. I set it more or less straight again by carefully turning the motor manually…

So I’m hoping this means the wiring is at fault, and the board is fine…

One thing’s for sure, once I get this trouble fixed, I’m going to have to calibrate quite a few things, at least level the bed…

That would indicate wiring or pins to me as well. It could possibly be a fuse on the board I suppose. if I remember right, both Z motors drive off the same controller, so if one is working and the other isn’t that might indicate another wire issue. The z endstop isn’t in the same run as the z motor controls though, so if something did damage the wireing and it’s more than one wire, i’d suspect it is somewhere near the ramps board itself, maybe where the wires come out of the ramps case. Maybe that’s too tight, or pinched, or the clamp got installed through the wiring. I’d start looking there. Sounds like you are getting close to being operational again though


My colleague and I were able to locate the source of the problem. It was the black plastic housing for the wiring that was too loose. It was not making contact with the board’s pins. Removing it and plugging the wires directly works, I’ll keep it that way until I find a replacement part.

That’s a new problem :imp: , I’m creating a new topic here: http://forum.lulzbot.com/viewtopic.php?f=37&t=392

Thanks for your help guys.

This is something we’d see in the fleet from time to time where a pin works loose. Usually you can take a very small screwdriver and push the pin back in to place so you don’t have exposed metal/have to worry about shorting anything out. Make sure to check the pin housings for the motors as well.

Good to know, thanks.