Z won't move up or down, and Y won't move back

In a nutshell, I can move the Y-axis toward the front of the machine, but not back. The z-axis will not move up or down at all now. I’m using Cura 14.09, which has been working fine for months, barring that the machine detects z-home too low about 25% of the time, causing the nozzle to dig into my kapton tape or blue painter’s tape - but that hasn’t stopped anything from working before.

Here’s what led up to it, perhaps something will give someone a clue as to what might be wrong…

  1. ABS spool ran out of filament during a print job late last night. Remaining 2-3" of filament was still in the machine from the nozzle up to just below the gear that pushes filament down (nothing unusual there).
  2. I put a new spool of ABS on the spool holder and went to heat up the hot end to pull out the 2-3" piece. Cura was still up, so I set the temperature to 242° C and waited for it to go up. It moved up very, very slowly. Around 160° C, I noticed that while it usually goes up about 6-7° per jump, it was only going up 1° per jump this time. I was able to pull out the 2-3" piece with needle nose pliers fine.
  3. Temp was still going up far slower than usual, so I closed Cura, brought it back up, put in a small object, and brought the printer control up again. This time it griped that the printer was a max temp, though it didn’t show a high temp. I closed Cura and turned off the Lulzbot Mini. Restarted it after 15 seconds, waited a bit, and restarted Cura, then went back into printer control.
  4. Now it showed the correct temp, and I was able to set the temp. I kicked off a print job, but it didn’t move up/down or front/back during the homing process, and then started printing up in the air (the print head happened to be up near the top of the machine).
  5. I stopped the print job and restarted the PC and the Lulzbot Mini. Went back into Cura and the printer control. Tried to move the print head around, and discovered that it will no longer move up or down, and will not move back (but will move the print bed forward up until I hit the very front). I lifted the machine and cleaned out some garbage filament that had dropped in there. Found some stringy filament caught in the cable up by the front that controls the forward/back. I removed that, but it still won’t move back (again, it does move the print bed forward, though).

Seems strange for so many weird things to hit at once, almost as if it was a circuit board issue rather than a gear or cable.

I’ve unplugged the machine and will check every gear I can find to see if anything is amiss, but thought I’d check on the boards before running off on a wild hunt.

Any thoughts or suggestions?

kevinrau This is interesting and could be a few things, please contact our technical support team to help troubleshoot what’s happening here. Email <support@lulzbot.com> or call +1-970-377-1111. Thanks!

…Okay, that’s eerie. My Mini just failed in exactly the same way. Y axis pins itself on the forward endstop, Z axis pins itself against the top endstop, and any attempt to jog away produces a “Endstop hit” message. X axis is fine, hot end and bed appear to heat fine. All the endstops click properly when touched physically.

My money would be on a ground failure common to the Y- and Z- endstops, but I’d have to look at a circuit diagram to really tell.

I had only problems with my Z-axis, but is was exactly what you described in the quote above. I did a bunch of things at a time, not sure which fixed it or in which order:

  • Hit the reset switch
  • Cut power after reset was complete
  • Used the development version of Cura
  • Cleaned the endstop switches
  • Clicking the “Motors off” button and hitting print again <— I think this did the rick for me
  • Turing the Z-axis down just a little bit
  • Starting the calibration, then realizing its too complicated and aborting it

Okay, now my printer is stuck with the same problem again and nothing of the above helps. It seems to be a software-frimware interaction thing and very intermittent. I opened a task about this sticking axis problem and wrote support an email. My printer is under two weeks old and unmodified. I use Cura on Ubuntu 14.04.

The symptoms:

  • If left to itself, the printer prints in thin air at maximal Z
  • If I try to move the Z-axis in the control window, the print-head doesn’t move and just gives “< echo:endstops hit: Z:10.00”
  • I can move the Z-axis down manually (after turning the motors of). After that the printer can move up and down by controlling the Z-axis, until it hits the top position. Then it’s stuck again.
  • If I span Z, I can make the Z axis move just a tiny bit (see log).
  • Sometimes I see large negative values like “-168.0” for the Z coordinate.

This is really annoying, can you help me fix it?

Hello con-f-use,

Could I get you to send an email to our support team at support@lulzbot.com. When you send the email please send in a quick video of what you are experiencing. The video will give us a better idea on what we need to do to get you back up and printing.

Thank you,

I posted a video of the problem to code.alephobjects.com.

Have you ever seen the same issue when controlling the printer directly through Cura?

One more question. Have you ever cleaned the hot end with a wire brush before?

Yes, I clean my nozzel regularly (pun intended) with the wire brush but only when the heating element is off. Since the print head can still move downward once it gets unstuck and still detects an endstop then when touching the metal bit on the plate, I don’t think the lower endstop detection is broken. I also have the same issue when printing directly from Cura. Actually I only used a remote computer and OctoPrint after the issue was there.

Can I get you to go ahead and send an email to our support team with this information. We can get this done a lot easier there instead of on the forums.

Send to: support@lulzbot.com

Thank you,

As I said, I already did. David Hall is now “passing it to his supervisor”. Thanks for your effort!

Ah, got it. I just spoke to David and you are in good hands.

Thank you in any case. David thinks the endstop detection was fried, when I cleaned the nozzle and shorted out the heater to the thermistor. As I said, I don’t think so, because I can get the print head unstuck. Then it moves down fine and also detects the bottom endstop fine (touching the metal disks on the build plate, I get an endstop hit message).

Did this issue get resolved? I have the same problem.

I can move the head up and down using the control in Cura, but when it prints, it goes to the top and stays there.

Seconded. It sounds like I may have shorted mine out as well. What was the fix for this?

I shorted out mine too. I could have sent my printer in for repair, but I decided to go DIY because I had stuff to print. :wink: The solution to a fried endstop is to replace the Rambo Mini board – if you take the DIY route, you’ll lose the warranty on the Board but not the rest of the machine, which makes sense to me. I have a Mini Rambo v1.3a and it works great. This is an approximately $130 solution.

I have vague recollections of reading somewhere that you could wire up some endstops with an I2C interface to work around blown endstop controllers on a Board. But I just tried googling that and had no luck so this might be a wild goose chase. I’d like to rediscover it if it is true though, because then I could put my original board to work.

The main lesson here, if you are going to clean the nozzle with anything metal, heat it up, turn it off and unplug the machine first. It’s pretty easy to short out an endstop by shorting the thermistor or heater when cleaning with metal.

If you are lucky, it’s replacing the small grain of rice sized fuses on the board. At least thats what the TAZ has, I know the Mini uses a different board variant, but the fuses should be similar.

If you are unlucky, its replacing the fuses… And the board.

They are the automotive style fuses in the Mini.