Lulzbot mini won't connect to win 7 x64 Lulzbot Cura

Hi,

I just bought a new Lulzbot mini 3D printer. I installed Cura 19.08 in Windows 7 x64. When I connect the printer, I got the “CONTROL” button in Cura and can open the control panel. However, I’m unable to connect. When I press the “Connect” button, nothing happens. I don’t get any kind of error.

I can see the printer in the Device Manager. I checked the baudrate and tried several values (9600, 115200) and made sure it is set to the same value in the device manager and under machine settings in Cura. I also tried AUTO for both serial port and baudrate settings.

The printscreens below should clarify this.

Any help is appreciated.

Thanks in advance!


Device_manager.png
Port_settings.png

Usually I disable the serial port on the computer so Cura does not try and connect on it. It has near drove me crazy sometimes when I connect and get nothing. It will connect, give no errors, and that is all. Or just select the RAMBo Com port in the Serial port settings.

Thanks for the reply.

What do you mean by “select the RAMBo Com port in the Serial port settings”? You mean to select explicitly the COM port (in my case COM5) in stead of AUTO? I tried this without success.

Your settings look fine… It should work.

I think kmanley was suggesting you disable COM1 in the Win7 device manager, to make sure Cura doesn’t even see a COM1 and wouldn’t possibly for-any-reason try to use it. Alternately, explicitly set COM5 in Cura settings, which it sounds like you’ve already tried without success.

I know you’ve already tried some of this, but I would try these, in order:

  1. Explicitly set COM5 and 115400 in the CURA machine settings.
  2. Exit CURA, reboot machine, restart CURA and retry connection.
  3. Disable COM1 in device manager (per kmanley suggestion). Reboot again and retry CURA connection.
  4. Try a different USB cable – and preferably one less than 2m in length.

Are you using any other software on the machine that might interfere with COM/USB connection? Anything that polls COM ports could make the port appear “in use” and prevent CURA from connecting.

Yes that is what I was suggesting if you do not use it then just disable it so you do not have issues with anything trying to use the un-used serial port.

Thanks a lot for your suggestions!

I tried all of them without success. Disabled COM1, tried 4 different USB cables… The only thing I’m not sure of is if any other software polls the COM port. I will look further into this.

However, I installed Cura in Windows XP on an other machine and this works just fine. Printing the rocktopus now!

Could this possibly be a driver issue in Win 7?

Do you by chance have any Arduino software installed, like the IDE? I’ve noticed Taz acts a little strange occasionally if I’m doing some Arduino coding with Cura running. I’ve ruined a few prints so now I just try to print from the SD card if I’m using other software that uses the com ports and does polling.

No I have no Arduino software installed.

I don’t think so, unless it is some conflict with another driver on you system. Both my desktop and laptop are running Win7 x64, and no problems with CURA connecting on either of them.