Mini Bed Level Adjustment

Is it possible to make adjustments to the level of the Glass/PEI bed? I’ve had the mini for about 6 months now, and i’m starting to find that the left side, mostly towards the back, is about 1mm higher than the front right of the bed, even after levelling I get a good print in the middle, but a high extrusion in the front and a low extrusion in the back.

The auto-leveling is supposed to correct for that. Make sure you have the auto-leveling gcode at the beginning of every print (unless you really know what you are doing). The correction factors calculated from the auto-leveling are not stored in the EEPROM so they are lost every time the printer is power cycled.

I use auto levelling for every print, however, when i’m watching the printer start to extrude the first layer, watching the Z distance as the print moves around on that layer, it is hugely noticeable that there is a large z difference between the front and back.

Use a straight edge to see if the glass is flat. The distance from the top of the washer to the bed in all 4 corners should be the same. You might try loosening the 4 corners and making sure the bed is sitting flat on the corner pieces. At this point, a call or email to might be in order.

Thanks for the advice. Here’s the underside of a print I just completed, the top of the picture is the high side, where it came unstuck from the build plate.

By “after leveling” do you mean just the printer going through the autoleveling process? If so you may try verifying that your x-axis is sitting level using these instructions:

Check that the four washers are correctly tightened – I encountered problems on one of my minis with auto-leveling, and traced it back to one of the four washers being loose. This resulted in the bed pushing up on the washer, tilting it upwards – so the probe in that corner was too high.

The best way I’ve found is to pinch the PEI/glass bed to the aluminum plate beneath with one hand to compress the flexible mount, then just snug down the screw on the washer. You want it just tight enough that the washer is level against the glass/PEI surface and won’t rotate by hand – any tighter than that and you risk stripping the threads in the aluminum plate (which is not a good thing at all).

I’ve added checking the washers for tightness (i.e. check that they won’t rotate by hand) to my pre-print checklist – a little loctite might make that unnecessary, but I never seem to get around to that! :slight_smile:

Thanks for both replies, I will try both solutions and see how I get on

I am having exactly the same problem with my mini on the left rear side. I’ve observed some things which have direct bearing on what is happening. Sometimes the level is correct and other times it is not.

When going through the leveling process, the hotend will wipe and then go to the rear left position to begin the leveling process. When the issue with the bed leveling as experienced, the first point in the leveling process, that rear left side, the hotend will drive itself into the leveling plate.

Under normal circumstances, the hot end would tap the plate and then lift and find the plate slowly. In the case when things go wrong, the hot end drives itself down into the plate pushing it downward about a quarter of an inch. It’s as if it doesn’t even detect that it’s touching the plate. It will then lift and then strike the plate again as if it were trying to find the position. It will then move on to the second point, correctly locate it and then move on to the third position. More often than not, at the third position, it will touch the plate, lift, and then begin lowering but decides it can’t find the position even though it never gets there and does a rewipe. It then returns to the third position, completes it, and then moves to the fourth position performing that successfully.

After this process is all done, the leveling is not correct.

If I disconnect, power down, restart and reconnect the leveling process will successfully complete. I may get an additional or two additional prints before it starts messing up again. Sometimes I don’t even get an additional print before things go wrong once more and I have to repeat the process all over again.

In the end, if it’s successfully starts correctly with that first point, things will be just fine. If not, things are never correctly leveled. It is always very predictable that it tries to drive the hotend into the first leveling plate when things go wrong. If it taps the leveling plate and then correctly finds the first point, the leveling will be correct.

I would like to confirm that I am getting a similar error with the automatic bed leveling on my refurbished lulzbot mini.

  1. The issue is random. Sometime the problem occurs and sometimes it does not. I am brand new to 3d printing so I am still learning the cause and effects involved.

  2. Some times auto leveling appears to work. Other times when the extrude head hit the bed washer, it appears that the extruder does not detect the impact with the bed washer as a result, the extruder causes the print bed to deflect downward up to a 5mm.

  3. As a result it appears that when then print process starts, the extrude head can be touching the bed hard enough that no filament comes out of the hot end. ( the filament drive wheel is turning so, I believe that it is trying to push filament through the head. Other times, the extrude is a few mm above the print bed. Then the filament kind of falls to the printbed.

EDIT - It seems everything works correctly after I fully restart both the printer and Cura software. 4/4 test prints worked correctly. It seems I can create good prints while I continue to debug the larger issue. To be honest, I was getting grumpy that my new printer was failing on most of the job I tried over the last couple of days.

My working “newbie” hypothesis is that the hot end must be perfectly clean of plastic and any fiber that comes off the nozzle cleaning pad before performing the auto leveling procedure.

Any schmutz, even a single fiber, from the nozzle cleaning pad can prevent the nozzle from make good electrical contact with the metal washer. I think the system detects the sudden lack of electrical resistance between the nozzle and the washer to determine the exact point at which they contact.


Edit: That seems to be the issue for me. 3/4 of test runs failed to level properly in at least one corner without cleaning off the nozzle of cleaning pad fibers. 0/4 test runs fail to level properly if I used a tweezers to grab the lose fiber off the nozzle between the self cleaning process and the auto level.

My hypothesis is that turning off both the printer and cura and then turning them both back on gave the nozzle another minute or two to cool between prints. That was long enough to enable the nozzle to clean properly without manually intervening with the tweezers.

NOTE: All tests in this tread are done with a new spool of Polylite PLA from Lulzbot with all material setting left at their default in Cura.

I wanted to reach out and mention that it isn’t recommended to use anything metallic on your nozzle, if you do have to clean your nozzle between the wipe procedure and autoleveling it would be better to use a scotch brite pad or some other nonmetallic abrasive. The metal tweezers could potentially cause a short that could travel back to the RAMBo and damage your printer. Alternatively it could be that the wipe temperature needs to be adjusted slightly to allow for better cleaning.

Thanks, I hadn’t found the knob to adjust wiping temp yet. I’ll try turning it down until the fiber stops sticking to the nozzle. In the mean time I use a non-metallic tweezers.

The family is starting to think that the fumes are affecting my brain. A week with my new printer and all i have to show for it is a desktop covered in little black cubes :slight_smile: