New Mini Owner - How to ensure my Mini is Optimal?

Hey guys,

Proud owner of a Lulzbot Mini as of last week. Of course I couldn’t resist jumping right in and printing like crazy, but I’m finding that my prints aren’t always of great quality (part of that is ABS learning curve). Not bad, but definitely could be better. I want to make sure my Mini is in optimal working order to eliminate the printer itself as a source of any printing errors.

What do you guys recommend I do to make sure my Mini is in top working order? What calibrations should I check? And how often should I check them? Is there a checklist somewhere with instructions? Is there any special tools or equipment I should invest in?

Any help would be greatly appreciated.

I have the standard .5mm extruder head.


Hey! I just got mine last week as well! I’m working on building a box enclosure for it at the moment. I found I was having issues with dimensional accuracy with the PLA I have been printing.

I calibrated my e-steps value using this method. ( I ended up with a value of 800 and I checked a couple times )

I also check my filament diameter before printing and adjust that value as well. My first couple layers use to get squished but now everything is working great. The dimensional accuracy now is what I consider acceptable.

There is another method of fine tuning from what I have read with the flow rates. Something about printing a calibration piece using a single wall per layer structure and measuring the thickness of the layer. Then correlating that number with the number the slicer thinks it should be. This flow rate value appears to differ from different brands/colors/type of filaments for it to be correct.

Oh and if you have issues with the auto-leveling feature, this thread worth a read.

Randy8, thanks for the feedback!

A few questions. Excuse my ignorance…

What is an E-step? In that documentation you gave a link for it mentions to load Pronterface. What is that? And where do I find it?


Here is a great video for reference that I use. Part 1 is the E-step calibration Part 2 is that flow rate calibration I mentioned.

From my understanding the E-steps correlates to the number of microsteps of the motor to millimeters traveled. You can find what your current E-steps value is by loading up Pronterface and inputting certain commands.

If you are using the Lulzbot Cura program, Pronterface is the window that opens up when you want to print. The window where you can manually move the X,Y,Z and extrusion as well as setting the temperatures.

There is a command box to the right where you can input the M-codes and G-codes. Here is the list of the different commands.

To find out your current E-steps value, you want to enter “M501” (cap sensitive). This will bring up your current settings on your machine. The M92 line is where you want to look. On the M92 line you will have an “E833” value of some sort. That is your current E-steps (I think default is 833 from my notes).

So after you go through the calibration process and you determine your new E-steps value, the way you input this value is on the same command line. I usually will type the following:
M501 (to see the current values)
M92 E800 (Change 800 to whatever your value is)
M500 (Saves your changes)
M501 (Verify the changes stayed)
I would then run through the calibration process again and make sure you end up with the 20mm±1mm left over.

Oh and to get it to extrude 100mm of filament, without having to click that extrude 10mm button on pronterface, I input the following.

G1 E100 F30

The G1’s E value is the amount extruded in millimeters. The F value for G1 is the feed rate. I initially tried just G1 E100 and it spat out the filament so fast that I think the hot end couldn’t keep up. Therefore the extruder hob bolt slipped and gave me a wrong number at the end.

Once you’ve calibrated your esteps, print some calibration cubes and other test objects to verify the printers performance.
The new high performance co-polyester filaments like nGen and Inova-1800 also make for top printing performance.
Quality varies among ABS / HIPS / PLA. Older filament can absorb water, so be sure to rule out bad filaments as a cause of poor prints.

Check for play caused by wear in the igus bearings periodically. They’re inexpensive, and easy to replace.
Watch for wear on the small and large herringbone gears. Print replacements while your printer is fresh.

In Cura where is the standard E-Steps setting? If I go into “Machine Settings” it currently shows the “E-Steps per 1mm filament = 0”

Is there another place I should be looking?

When I type M501 in the command line, nothing happens.

Ahhh nevermind. You have to use the " "'s Duh! :smiley:

E-steps stand for “extruder steps” and is the number of steps the extruder motor needs to make to feed 1mm of filament into the extruder. There are similar settings for X, Y, and Z-steps, but you shouldn’t have to mess with those - they are pretty accurately set coming from the factory.

The e-steps setting under machine settings changes the setting in the software, over-riding the setting made in the printer’s firmware. (Leaving it at 0 in Machine Settings basically says “use the firmware value”). One advantage of setting it in the firmware is that the printer will use that value regardless of what computer you have controlling it.

As Randy8 mentioned, Pronterface is the window that comes up when you click “Control” after loading an item to print in Cura. It looks a little different than the interface shown in the extruder calibration instructions he linked. The beginning of that instruction has a link for Pronterface that is stand-alone, separate from Cura. This one odes look more like what is in the instructions. It also has a manual extrusion speed control, which Cura lacks (unless you want to type in the G-codes that Randy8 mentioned).

One thing you’ll find in other threads on the subject is that the extrusion speed of 100mm/min shown in the instructions is too fast. THe back-pressure in the extruder will cause the motor to miss steps, causing an inaccurate e-steps measurement. A speed of 30 or 40 works much better - and is close to the speed used when actually printing. The G-code which Randy8 provided handles this: G1 E100 F30. The E100 means “extrude 100mm”, the F30 means to do so at a rate of 30mm/min. Or you can download the Pronterface from the link and set the length and speed in that.

You don’t need the quotes, you do need to use a capital M.

Odd, because if I just put in the code nothing happened except for the code would appear in the flow, but if I used the quotations the command would work.

Hmmm… went back and did it again and it worked without the quotations this time. shurg

At any rate, I calibrated my e-steps (finally got my hands on a caliper) and my settings changed from 833 to 822. Does that much of a change seem normal?


Just wondering if there was a comprehensive list of the standard Gcodes that are used for the Mini?


Your number seems quite reasonable to me, but there are others on here with a lot more experience than I have. I ended up at 825, and probably could use some more fine tuning. When I tried to calibrate using the 100mm/min speed, I was getting somewhere around 860 or 865, and everything I printed was coming out over-extruded.

If you want to try to fine tune things further, try the method described here:
Triffid Hunter’s Calibration Guide

Here is the list of G-codes and M-codes that you could use.

Also I found out my calipers were measuring incorrectly. I ended up with a Esteps number of 822.

Thanks Randy,

I was hoping for more a beginners list. Like a specific generic list of gcodes that are commonly used by users to perform the more common functions. Anything like that that you know of?

To tell you the truth, once I got the school’s Mini dialed in, I haven’t needed G-codes. The only time I mess with them is when I’m trying to further fine-tune the settings.

Here’s a link to a g-code sequence posted by Rhoderman about re-setting the z-offset, which I found helpful.

My first layer was getting too “squished” onto the bed, and the parts were very hard to remove. These are both symptoms of having the nozzle too close to the print bed when printing the first layer (z-offset set too low). So I played around with a few different numbers and ended up raising the z-offset by 0.1mm.

That and the stuff needed for extruder calibration are about all I needed for starters. I’ll probably poke around more at some point, especially if I want to customize the start-up or end codes for printing.

Thanks John, I appreciate it.